Opening up the Traktor Z1, removing knobs

Discussion in 'KONTROL Z1' started by Vegard Haugen, Apr 24, 2018.

  1. Vegard Haugen

    Vegard Haugen New Member

    Messages:
    1
    Hi there!

    Me and some friends managed to spill some beer over my Z1 a while ago, we immediately turned it upside down and dried away all we could, but the A and B buttons are not working well, sometimes I have to push really hard to activate them, also the "clicking" sound when I push the button is gone.

    The warranty is over, so I have to fix this myself. I tried to open the device to remove any sticky stuff near those buttons, but I'm not able to open it up at all! Anyone here have any advice about how I can open the device? I assume I have to remove the knobs first? And how can I do that, I tried pulling as hard as I can with pliers, but I'm seriously worried that I'll destroy it somehow. I tried to put it on the floor and kept my foot on it to hold it down while pulling the knobs with pliers. It seems impossible. Any advice?

    Thanks!