1. Hi everyone,

    Apple just released Logic Pro 10.5 for MacOS 10.15. We found out that Massive X, Crush Pack, Mod Pack, Replika, and Replika XT will crash.

    Our teams are currently working on a fix, and we hope to have this out to you as soon as we can!

    Best wishes, 
    The NI Team

    Dismiss Notice

Oscillator noise in anything but exclusive

Discussion in 'REAKTOR' started by Voxxool, Mar 11, 2020.

  1. Voxxool

    Voxxool New Member

    Messages:
    8
    I recently got Reaktor 6 and was working through tutorials... and the oscillator was making some crazy noise until I went to WASAPI exclusive mode, when it sounded correct. However, this is annoying as I can't watch tutorial videos at the same time. I also have Asio4All and the same issue occurs with strange oscillator sound. Does anyone know of another driver that may solve this? Or whatever is running that is causing the noise?
     
  2. Paule

    Paule NI Product Owner

    Messages:
    6,097
    Do you try to rise up your latency?
    What kind of computer you're using? Mayhaps R6 is too large.
    What OS?
     
  3. Voxxool

    Voxxool New Member

    Messages:
    8
    Well it works fine in WASAPI exclusive mode... how do I raise latency? AMD Ryzen 5 3500U, 8gb ram, Windows 10
     
  4. colB

    colB NI Product Owner

    Messages:
    3,229
    I had an issue that sounds similar from your description - took a while to solve. For me it was 'exclusive mode' that caused the issue.

    Hit the windows button at the bottom left of the screen, and then the settings 'gear' icon.
    Select sound, then at the top right from 'Related Settings', click on sound control panel.
    From the playback tab choose the main output from your sound device (the one causing the issues)
    Hit the Properties button - now from the properties dialog, click the 'Advanced' tab.
    You should now see an section headed 'Exclusive Mode', for me Allow applications to take exclusive control of this device was selected. Deselecting it fixed the problem. Might help for you. So, assuming one/both are ticked, deselect both checkboxes and hit the 'apply' button
    Then, probably best to restart windows to see if it helped.

    I'm sure there is an easier route to this paricular dialog - maybe directly via control panel, but whatever, it would be worth a try - can't do any harm, and you can just switch it back if it doesn't help.

    Edit: there is an alternative route:
    In the search box next to the windows button, type 'control panel' hit 'open' from the results, now choose sound from the list, now go to line three in my previous instructions :)

    Good luck.
     
    • Like Like x 1
  5. Voxxool

    Voxxool New Member

    Messages:
    8
    I installed it on my laptop and the problem was solved... maybe I need an external card for m,y laptop.
     
  6. colB

    colB NI Product Owner

    Messages:
    3,229
    Did you try my suggestion?
    I had the same issue as you, now I can have Reaktor running using ASIO drivers, and at the same time, watch a web video - it all works.
    That will not happen if exclusive mode is on in windows control panel. The selection in Reaktor's audio and midi settings doesn't activate or deactivate exclusive mode. The fact that selecting Exclusive mode there works for you suggests to me that it is switched on in windows and needs to be switched off for non exclusive functionality.
     
  7. Voxxool

    Voxxool New Member

    Messages:
    8
    Actually your suggestion cut the audio from Reaktor when in WASAPI exclusive, and didn't get rid of the crazy beating sounds with WASAPI shared or ASIO... but on my desktop Reaktor and web videos get along just fine in shared mode, so this is what I'll use *shrugs*

    edit: and this is in WASAPI shared mode... may get ASIO4all later if there's issues