1. Please do not install macOS 10.15 Catalina yet, as Native Instruments software and hardware products are not supported under macOS 10.15 yet. For more info, please go HERE!
    Dismiss Notice

Bug Pad Color Indexed Mode does not match Controller Editor Manual definitions

Discussion in 'MASCHINE Area' started by will4laptop, Apr 29, 2018.

  1. will4laptop

    will4laptop NI Product Owner

    Messages:
    48
    NI Team,

    I have noticed that some of the MIDI commands for setting pad colors in Indexed Mode do not match their definitions on pages 335-336 of the Controller Editor v 2.2.0 manual.

    Issue: White color codes listed in the manual do not work.

    For example, I would expect 70 ({White, Bright}) to fully illuminate the pad. However, when this signal is sent, the pad is completely dark.

    By trial and error, I found that 76 is probably {White, Dim} and 78 is probably {White, Bright}.

    Q1: Is this a typo in the manual, or a bug with the Maschine hardware?
    Q2: Is this bug specific to Maschine Studio, or do the same codes produce the same White values across MK2, Mikro MK2, and MK3 as well?
    Q3: Will the colors these pads produce be changed to match the table in the manual?

    The reason this issue and these questions (Q3 in particular) are of importance to me is that I am the developer of a piece of software that programmatically sets the color and luminosity of Maschine's pads depending on the function they are controlling. In order to reduce MIDI traffic and to enable support for Maschine MK3, I am working on an update that moves from controlling the pads via HSB Mode to using the Index Mode.

    The following photo shows what color is produced on Maschine Studio when the indicated MIDI value is sent to the pad:
    maschine-studio-indexed-colors-white.jpg

    Relevant pages from the manual:
    manual-p335.jpg

    Please let me know if you have any questions and thank you very much for your time!

    I am using Controller Editor 2.2.0 R286 with Maschine Studio on macOS 10.13.4.
     
  2. D-One

    D-One Moderator Moderator

    Messages:
    6,844
    I would ask that via a support ticket. Devs/PM's rarely reply here.
     
  3. will4laptop

    will4laptop NI Product Owner

    Messages:
    48
    D-One thanks, it looks like you're right. As such, I just submitted a ticket. Cheers!
     
  4. themixtape

    themixtape NI Product Owner

    Messages:
    245
    I'm very curious about this as well, and am experiencing similar. I bought a Maschine Jam for use with Reaper and the Playtime (Ableton Session View) plugin. No matter how I configure the script, I can't get the LED Indexed color to show a FLASHING state (to indicate "almost stopping" or "almost playing"). All colors are fine.. just cannot get the Flashing State to work. This is possible with Maschine Jam, however... according to the manual. Any thoughts? Thanks, guys!
     
  5. D-One

    D-One Moderator Moderator

    Messages:
    6,844
    Flashing state doesn't work for me either, only dimmed and full bright.

    Also, "black" color does nothing, if there's White on the color Index then what the heck is a Black? How can light be black? -.-
    Controller Editor's manual being from 2017 probably doesn't help.
     
    Last edited: Oct 17, 2019 at 1:16 AM