1. Please do not install macOS 10.15 Catalina yet, as Native Instruments software and hardware products are not supported under macOS 10.15 yet. For more info, please go HERE!
    Dismiss Notice

Bug Perform FX automation crashes Maschine

Discussion in 'MASCHINE Area' started by sevdahbaby, Apr 23, 2018.

  1. sevdahbaby

    sevdahbaby New Member

    Messages:
    20
    This happened while I was practicing for a live routine and the bug is consistent. It is a little bit heavy project with couple of instances of Razor and a couple of instances of other plugins, Groups routed into other Groups, but all in all CPU on my Macbook Pro 15" mid-2014 is about 25%, nothing too heavy.
    Maschine crashes every time I start recording a sample to the audio module from my external source (Microphone input on Maschine MK3). At the start of the same bar I put my finger on Perform FX touch strip, doing a filter sweep on another group (not the one I am recording audio on). And that's the spot in the track in which Maschine crashes every time. I am also recording automation since I want to record this routine live, in one take. I tried to record a take without recording the automation and the crash didn't occur.

    This routine was working flawlessly in Maschine 2.7.4. so I believe this is a bug in 2.7.5.

    Cheers!
     
    • Informative Informative x 1
  2. Kaldosh

    Kaldosh NI Product Owner

    Messages:
    1,454
    Same here. Had much more crashes than usual with 2.7.5 during the week end even though there's is plenty of things this update does better.
    Like you processor 45/50% nothing extreme.. In my case it crashed 4/5 times during 7/8 hours of use
     
  3. sevdahbaby

    sevdahbaby New Member

    Messages:
    20
    Ok, I feel better now knowing I'm not the only one :) So it probably is a an update issue... I was thinking for all of the possible solutions, but I recreated the same conditions from the last session (when everything was working fine) but the crashes keep occurring.
    Maschine also crashed on the part in the track when I record automation of a group effect (a couple of groups routed to that group)... and does that pretty randomly...
     
  4. Kaldosh

    Kaldosh NI Product Owner

    Messages:
    1,454
    Happened to me too during recording automation. I must send my crash log to Chad@NI
     
  5. sevdahbaby

    sevdahbaby New Member

    Messages:
    20
    Cool, I'll do it too
     
    • Like Like x 1
  6. sevdahbaby

    sevdahbaby New Member

    Messages:
    20
    Btw, do you have his contact? Is there an official way to send a crash report?
     
  7. Kaldosh

    Kaldosh NI Product Owner

    Messages:
    1,454
    Just have to send it as a pm to Chad @ NI through the forum
     
    • Like Like x 1
  8. D-One

    D-One Moderator Moderator

    Messages:
    6,826
    So you're recording automation in Group #1 at the same time your recording to an Audio Module in Group #2?
     
  9. sevdahbaby

    sevdahbaby New Member

    Messages:
    20
    Yes. Also, this Group #1 has a lot of incoming signals from other groups, which maybe makes it a bit more demanding. But again, this was working ok a couple of days ago.
     
  10. D-One

    D-One Moderator Moderator

    Messages:
    6,826
    Then it's natural that it doesn't work. AFAIK You cant record Perform FX automation to Group #1 if you have Group #2 selected/active, Perform FX is designed to work only on the active Group. Are you sure this was working on the previous version?
     
  11. sevdahbaby

    sevdahbaby New Member

    Messages:
    20
    Yes, but I press Start on Sampling module a little bit before the next bar, so I have time to switch from Group #2 to Group #1 and start recording automation of the Perform FX. This routine worked. The only thing (that I am aware of) that changed in the setup is 2.7.5. update.

    Plus, Maschine is crashing, that's not natural ;)
     
  12. D-One

    D-One Moderator Moderator

    Messages:
    6,826
    Ohh I see. I just tried to reproduce it and it didn't crash for me.
    Does it also crash if you use another Audio Interface?
    Do you mind sharing the exact Record settings you are using? Record Mode, Monitor On/Off, etc...
     
  13. sevdahbaby

    sevdahbaby New Member

    Messages:
    20
    I haven't tried with another interface, since I wanted to use Maschine MK3's mic input for an outdoor recording of this routine.
    Record mode is Loop, Monitor is Off, but I am listening the mic through this sound's input. Target is Take.
    Also I have effects running on this sound. I know, it is all a bit CPU hungry, but again, it all worked flawlessly a couple of days ago.

    Also, at first I thought that maybe running on laptop battery and running Maschine without power supply could be the reason for instability, but unfortunately crashes happened on power supply (both for laptop and Maschine MK3) too.
     
  14. sevdahbaby

    sevdahbaby New Member

    Messages:
    20
    UPDATE:

    I tried recording automation of Perform FX on this problematic spot in my song and Maschine (2.7.6.) crashes EVERY TIME :/
    I've been preparing this routine for months now, and now I cannot shot my video :/

    Please help, NI
     
  15. Kaldosh

    Kaldosh NI Product Owner

    Messages:
    1,454
    I think begging is really what they want us to do :rolleyes:
     
  16. sevdahbaby

    sevdahbaby New Member

    Messages:
    20
    You're still having crashes when recording automation?
     
  17. Kaldosh

    Kaldosh NI Product Owner

    Messages:
    1,454
    My problems where very random and mostly during loading 3rd party plugins
    Other than that 2.7.5 was really great with CPU for my old machine.
    2.7.6 is not as good.
    If they want they really really can optimise CPU usage... But then you don't sell new computer.... Exactly because of that the world is full of too many poor, a few people way too rich and rubbishes everywhere in the ocean and landfills...
    All that mentality is not very eco friendly.

    But I couldnt have your setup to work on my computer so difficult to compare I am afraid
     
  18. sevdahbaby

    sevdahbaby New Member

    Messages:
    20
    Ok, I've narrowed the problem - recording automation is the main issue here. It was just a coincidence that I was starting the recording of an audio loop. Maschine crashes even if I just start recording the automation for Performance FX on that spot in the song

    Considering planned obsolescence, yes it is a big problem...
     
    • Like Like x 1
    • Informative Informative x 1
  19. D-One

    D-One Moderator Moderator

    Messages:
    6,826
    Does recording Perform FX automation always crashes Maschine for you or is it only in this specific project? I changed the thread tittle.
     
  20. sevdahbaby

    sevdahbaby New Member

    Messages:
    20
    I've checked another project and everything seems to be in order. I think it is only this specific project. And what's even wierder, if I start touching the strip a little bit before the start of the next section of the song, sometimes Maschine doesn't crash. But if I have to think about it during the performance... it's like walking on a thin line :D

    Update: it crashed on me right now, even though I started touching the strip before this problematic spot...