Pops and Clicks in Nuendo 4.2.2

Discussion in 'Technical Issues - KOMPLETE (Archive)' started by zvenx, Dec 18, 2008.

Thread Status:
Not open for further replies.
  1. zvenx

    zvenx NI Product Owner

    Messages:
    407
    Hi, is this happening to anyone else?

    Although I have had Reaktor for years I probably have used it four times...
    After downloading the free Kore Complitation and playing with it for awhile I decided to try back Reaktor (running 5.1.5) and now I notice that in my system.....if I start a new project and open one instance of Reaktor, although my cpu usage is low I am getting spiking, and my vst performance meter is shooting up to red and I am getting pops and clicks....even if I remove reaktor, it continues.....same thing happens if I open Kore player and play a patch that uses the reaktor.....I notice if I turn off Nuendo's Mutliprocessor it goes away. Although I am running at 64 samples buffer, even if I move it to 128 the problem continues....
    Is this happening to anyone else?


    thanks,
    rsp


    Nuendo 4.2.2 | Intel DP35DP : Intel Quad Core QX 6700 : 4GB RAM | Windows XP Pro SP3 | Lynx Two C | Midisport 4x4 & 2x2 | 2xUAD-1, UAD-2 Quad |
     
  2. york909

    york909 NI Product Owner

    Messages:
    31
    Same here in Cubase 4

    I'm suffering the same problem on Cubase 4 on my q6600 based quad core system. One workaround for me is to disable multiprocessing, reset vst system, then reenable the multiprocessing. Ok this is not ideal and I have to do this every time I load the project or reload reaktor.

    I've put in a support ticket to NI about this and also one to Steinberg.... I hope we hear something back on this.

    Fingers crossed this can be fixed since it makes browsing Kore presets a pain!

    John
    Cubase 4 / Komplete on Vista Q6600 System
     
  3. zvenx

    zvenx NI Product Owner

    Messages:
    407
  4. york909

    york909 NI Product Owner

    Messages:
    31
    Thanks for posting

    Very interesting discussion. Here, my Cubase priority does change to 8 from 13 when I load a Reaktor instance in Cubase (or via Kore in Cubase). However returning C4's priority to 13 does not stop the spiking.

    I reported this via the online reporting systems at Steinberg and NI - Steinberg did get back with some general optimisation tips (which don't make any difference for me in this very specific circumstance). I have to stress c4 works great for me with the rest of Komplete 5, Arturia, Waves, Sonnox, Altiverb etc. So it seems to me it is a problem specific to Reaktor use in C4/N4 and not a more general optimisation problem related to my hardware environment.

    This can only be stopped by disabling the multiprocessing, resetting the vst system, then reenabling the multiprocessing. Perhaps I should try to make a macro to do this for me :-(
     
  5. zvenx

    zvenx NI Product Owner

    Messages:
    407
    :)
     
  6. york909

    york909 NI Product Owner

    Messages:
    31
    More investigation

    I spent a long time trying to sort this out today, and find out what is happening and when! My machine is Q6600, dual boot XP Pro and Vista 32.

    I suffer spiking using C4 with R5 on Vista, but I can't replicate this spiking on XP. So basically I think there are two issues for my system:

    1 – Launching Reaktor under C4 causes Cubase priority to drop from 13->8 (affects XP and Vista, not a big problem for me and is easily reset in taskmanager).
    2 – Launching Reaktor under C4 on Vista only causes spiking which can be stopped by switching off/back on the multiprocessing.

    I'm deciding whether to go back to XP for the audio stuff - I've so many updates and authorisations to apply, cos I only kept Vista updated! After a shaky start I have grown to prefer Vista and get I get pretty much comparable performance on both.

    So far NI did not reply to my ticket - I'm wondering whether to resubmit.
     
  7. york909

    york909 NI Product Owner

    Messages:
    31
    Tried this in C5

    Glad to say NI did get back to me on my submission - but no resolution yet.

    Have received Cubase 5 today - so far, the same issue is still happening.

    John
     
  8. m127

    m127 NI Product Owner

    Messages:
    43
    Hey york, I am also one of the early reporters of this crappy problem.

    Do you happen to have any new information that I don't.


    I am sick and tired of the annotayance of having to tweak here and there every time I want to use Reaktor (happens sometimes with KORE too).
     
  9. york909

    york909 NI Product Owner

    Messages:
    31
    Not much more..... Still happening

    The problem is still happening here. Steinberg confirmed that some VSTi's including Reaktor cause spiking under MP- this was in their Cubase release notes (from memory, the notes for Cubase 5.01). From memory, sb Indicated that the issue needed an update from NI.

    The official Steinberg workaround shown on the release notes was to toggle the audio priority whenever the issue occurred. This does stop the spiking on my system and is less disruptive than switching off/on multiprocessing.

    At this point (some time ago now) I drew NI support's attention to Steinberg's statement.... NI said (paraphrasing) 'thanks but a date for a fix is not currently scheduled'.....

    I still find this problem hugely disruptive and I even considered changing to an i7 to see if it will help. I do think that we should have seen a fix by now for this problem (whether from sb or ni).... And I am disappointed to still be waiting!
    ---
    For me this happens whenever a kore preset that uses reaktor is selected. This happens a lot and limits the usefulness of Kore for me as a tool for browsing sounds!

    I wonder if it will be different in Windows 7? I am waiting for Delta 66 drivers so I can try. In the meantime I am avoiding Reaktor sounds and concentrating on Massive and Arturia synths.
     
  10. m127

    m127 NI Product Owner

    Messages:
    43
    Thanks York909.

    Since this only happens in Steinberg's hosts (Reaper, frootyloopys, Sonar, tested here), it is pretty obvious the issue is strongly related to how the Steinberg's "VST2.1 wraper" handles certain plugins.


    I sincerely am hoping this is not a typical irresponsible case of playing macho between NI and Stenburg.

    I can imagine: "Well, it's your host, you fix your wrapper", "Well, it's your plugin, you fix it to conform to our standards"....


    If it's not that, then it must be a huge technical issue in Reaktor's sw architecture, which is equally as bad news.



    What bothers me personally is the lack of official information on this matter, as to what the problem really is, as to what is being done about it, etc.

    I think the dynamic update status in the Maschine subforum is a great idea, and should be applied to the rest of their product line.


    This issue has been reported worldwide, and there are plenty of people affected. That is far from being an isolated, individual setup related problem... the standard "answer" from 99% of companies giving pseudo-support to sw.



    Patience? We have been very patient! I have been patient mainly because I don't particularly enjoy quarrelling with my favorite sw providers. BUT...come on! It's been more than 15 months since I first found out. Please!


    This "there is no date for a fix" statement is OK during the first one-two months if you will, but, nearly two years after the first reports, this is totally unacceptable, disrespectful, and even unprofessional.


    I don't know who told music sw developers that because these are just music production products, customers don't matter as much. I say this because there is a generalized similar behavior in the industry as a whole.


    Trust me, if this was a same degree malfunction in a car, this would have been fixed ages ago.


    But OK, they must be too busy working on Komplete's "diet"... Or should I say: inKomplete? How sad really.




    .
     
    Last edited: Oct 16, 2009
  11. york909

    york909 NI Product Owner

    Messages:
    31
    I could not agree more. The difficulty I have is the extent to which this bug undermines the Kore concept for me. I also feel like I wasted a huge amount of time reproducing the issue and communicating with sb and ni. The issue largely renders Reaktor a no-go area for me. This means I am disappointed with the investment I put into Kore + Komplete 5. I've avoided Maschine, Traktor upgrade and Komplete 6 'upgrade' as a direct result of this problem.

    Of course we as customers don't know if some improvement is needed on steinberg's side. But none if my other VSTis have this problem. Surely Cubase/nuendo +Reaktor on a C2Q system with an intel chipset cannot be that unusual....

    I incorrectly expected that this would be fixed quickly and I was happy to test the issue. Now, I have basically decided that i don't have time to nag sb/ni further about this problem any more. But I will take their response into account when considering purchasing decisions in the future!
     
  12. theoryzero

    theoryzero NI Product Owner

    Messages:
    234
    Do not bother with an i7. I have an i7 system since last fall and am having the same problem. So far the only workarounds have been to disable/enable multiprocessing. I also disabled hyperthreading which does seem to help the situation, but occasionally I will still get clicks and pops with Reaktor 5 + Cubase 5.01. Disruptive, but a workaround I suppose.

    I wasn't aware of this thread, so I had originally posted my findings here.
    http://www.native-instruments.com/forum/showthread.php?t=87054
     
  13. york909

    york909 NI Product Owner

    Messages:
    31
    Thanks for the heads-up re the i7.... And here is hoping (perhaps in vain) for a resolution soon. Better late than never.....
     
  14. york909

    york909 NI Product Owner

    Messages:
    31
    Anyone got any news on this one? Seems we are still waiting for a fix for this. I can't understand why more people are not complaining about this problem - surely quad core + Cubase/nuendo/reaktor must be a common configuration?

    I wonder if it only shows up on certain systems? Frustrating that both NI and Steinberg both recognise the problem but nothing has been done - despite Cubase 5 and Komplete 6 coming out!
     
  15. theoryzero

    theoryzero NI Product Owner

    Messages:
    234
    I received a reply from NI on my bug report at the end of October. It took them a few months to confirm the bug, but they said they have reproduced it and will issue a fix in a future version. I took this to mean Reaktor 6. I have since upgraded from Vista 64 to Win 7 64 and still experience the same issue. Their full reply below:

     
  16. york909

    york909 NI Product Owner

    Messages:
    31
    Still waiting....... I fail to understand why this can't be fixed with Hotfix for affected users (including patching the Reaktor engine in Kore 2)..... Surely after more than 1 year and a major paid upgrade of Komplete that's not too much to ask.
     
  17. deadfly

    deadfly NI Product Owner

    Messages:
    42
    I'm having this problem as well. I've been doing a few experiments to find the cause and I'm pretty sure it's something to do with the quad core CPU. Is it worth sending a bug report about it, or shall I just post the details here?
     
  18. Neverender

    Neverender New Member

    Messages:
    7
    Hey. First post.

    I'm a new owner of Komplete 6 and running on a Q6600, and of course, this bug rendered my host (Cubase Studio 5) unusable after loading an instance of Reaktor. Boosting Cubase's "audio priority" reduced the number of underruns, but did not by any means make it usable. In my experience I had to both readjust the priority of the Cubase process as well as toggle its affinity mask in order to restore proper function.

    Suffice it to say, I got tired of doing this very quickly.

    Over the weekend, I downloaded the VST SDK and tried to learn my way around. I made a small wrapper DLL that automates the task of fixing Cubase's priority after loading Reaktor. You rename the Reaktor 5 VST DLLs, copy the wrapper DLL in their place, and Reaktor behaves exactly like it used to - except Cubase stays at the right priority.

    I've been using it over the past couple of days, and it seems solid on my computer, so if anybody else wants to try it out, maybe I could upload it (with source code even).

    Fine print: No guarantees, cannot be held responsible if it causes your computer to catch fire, side effects include dry mouth, insomnia, ...
    (But seriously, it should work fine. It's fairly simple.)
     
  19. york909

    york909 NI Product Owner

    Messages:
    31
    Welcome, Neverender - and thanks for your post. Also on a Q6600 here - I like your ingenious solution!

    I get particularly mad at how this problem really affects the convenience of Kore for patch-browsing. I'm not sure if a similar approach would work on Kore - since Kore uses an internal Reaktor engine AFAIK (not the VST dll), so I am not clear whether a VST Kore wrapper would help.

    But your simple approach has made me wonder again why it has not been possible to issue a Hotfix for this during the last 17 months - NI, are you listening?
    ---
    And deadfly - NI have confirmed this issue, but we have waited a long time for a fix. I think reporting it as an issue directly can't hurt, because it will hopefully move this up the priority pile!
     
  20. Neverender

    Neverender New Member

    Messages:
    7
    Yeah, I thought about the Kore factor as well. If I can, I'll download some kind of Kore Player freebie that exhibits this bug, and look into the possibility of finding an appropriate hook there as well. Maybe something like the UI update for the contents of the FXB/FXP preset dropdown, or a change in the available automatable parameters...
     
Thread Status:
Not open for further replies.