We launched a new online community and this space is now closed. This community will be available as a read-only resources until further notice.

Pops and clicks on a Windows 7 64 bit system

Discussion in 'NI Audio Interfaces' started by Gary_W, Jan 13, 2012.

  1. Gary_W

    Gary_W NI Product Owner

    Hi Folks,

    Just raised a support ticket with NI and thought I'd post on here too..... Any help gratefully received as this is NOT good! System is Win 7 64 bit, I have made sure that all power throttling is turned off.


    I have just bought Komplete Audio 6 and am having bad problems with clicks and pops on playback.

    Any WAV file that is played back via Windows Media player has the problem, as does anything I play back in Reaper. It's fine mostly, but you get random clicks and pops and this is making it unusable.

    It does this via the main outputs AND via the headphone socket, so it's nothing to do with balanced cables etc. There are no input cables connected, nor is midi connected so we can exclude that.

    So far I have tried:-

    1. A different USB cable
    2. Changing USB ports
    3. Setting the buffers to the maximum, and even at 27ms of latency it still does it, so it's not buffers
    4. I have updated firmware to version 37 (it was on V.29). There is no difference.
    5. I have been working with the latest drivers, but I've now tried rolling back to the 2.99 that shipped with it. No difference

    I would appreciate your help please - when it works it's brilliant but this issue is making the product completely unfit for use. If you are unable to help I will have no choice but to return the unit for a refund.

    There we have it, folks. Can anyone help?
  2. mantismu

    mantismu New Member

    I'm having exactly the same problem and am considering returning mine.

    Windows 7 64 bit with latest firmware and drivers.

    I've tried all the same steps, although changing USB ports eliminates the problem for a short while it soon returns.

    I've seen a suggestion to try a USB powered hub to eliminate the pops although I don't see why this interface would need it while every other interface I've used on this machine is fine.
  3. pawcut

    pawcut NI Product Owner

    did u unplug all other usb devices?
    i had that when my ext harddrive was plugged in and it dissapeared when i unplugged it !
  4. Iceman_jkh

    Iceman_jkh Forum Member

    Another thing you can try, is to disable K-Audio-6 as an audio interface in windows, under "Manage Audio Devices". Then simply reenable it.

    I often get bouts of corrupt audio (for no apparent reason), and this trick fixes it. Granted, it shouldn't happen in the first place :(
  5. Gary_W

    Gary_W NI Product Owner

    Thanks for your replies, folks.

    I've still had no word from NI regarding the ticket I put in!

    Since posting, I've managed to improve it a lot - I downloaded the DPC Latency Monitor program and it was reporting a very occasional spike into the Amber section, hence causing my USB interface to be rather unhappy. All of my drivers were up to date according to the main part of the ASUS website, but I then found a newer USB driver for my ASUS mainboard. It wasn't on the ASUS website in a sensible place, hence me missing it before! Anyway, that has cheered matters up a lot. I no longer get DPC Latency spikes and the instances of popping and clicking have gone to a large extent......

    However, it's still not fixed.

    Reaper seems fine (he says, touching wood). But if I do simple things such as playing a Youtube video or playing a track from Soundcloud or a similar web sound it will tend to not like it and start with its clicking and popping nonsense.

    Very annoying. As is the silence from Tech Support. 12 days ago I filed the ticket on this and, apart from the autoreply, no contact.
  6. Hardcare

    Hardcare New Member

    Hi, I'm using the Audio Kontrol 1 hardware audio card and I also experienced a lot of crackle and pop in my audio, no matter what I was doing.

    I've found a workaround for this that works every time for me, at least:
    Doing a Windows restart without shutting down fixes these sound issues every single time. I start my computer up, log in and choose Restart Windows in the shutdown menu. When the computer has rebooted, I have no problems whatsoever until next time I start my computer up cold.
  7. Gary_W

    Gary_W NI Product Owner

    Thanks for that, Hardcore.

    I'm starting to think it's a 'windows driver with the Komplete' as opposed to anything else - When Reaper is controlling it it seems to be OK. It's just when 'normal' programs are using it as a regular soundcard, it's drivers seem really flakey!

    Well that's the theory I'm working on. What else can I do apart from come up with theories and try my best until I get some official help?


    I'm over here? Remember? The guy that raised a support ticket 2 weeks ago?

    Never mind......
  8. faster

    faster NI Product Owner

    Is your PC self built or brand name? If self built, post specs?
    Do you have mo-bo's sound card disabled? You have to!
    I have AK-1, KA-6 is a bigger version, and I, and thousands of others have no problem, I can have several standalones running, like Krypt and Metaphysical EI2XT, windows/VLC player and u tube and all sounds good...no glitches, AK-1- 256 samples and 2ms latency.
    W-7 ultimate, 64bit, 6GB RAM.

    Have you used black vipers tweak and cut most of the useless services running in the background?

    It is probably something that can be tweaked. If the KA-6 works, it's your PC probably?
  9. Gary_W

    Gary_W NI Product Owner

    Hi Faster,

    I have little doubt that it will be 'something' with my PC - but I have to say that Komplete 6 seems a lot more 'picky' than anything else I've used over the last few years! No issues with previous soundcards, a Firewire sound interface, Maschine, Kore, you name it. This thing? D'oh!

    I haven't tried the tweaks in the link you posted - thanks for those and I'll give them a try. In the meantime, specs for this system (which is a self build of just over a year old and otherwise working OK) are:-

    Window 7 with SP1.
    Intel Core i7 950 at 3.07G (not overclocked)
    Asus P6X58D-E Motherboard
    12 Gig DDR3 memory
    NVidea GTX260 graphics card
    Logitech Mouse
    Z-Board keyboard

    The problems occour with nothing else attached to the system..... You can work for anywhere between 10 minutes and a couple of hours before the pops and clicks arrive but when they show up they are there until you reboot.

    I have found a few older drivers in there - the ASUS website is a bit pants TBH! I've now updated the USB driver twice (once to the one hidden in an entirely inappropriate section of the ASUS website and once to the actual latest one). I'm also bang up to date with the Komplete 6 driver and firmware and the graphics card is running the latest.

    Another thing I've done is to install DPC Latency Checker - I have nothing going on to worry about. My DPC latency is betwen 120 and 150 microseconds, so well under the threshold for giving issues.

    I have also ensured that the onboard sound is turned off in the bios. And I've turned off the power saving options for USB and the processor in BIOS. And in Windows 7 for good measure.

    And I also went out and spent £15 on a powered USB hub just in case Komplete was taking more juice than my PC could provide.

    All of the above has made incremental improvements but nothing has got rid of the issues completely.

    I today flashed my bios to the latest level. No pops and clicks so far, but it'll be a day or two before I trust it as if this has fixed it I'll be both impressed and amazed :) Really hope it has but I dare not hope! In the meantime, any thoughts appreciated and, if you or anyone else needs further detail please let me know ;)

  10. Gary_W

    Gary_W NI Product Owner

    Still there.... Youtube drives this thing nutty and it then starts with the pops and clicks!

    Every time I think I've fixed it, it comes back again!

    I'll now start looking at the tweaks link from Faster to see if any of them get rid of it - very, very annoying to have to chuck this amount of effort at the only device that seems to not get along with my PC!
    This 'fix' does indeed work on mine too!

    The interface works fine for anywhere between 10 minutes and a couple of hours. Then the pops and clicks start. Once they start, they don't stop.

    Restarting the interface fixes it.

    Anyone who can discover 'why' please let me know :) Re-starting is not what I need....
  11. faster

    faster NI Product Owner

    Hey Gary,
    sorry to hear you have still problems...
    Your specs are great, I would overclock between 2-5%, in BIOS, manual overclock, it does not put a stress on CPU, just a bit more speed.

    After BIOS update, did you go back to BIOS and disable Audio and "cool and quiet"?

    Can you do a little test, like open Reaktor with something sequenced and let it play,
    Then open something else from Komplete and let it play and some other standalone, like Maschine. If these things play without a problem, it's great.

    Forget the utube, that is not a "standard" of audio. I suspect that Utube plays through your main board audio...VLC works?

    Do the viper tweaks, only do those that are listed in his chart, because some may be parts of your software.
    When you boot, how many processes do you have running? (task manager)
    Do you have/use Antivirus?

  12. DJ Hellfire

    DJ Hellfire Forum Member

    Gary, I see that you have 12GB Ram. But are you using the 64-bit version of the app? The 32-bit version will only allow you to use up to 3-3.5GB ram which can cause your issue with a heavy amount of instruments loaded, even at a high buffer.
  13. Iceman_jkh

    Iceman_jkh Forum Member

    I'm sorry, but in my opinion, you cannot excuse the lack of YouTube
    compatibility. (I also have issues with Youtube seeming to trigger the
    corruption, but its not always youtube.)

    The KA6 is an expensive/professional audio interface that should simply
    work with ALL Windows and Mac audio streams. Also, the fact that my
    'fix' worked, means that this issue is almost certainly a
    software/driver issue - not hardware.

    I'm not a programmer/driver guru but I believe that disabling-reenabling
    the device closes the corrupt stream (possibly caused by a memory leak)
    and then creates a new (and un-corrupt) instance of the stream when the
    device is reenabled. Therefore effectively fixing the issue (or rather
    is a temporary workaround).

    In my opinion, a better windows audio device driver/NI Komplete Audio 6
    driver would be the solution. Given that thousands of other audio
    devices (all types of on board audio, other manufacturer's audio
    interfaces) seem to work fine (with all audio including youtube) on many
    other PC configurations of Win7), I suggest that the issue lies with the
    NI driver itself.

    On a side note, I too have Win7-64bit+12GB RAM and have noticed
    occasional issues with my PC (and occasionally in the PC game
    "Battlefield 3"). Some other Battlefield 3 players, also with
    Win7-64+12GB config, have reported similar issues - ie: glitches with
    the game.

    Perhaps you could try reducing your RAM to 8GB [remove a stick/pair]
    (yes, I know that's a really weird suggestion), but perhaps it is a
    memory leak with Win7-64 that Microsoft are unaware of, and it manifests
    as this audio glitch?

  14. andyfitts

    andyfitts New Member

    I am having the same problem with my Mac.
    It's super frustrating.
    Granted, my specs are on the slow end of things, but I think it's something with the Komplete Audio 6, not my computer. It has all of the symptoms you are talking about. I will be listening back, whether in ableton live, garage band, itunes, or an audio file in the finder window, and suddenly the audio begins glitching out with click and pops to the point where it's so fuzzed out that I can't even hear the music anymore.
  15. Gary_W

    Gary_W NI Product Owner

    Thanks for the replies, all. I'll try all the suggestions over the next couple of days as life allows ;)

    Andyfitts - I'm fortunate that mine doesn't go as badly as yours - I get the regular pops when it happens but the audio is still the prevalent thing.... Hope you too manage to sort it!

    Iceman - I agree. I had a Firewire interface before this which was a few years old. In terms of quality when it's working, the Komplete is a great product but so far it's been no fun at all and felt like a real step backwards. It's an audio interface and should certainly cope with any sound you care to chuck at it!

    DJ Hellfire - I'm using the 64 bit versions of Reaper and Maschine. These SEEM to be OK but not 100% confident in it any more! It appears to be non-asio operations that upset the card till you reboot it. In my Windows XP days (and before!) I always ran a seperate partition for recording. These days, I don't. With my old interface that was not an issue - it's a meaty PC and even though it's a multi-use PC I keep it pretty clean. Why could a 4/5 year old interface cope with this and a brand new one not?

    Faster - thanks for the advice. I'll avoid overclocking at the moment (quite agree that it's more than capable, but if you look at the free resources I'm never stretching the thing at all so I'll leave it alone at the moment).

    Reaper + Maschine together seem to be fine - I can play audio in either without upsetting it. So far! But it is the web based stuff that gets upset. This should not really be an issue - I have onboard sound disabled on the MOBO, there is no other soundcard in play and Windows is being told to use the card for audio....

    I will go through the tweeks over the next few days. I do have antivirus running. I'll disable to fault find just in case, but the fault seems to turn up with using a web-based sound program as opposed to the virus checker 'doing something'. Quite understand that I can't see all of its evil little ways though!

    Thanks again

  16. Gary_W

    Gary_W NI Product Owner

    NI Support have been in touch with me and suggested 3 things - thought I'd share. The first two definately don't work for me but may benefit some of you :)

    1. Ensure all inputs and outputs are set to the same sample rate, otherwise it can glitch. (on mine, those that are enabled are at 44.1 so no joy for me)

    2. There is one known issue that affects all USB 2 interfaces on all Windows Vista &
    Win7 machines:

    There is high CPU usage when using a USB audio device connected to a USB 2.0 EHCI host controller:

    (again, no joy for me. When I downloaded, Windows 7 64 SP1 told me I didn't need the fix!)

    3. Suggested that I up my USB buffer to 4mS. I've done so for the sake of fault finding and will see how it goes (it's intermittent so may take a while before I know if it's fixed it or not). But I don't consider this an actual fix as it's giving me nearly 12mS of latency. That's going back to Creative Labs days!

    I've written back to explain that 1 and 2 didn't work and that 3 might do (time will tell) but it's not a 'fix' due to the high latency involved.

    I'll keep trying and eventually we'll get there. With a bit of luck!

    Edit - Despite having a 4mS USB buffer, I still get the clicks. So it's not that either!
    Last edited: Feb 2, 2012
  17. Gary_W

    Gary_W NI Product Owner

    OK, a few days on. Problem still there.

    It is clearly NOT an ASIO problem (Reaper is working fine). It is any WASAPI program (so that's web audio content, iTunes, Media Player etc).

    Once the glitching starts, any WASAPI program still gives glitches. Whilst in the glitch state, Reaper still works perfectly via ASIO.

    Disabling and resetting the NI driver fixes the problem 100% of the time. Then it recurrs at some random point down the road and there we go again.

    I have done everything in this article http://www.native-instruments.com/knowledge/questions/847/Windows+7+Tuning+Tips+for+audio+processing

    I am also running with no virus checker for test purposes and have kicked out just about everything.

    I've been through hours worth of tweaks. No change.

    When I'm in a glitch state my CPU useage is still below 10% as is memory useage.

    Something is upsetting the NI driver file here - I'm willing to be proved wrong but I can't see how it can be anything but the driver now..... If it was, why would resetting it fix it if some other fault state was happening with my PC? Others are having the problems too......

    I am now at the end with this. It gets the weekend and then, on Monday, it gets exchanged for something that will actually work for me. I am just so sick of trying to fault find as opposed to actually making / listening to music so whatever the problem is caused by, it's gone if the fix does not fall into my lap now as I've had enough of trying this hard to do something that even a 2496 would do!

  18. Iceman_jkh

    Iceman_jkh Forum Member

    I'm sorry to hear about your experience Gary.

    You've probably done this a few times - I haven't reread the thread in a while - but perhaps try uninstalling the drivers, using driver cleaner or the like, and then reinstalling the drivers?
  19. Gary_W

    Gary_W NI Product Owner

    Thanks Iceman, appreciate your thoughts.

    Unfortunately, I've pulled the plug and have returned this to the shop I got it from as 'faulty'. They are shipping me a new interface (different brand).

    Towards the end, the clicking got worse and I got the slowed down audio and glitches that others have reported with this interface. It became more than 'annoying' - it bypassed that and went to 'unusable'. I have no idea how this happened as no other changes / programs or anything have been installed on the PC and everything else appears to be working perfectly. When glitching, CPU and memory are normal and no latency spikes reported..... As weird as a weird thing on national weird day :(

    Tech support here tried to help but the last email they sent me was basically a link to the on-line troubleshooting guide which I politely explained that I'd already gone through several times before. I told them this on Thursday / Friday last week and asked for further guidance. I've yet to hear back, but as the previous email from them gave the indication that they really didn't know what it could be if I'd done all the things I've done didn't fix it then I felt I had no choice but to bail on the product. A regretable decision but what else can I do? I am unable to fix it, tech support cannot fix it and you guys plus the help of another excellent forum have not been able to find the gremlin here. We've all tried hard, but on this occasion it just wasn't enough....

    For those of you that it's working well for - I'm glad for you. It's a great little interface and I'm sure you'll get years of use.

    For those having issues, I wish you better luck than I've had. It hasn't been a good experience..... It has taken up an awful lot of my time and given me a plenty of frustration. Many thanks for those on the thread who have made helpful suggestions - it is appreciated.

  20. chrome86

    chrome86 New Member

    Ka6 gone!

    I can't believe this.....

    I've posted twice on this forum in great detail about my issues with my Komplete Audio 6. And the moderators haven't even published them (would be some miracle if this post is even visible).

    Anyway, my KA6 is gone. After one month of no support from NI and trying all Gary_W's suggestions (I hope things work out for you mate after all the effort you've put in, much appreciated), i've RETURNED THE DAMN THING AND GOT A FOCUSRITE SAFFIRE 6 USB AUDIO INTERFACE!

    All I can say is WOW! Zero latency, no pops or clicks or ground looping issues.