1. Please do not install macOS 10.15 Catalina yet, as Native Instruments software and hardware products are not supported under macOS 10.15 yet. For more info, please go HERE!
    Dismiss Notice

Possible to install 3.0.2?

Discussion in 'TRAKTOR PRO / TRAKTOR SCRATCH PRO' started by boysteve, Feb 22, 2019.

  1. boysteve

    boysteve NI Product Owner

    Messages:
    2,335
    I'm holding off on 3.1 because there seem to be a lot of problems. I want to install 3.0.2, but it's no longer offered on Native Access or my NI Account page. And, what a surprise, it seems almost impossible to contact NI directly now! Does anyone know how to legit install this version? Many thanks in advance.
     
  2. Matt @ NI

    Matt @ NI Support Team NI Team

    Messages:
    611