1. Hi everyone,

    Apple just released Logic Pro 10.5 for MacOS 10.15. We found out that Crush Pack, Mod Pack, Replika, and Replika XT will crash.

    Our teams are currently working on a fix, and we hope to have this out to you as soon as we can!

    Best wishes, 
    The NI Team

    Dismiss Notice

Rant: Very frustrated with Traktor Scratch!

Discussion in 'Technical Issues' started by startupthetraktor, Apr 18, 2009.

Thread Status:
Not open for further replies.
  1. startupthetraktor

    startupthetraktor New Member

    Messages:
    3
    Using a store bought Traktor Scratch for some time now and I must say that I am starting to like the system less and less the more I use it.

    I find the documentation vague and sparse on actual technique namely optimizing latency settings etc. I am having real trouble with the beatgrids and find that they are not reliable or easy to set up. Tracks still drift on me and imputing my thousands of tracks has become a nightmare.

    I am also having a hell of a time getting the tables to calibrate without a channel missing message. I have tried 6 different 1200's and still get the channel missing message on and off, here and there and at random while using them. Sometimes it works fine, sometimes it doesn't.

    Overall I must say I am starting to feel very disappointed with Traktor and all the tinkering that needs to be done isnt worth it.

    Anyone else feel the same way? Can someone please blow some sunshine my way about this product?

    :S
     
  2. lethal_pizzle

    lethal_pizzle NI Product Owner

    Messages:
    10,601
    The documentation is vague and sparse, you are right.

    I find beatgrids very easy to set up. Check out djtechtool's vidoes on youtube. They have a tutorial for setting beatgrids on Traktor 3 that is applicable. Tracks with a varying tempo cannot be accurately beatgridded.

    Latency depends on your processing power. Just use the lowest you can without dropouts.

    The channel missing thing is a bit worrying. I don't get that. Sounds like a dodgy connection is dropping a channel. It could be your wires? If not your wires it could be your Audio8 has a fault?

    I use TS to gig out and am very happy with it. I've had TSPro for 6 months now, but still use TS to gig out with as I find it very stable.
     
  3. startupthetraktor

    startupthetraktor New Member

    Messages:
    3
    Thanks Lethal. I am going to check out those videos.
    ---
    Still having trouble. I cant even get the hotkey template from the video makers website to save and he doesn't show how to do it without it.

    Setting up Traktor to work properly so far has been an awful experience.
    ---
    The process of setting up a Beatgrid is awful and complicated. I have been trying for a while. I am starting to regret getting Traktor and will probably end up back with playing CD's if I cant make a breakthrough soon.
     
  4. djquartz

    djquartz NI Product Owner

    Messages:
    5,321
    Check your headshell, if you tried 6 turntables and had the same problem there is obviously a common denominator.

    Did you swap them around to see if the problem moved to the other sides.

    As for beatgridding, there is tutorials and lots of information on this very forum regarding the matter.

    Some of the information may be sparse but then again would ANYBODY read a 500 page manual?

    I highly doubt it because no one reads the manual as is now.

    If you need help ask and you will receive.
     
  5. DJ Freshfluke

    DJ Freshfluke Traktor Mod Moderator

    Messages:
    26,779
    lol, you're oh so right!

    btw, if 6 turntables have the same issue, the culprit may be sth else, the headshell, a cable, even the audio 8 itself. swap every part one by one to find out.
     
  6. strrog

    strrog Forum Member

    Messages:
    29
    No logic....

    If i have problem, where can i change the cables and i4 audio card? FREE OF CHARGE OF COURSE........:(
     
  7. Karlos Santos

    Karlos Santos Rocket Man Moderator

    Messages:
    12,056
    I dont understand, you say "If" .
    Have you got faulty cables and a faulty Audio 4 or not ?

    If they are still within the Warranty Period you should contact Technical Support to have them exchanged.

    http://www.native-instruments.com/index.php?id=suppform&L=1
     
  8. strrog

    strrog Forum Member

    Messages:
    29
    Answ

    Hi,

    The tips on this forum sometimes suggest that you test with other hardware. If i just bought the product where can i get optional hardware to test my set up if i have problems.
     
  9. Karlos Santos

    Karlos Santos Rocket Man Moderator

    Messages:
    12,056
    Still not with ?
    Have you got problems with the Hardware?
     
  10. lethal_pizzle

    lethal_pizzle NI Product Owner

    Messages:
    10,601
    You can test the cables by swapping them over to see if the problem switches with the 'faulty' cable.
    You can test the channels on the audio8 by swapping your decks over and see if the problem switches to the other deck.
     
Thread Status:
Not open for further replies.