Reaktor 5.5.1 & Cubase 5.5.1

Discussion in 'REAKTOR' started by Insectfish, Oct 10, 2010.

  1. Insectfish

    Insectfish New Member

    Messages:
    14
    Bought Reaktor yesterday (download) and it's causing nothing but problems in Cubase 5.5.1

    ASIO driver (MAudio) keeps flipping out and everytime I try to open a patch it crashes the computer

    Windows 7 (64bit) 8 gig RAM, Quad Core

    Thoughts would be very much appreciated
     
  2. kb123

    kb123 NI Product Owner

    Messages:
    1,253
    you need to run it as a 32bit vst, probably best to use jbridge
     
  3. Insectfish

    Insectfish New Member

    Messages:
    14
    Thank you for you reply.

    I don't remember seeing an option to install at 32bit.....but I'm guessing that's what the jbridge does? I do have Cubase running at 32bit...as I had problems with other plugins
    ---
    Just re-installed it again

    As a stand-alone unit it's working fine....whap it in Cubase, frraapp!
     
  4. Bill Lumberg

    Bill Lumberg Forum Member

    Messages:
    21
    after you open reaktor in cubase just go to Devices-Device Setup-VST Audio System and switch off the multiprocessing. this should fix the problem. then you can go back and switch the multiprocessing back without any further problems.
     
  5. Insectfish

    Insectfish New Member

    Messages:
    14
    Well, I'm not sure why that should work Bill....but it certainly seems a little more stable after doing so :) Also after reading a few more posts on here doing the same with 'Audio Priority' Normal/Boost seems to clear the ASIO spiking a well.....at the moment anyway!

    What an absolutely bonkers way to work?

    Is this a well known issue?
     
  6. Insectfish

    Insectfish New Member

    Messages:
    14
    Well...what Bill suggested above seems to be working but NI must be aware of this? Everytime I open up a new instance of Reaktor I'm having to run through this procedure!

    Anyone else have this problem?
     
  7. grobsen

    grobsen NI Product Owner

    Messages:
    12
    they are aware.
    I have filed a bugreport during public beta testing of reaktor 5.5 and have been in contact with ni support team about this not too long ago.

    since this bug exists for some time now, i guess it's a bigger issue and will take time to solve - so you better get used to it :) i did...

    i am actually not so sure that your crashes are part of the same problem. crashing after loading certain patches reminds me of http://www.native-instruments.com/forum/showpost.php?p=659695&postcount=35

    good luck!

    edit:
    instead of disabling multitasking try unchecking core 0 affinity for cubase.exe in task manager (task manager - processes - right click on cubase.exe - set affinity... - uncheck core 0) - this should at least work for all future instances of reaktor during the same session.
     
  8. audiokrat

    audiokrat Forum Member

    Messages:
    28
    I'm having the same problem, i think.

    Reaktor 5.5.1 crashes Cubase 5.5.1 (32bit) AND Ableton Live when loading certain (i presume certain high-CPU-consumpting) Ensembles. In my most recent case "The Finger".

    On Windows 7 64bit. I have an i3 and an i7 system (8 cores).

    I will go check the CORE 0 thing...
     
  9. faster

    faster NI Product Owner

    Messages:
    932
    The Finger? It takes 1.8% CPU on a dual core AMD 6000+ with 3GB of memory and XP Sp-2:p
     
  10. audiokrat

    audiokrat Forum Member

    Messages:
    28
    for me the solution seems to be the deactivation of hyperthreading (BIOS)!
     
  11. grobsen

    grobsen NI Product Owner

    Messages:
    12
    cubase maintenance update:

    "The following issues have been fixed in version 5.5.2:
    (...)
    * Fixed a crash involving NI Reaktor 5."
     
  12. Bill Lumberg

    Bill Lumberg Forum Member

    Messages:
    21
    I can't believe I missed that :eek:. Hopefully it solves the problem!
    ---
    Ok so I went ahead and upgraded to 5.5.2 and its just as bad as 5.5.1:( what a shame...
     
  13. satorioz

    satorioz New Member

    Messages:
    1
    I found this post for running Reaktor in cubase - I haven't tested it that much but its a touch more stable loading the finger which was crashing straight away on load up (cubase 5.5.2 32bit win 7 64).

    Might try the tweeks mentioned in this thread too see if that helps too.


    "If REAKTOR crashes when inserting an Ensemble it might be possible that the Data
    Execution Prevention of Windows is activated.

    If that's the case, please open the following path in the Windows Control Panel:

    Control Panel / System /Advanced System Settings /
    Performance (Settings) / Data Execution Prevention.

    If the Data Execution Prevention is turned on for all programs and services, the
    Reaktor5.exe ( c drive programs / native instruments etc) and the executable of the host/sequencer where REAKTOR is used as plug-in (e.g. Cubase5.exe - programs/ steinberg etc) should be added to the list of exceptions to solve the
    issue."
     
    Last edited: Nov 20, 2010
  14. JPaul23

    JPaul23 NI Product Owner

    Messages:
    930
    I have a similar problem, but in my case Reaktor5 is crashing in Kore. Already been in touch with Support who suggested the DEP *fix* , but if anything it just makes the crashes quicker.
    The DEP was activated for "essential windows programmes only" though, so I'm hazarding a guess that Reaktor and Kore aren't exactly windows essentials....
    Sent in another Crash Log anyway. I guess this is why the R5 update hasn't happened yet.
     
  15. Insectfish

    Insectfish New Member

    Messages:
    14
    Yep, I'm having the same problem....tried the DEP option and it did not resolve the issue. I've managed to get Reaktor to run in a semi-stable manner (by switching on/off Multi Processing and switching on/off Disable CPU Energy Saving in Cubase) by no means how I'd like to work.....and I can confirm that when opening an instance of The Finger my system crashes!
     
  16. Bill Lumberg

    Bill Lumberg Forum Member

    Messages:
    21
    I've found that the multi processor on/off trick only works on projects where the asio meter is very low. On projects where the asio meter is above 40 to 50 percent the on/off "work around" doesn't work any more...
     
  17. Adam_AlterImage

    Adam_AlterImage New Member

    Messages:
    3
    New version of Reaktor not opening in Cubase, still old version

    Ok I have a rather dumb question as Im not the most tech savvy person. I got Komplete 5 back in July and all has been well. Recenlty, Reaktor just stopped loading. So I figured it was time to update anyway and installed 5.5.1. For some reason all my other vsts from Komplete 5 disappeared and I ended up reinstalling everything, no big deal. I ran all the Komplete 5 updates again including Reaktor 5.5.1.

    The question - in cubase 5, i open up reaktor and its still the old version, so when i try to open any ensemble it says that it cannot work because it is updated for the new version of Reaktor. When i updated I didnt get new dll files or anything, i checked all the current ones in my VST folders and they are from back in July. (i have cubase 4 and 5 installed but neither have new dll files from the updates and my NI folder on the C drive does not either)

    What am I missing here? Im sure its something silly but I'm just not connecting it. Thoughts?

    Thanks for your help.

    Adam
    ---
    Nevermind, I figured it out :D

    thanks
     
  18. Insectfish

    Insectfish New Member

    Messages:
    14
    Hi,

    Had a look in my systems Bios and can't see anything listed as 'Hyper Threading' Could this function be listed under an alternative name?
     
  19. JPaul23

    JPaul23 NI Product Owner

    Messages:
    930
    Disabling hyperthreading has been suggested to me by Tech Support too, as Reaktor keeps crashing Kore. I'm not really confident doing this, and was told that I might lose all my registration info by doing this, but that re-enabling HT if the trick doesn't work will bring back reg info. My question is, if disabling HT makes everything stable and my registration info is lost, what then? Do I have to re-register for my products to work in anything other than demo mode?
     
  20. Vadim_K

    Vadim_K NI Product Owner

    Messages:
    121