1. Hi everyone,

    Apple just released Logic Pro 10.5 for MacOS 10.15. We found out that Crush Pack, Mod Pack, Replika, and Replika XT will crash.

    Our teams are currently working on a fix, and we hope to have this out to you as soon as we can!

    Best wishes, 
    The NI Team

    Dismiss Notice

Run As Admin Hinders Drag n Drop

Discussion in 'MASCHINE Area' started by hi-d-ho-man, Dec 3, 2016.

  1. hi-d-ho-man

    hi-d-ho-man NI Product Owner

    Messages:
    402
    I use J-birdge for a couple x86 plugs i like to use. JBridge tends to need the host to run in admin mode in order to work best. BUT, I found that win I run Maschine in Admin mode on my system (see my sig), I lose Drag N Drop capabilities with both audio & midi. Who knows what else is affected, this is just what I happened to notice. I put in a request for support, they asked me make a vid so i thought i'd share it to see if others experience too and if it is indeed a 'bug'

    https://dl.dropboxusercontent.com/u/43461728/maschine_admin_pos_bug.zip
     
  2. UltimateOutsider

    UltimateOutsider NI Product Owner

    Messages:
    594
    Yep this is a problem with many programs, not just Maschine. There are strange side effects regarding process interaction when some processes have admin rights and others don't. I would not be surprised if this is something NI cannot fix.

    Two possible workarounds for you, though: 1) Try just running 32-bit Maschine when you need to use 32-bit plugins. This may not be feasible long-term since some plugins are finally starting to come out as 64-bit only, but so long as your plugins load you're not really missing anything on Maschine by running the 32-bit version. 2) Disable User Account Control in the Windows User Accounts control panel. On Windows 7 this alleviates a number of permissions-related issues, although it doesn't always do the trick on Win 8 or Win 10. Of course it's not as secure as leaving UAC enabled, so it's a draw.

    (I tried working with jBridge for a while and I stopped bothering for a similar reason. With a DAW running in admin mode, I had to ALSO run my video recorder in admin mode in order to create DAW tutorial videos, otherwise the recorder couldn't track mouse activity whenever I was working in the DAW... and I don't like when apps force me to launch in admin mode anyway.)
     
  3. hi-d-ho-man

    hi-d-ho-man NI Product Owner

    Messages:
    402
    thanks for the reply.i didnt remember anyone mentioning it here so i wondered if was just me. i noticed it back during 1x but was to lazy to create a support ticket
     
  4. CakeAlexS

    CakeAlexS NI Product Owner

    Messages:
    5,312
    This behaviour is totally "by design" and is down to user permissions (not a bug). Ultimately you shouldn't be running anything as admin anyway unless you are installing. The reason why some plugins don't work unless running as admin is because they don't handle permissions well (poorly designed). The workaround is generally to open up registry permissions on plugins that don't work, Google for the specifics.

    I strongly do not recommend disabling UAC as this reduces your computer's security. It's not just there to nag you.

    Of course if you dump 32 bit plugins altogether (as I have) you won't have the issue.
     
    Last edited: Dec 4, 2016
    • Like Like x 1