S2 MK1 - Can someone find the error in these screenshots?

Discussion in 'KONTROL S2 / KONTROL S3 / KONTROL S4' started by MarcAeroe, Feb 15, 2020.

  1. MarcAeroe

    MarcAeroe New Member

    Messages:
    6
    Hi Everyone

    After two sleepless nights trying to install my new (used) S2 MK1 I am not desperately seeking for help. I have done EVERY youtube and written tutorial I could find, but Traktor Pro 3 does not react when I use the controller. I hope a helpful soul can find the errror in my screenshots and save my life (feels like that right now :) )
     

    Attached Files:

  2. MarcAeroe

    MarcAeroe New Member

    Messages:
    6
    A little more screenshots
     

    Attached Files:

  3. ErikMinekus

    ErikMinekus NI Product Owner

    Messages:
    677
    Your mapping says Maschine MK2. You need to import the Kontrol S2 mapping.
     
    • Like Like x 2
  4. MarcAeroe

    MarcAeroe New Member

    Messages:
    6
    Wow. You give me hope.. I am sorry, but I do not know what "Mapping" means. I have tried to google "import kontrol s2 mapping", but cannot find any help that I can translate to action. Do you have the energy and time to share how I can go about it?

    I changed in "Controller Manager" but is now stuck like this:
     
    Last edited: Feb 15, 2020
  5. MarcAeroe

    MarcAeroe New Member

    Messages:
    6
    Screenshots:
     

    Attached Files:

  6. Tijn71

    Tijn71 NI Product Owner

    Messages:
    147
    When you use mapping you must set your in- and out port in the controller manager - device setup to the controller you want to use the mapping on. In this case you need to set the in- and out port to the S2 mk1.
    But I'm wondering why you changed to the "audio kontrol 1" in the setup wizard. In the previous screen from the wizard it says everything is already setup correctly.
    upload_2020-2-16_10-52-11.png

    I think you should have enterd NO here
    upload_2020-2-16_10-55-41.png

    Here you had the S2 connected. The speaker turned white. Meaning your device is connected.
    Printscreen TP37.jpg

    Also there is no need to change anything the the Controller editer unless you use custom mapping. When you use the setuop Wizard Traktor automaticly loads the standard S2 mapping you need to use the S1 mk1. Just check the in- and out ports are setup as written above
     

    Attached Files:

    Last edited: Feb 16, 2020
  7. MarcAeroe

    MarcAeroe New Member

    Messages:
    6
    Thank you very much for your kind kind help.. I have tried to adjust according to your instructions. However it still does not react when I use the controller. I will attach screenshots with my present settings:
     

    Attached Files:

  8. Tijn71

    Tijn71 NI Product Owner

    Messages:
    147
    What are your in- and out port set to?

    Printscreen TP38.jpg
     
  9. MarcAeroe

    MarcAeroe New Member

    Messages:
    6
    I have no options to select. So it is just "none". - Again thank you!!
     

    Attached Files:

  10. Tijn71

    Tijn71 NI Product Owner

    Messages:
    147
    All I can think of at the moment is, and maybe you have done it already, is to completely re-install Traktor and your controller editor. This to have a clean start. And then follow the steps from the previous posts.