S4MK3 windows 10 (1909) disabling device

Discussion in 'KONTROL S2 / KONTROL S3 / KONTROL S4' started by Abstractamcr, Mar 27, 2020 at 2:28 AM.

  1. Abstractamcr

    Abstractamcr NI Product Owner

    Messages:
    4
    This is getting a bit much. I have had ZERO issues between the MK3 and windows. has worked with out fail for months. Saturday, despite nothing changing on my computer in the slightest, windows would not allow the S4 to connect and use the USB correctly. I ran update for win, bringing me to 1909 version of win. Rebooted, and everything was back to normal. yesterday had the controller and traktor on for about 20 hours ZERO issues. Today back to not connecting. once again NOTHING has changed on my system. HELP PLEASE, I have a gig Friday 3/27 i need to stream it from my studio. Incidentally the controller works fine on my mac, but i dont have my library there and dont want to move 30k tracks over to it.

    From the events section of the USB device in question from device manager:
    Device USB\VID_17CC&PID_1720\6&301263fd&0&1 was not migrated due to partial or ambiguous match.

    Last Device Instance Id: USB\VID_17CC&PID_1722\48156698
    Class Guid: {88bae032-5a81-49f0-bc3d-a4ff138216d6}
    Location Path: PCIROOT(0)#PCI(1202)#USBROOT(0)#USB(1)#USB(1)
    Migration Rank: 0xF000FFFFFFFF0113
    Present: false
    Status: 0xC0000719

    Please Advice. :(
     
  2. Cheef Roberts

    Cheef Roberts NI Product Owner

    Messages:
    105
    1. Try a different USB cable.
    2. If that doesn't work try reinstalling the ASIO driver.
    3. You could also try a different USB port.
     
  3. Abstractamcr

    Abstractamcr NI Product Owner

    Messages:
    4
    Appreciated, have def tried new cable. REALLY dont want to reinstall that as i have other things and they arent having an issue. I honestly dont think this is an NI thing perse. It seems like everytime windows detects an update, this happens. the other day going from 1903 to 1909, and then right when i posted this message i went and checked and sure enough there was another update, run that little update and windows sees the device yet again fine. if it happens a 3rd time we shall see. I mean i keep updates turned off but yet here we are.
     
  4. Abstractamcr

    Abstractamcr NI Product Owner

    Messages:
    4
    on the plus side it got working before my gig, so there is that.
     
  5. Cheef Roberts

    Cheef Roberts NI Product Owner

    Messages:
    105
    I have Traktor installed on a different partition and that is all I use this partition for and I keep it offline to help with dpc latency. This way I get no updates thus no problems like the ones you have had. I use another partition for online and all other programs etc.
     
  6. Abstractamcr

    Abstractamcr NI Product Owner

    Messages:
    4
    That is some legit methodology for sure man. I might end up doing that at some point. {shakes fist at MS}
     
    • Like Like x 1