1. We're currently conducting systematic tests with the release version of macOS 11 (Big Sur) in order to offer full compatibility of our products as soon as possible. You can find our latest compatibility status - here


    Please note that although announced at the same time as macOS Big Sur, Apple Silicon processors are an independent release with separate compatibility concerns for NI products. Compatibility with macOS Big Sur will not yet ensure compatibility with Apple Silicon processors. At the moment, Native Instruments products are not supported on computers with Apple Silicon processors. Read more - here

    Dismiss Notice

S61 mk2 Kontrol rotaries not working on startup (Ableton)

Discussion in 'KOMPLETE KONTROL SERIES' started by kontrast, Jun 21, 2019.

  1. kontrast

    kontrast New Member

    Messages:
    6
    Hi all,

    i ugpraded my Komplete 12 yesterday and updated my firmware (0.5.2 to 0.5.9) and vsts of the s61 mk2.
    I have added the Kontrol VST Instrument-Rack with activated scale-menu as a preset, loading everytime i start a new project.
    Ableton recognizes the S61 without problems, playing works, the screen on the S61 works, buttons on the keyboard work. But since the update i can't change the settings in the scale-menu using the s61 rotaries. This did work before i updated.
    The popup menus are still shown on the screen of the keyboard, but nothing happens. Changing it through the VST works though.

    Switching to another screen menu and back -> rotaries work now
    Loading a new Kontrol Instrument-Rack during a project -> rotaries work (doesn't start up at the scale menu though).
    Loading a new Kontrol Instrument-Rack on a new track (works), then switching back to the startup instrument -> still doesn't work.
    Creating a new preset with a working instrument, then load a new project -> rotaries won't work again.

    I assume there is a problem when the vst is starting up at the scale-screen-menu.
    Any ideas?
     
  2. Louis~

    Louis~ NI Product Owner

    Messages:
    214
    Hi, just wondering why you are still using the KK instrument rack? With the latest updates and using the MK2 you should only be loading the KK plug-in, not the instrument rack. (No need to copy Scripts anymore) Have you tried this yet? MK1 users still have to use the instrument rack and copy Scripts. Hope this helps…
     
  3. kontrast

    kontrast New Member

    Messages:
    6
    Yea i realized that after i posted.. i did replace the instrument rack with the plug-in, same bug though :(

    I got 3 Midi Devices showing up in Ableton:
    Komplete Kontrol DAW - 1
    KOMPLETE KONTROL - 1
    KOMPLETE KONTROL - EXT 1

    Using "Komplete Kontrol DAW-1" on my track as midi input doesn't receive midi, so i use "KOMPLETE KONTROL - 1". Maybe that is the issue? If yes, how do i get ableton to receive midi using "daw-1" as input?

    I attached 2 images for clarification
     

    Attached Files:

    • 1.png
      1.png
      File size:
      26.6 KB
      Views:
      108
    • 2.PNG
      2.PNG
      File size:
      48.3 KB
      Views:
      115
  4. Louis~

    Louis~ NI Product Owner

    Messages:
    214
    You should be using DAW 1 as your midi input. First, I would try deselecting KK in midi to none, then closing everything down, rebooting your computer and then opening up the KK software, In preferences make sure that all your midi inputs are selected then close KK and open Ableton and set up midi with KK with DAW one. See how that goes…
     
  5. Louis~

    Louis~ NI Product Owner

    Messages:
    214
    Why is your Ableton midi preferences set to none? In the first column you should have KK MK2 selected and for the second and third columns you should have the Daw 1 selected.
     
  6. kontrast

    kontrast New Member

    Messages:
    6
    Thanks for your time, but it didn't work.
    There is nothing to chose from in the columns relating to KK - only if i copy the mk1 scripts (edit: the ableton9 scripts)

    //edit:
    Ok i didn't realize the folders inside the midi remote scripts where shipped with ableton 10.1
    Luckily i saved those before messing with the updates. I copied them back and "Komplete Kontrol S Mk2" shows up now. Still no difference though. Nothing received if i select "Komplete Kontrol Mk2 Input (Komplet Kontrol DAW - 1)" for my midi input.
    Keyboard screen hooks up with the VST - still got the bug there
     
    Last edited: Jun 22, 2019
  7. Louis~

    Louis~ NI Product Owner

    Messages:
    214
    We are talking about 2 different things here:

    1- Ableton Preferences, Link Midi, Control Surface, Select "Komplete Kontrol S MK2" ...Ableton Preferences, Link Midi, Input And Output "Komplete Kontrol DAW-1"

    2- Now insert a KK Plugin on a track and leave Midi From to "All Ins"

    If this doesn't work then I strongly advise you read the Install for the latest KK and also how to setup a KK track in Ableton. Sorry I couldn't be more helpful..
     
  8. kontrast

    kontrast New Member

    Messages:
    6
    Ah i got you. I did test all variations though, including the one you describe. Thank you again though.
    Midi from All ins works, because it gets the midi input from all - and "komplete kontrol - 1" is included in that.
    Anyway thats a non issue for me, like i said the plugin works flawlessly if i add it during a session. Only when setting the project as a preset the rotaries don't work on startup. Just a little inconvenience and weird that it didn't occur before.
    I did uninstall and reinstall by book today - still has the same behaviour.

    Is there a dedicated bug report anywhere? Maybe NI can check if they can replicate the rotary problem (windows, ableton 10.1, newest NI driver/software versions)
     
  9. Louis~

    Louis~ NI Product Owner

    Messages:
    214
    If you drop down the Macros Tab you will see Encoder movement even after saved Project preset. You can also scroll pages from the MK2 and the plugin shows this.
     

    Attached Files: