Sinebeats 2 multi out not functioning correctly

Discussion in 'Technical Issues - KOMPLETE (Archive)' started by Ruari, Jun 22, 2011.

  1. Ruari

    Ruari NI Product Owner

    Messages:
    265
    I'm having difficulty using Sinebeats as a multi out instrument, first of all I select the outputs I wish to use in the mixer, then I de-activate Use Single Out in the Master section - nothing can be heard except some sounds from out 1&2 (which in this case is the Noise Synthesizer)

    If I then click Use Single Out again to highlight it I get a burst of noise from all the outputs, the meters all light up then the sound completely stops other than the sound of Output 1&2.

    This is happening both standalone & as a plug-in inside Logic, it doesn't seem to matter which snapshot I try it always seems to behave the same way.

    Does this happen with anyone else & does anyone know how I can fix it?



    EDIT:I'm using Reaktor 5.6.0 & Logic 9.1.4 in OSX 10.6.7 by the way
     
    Last edited: Jun 22, 2011
  2. Ruari

    Ruari NI Product Owner

    Messages:
    265
    No-one has experienced this or knows how to fix it?

    I'm going to re-post it in the main Reaktor forum to see if I can get a response.
     
  3. sowari

    sowari Moderator Moderator

    Messages:
    27,766
    i'll try to have a look today if i have time.

    sowari
     
  4. Ruari

    Ruari NI Product Owner

    Messages:
    265
    I'd really appreciate that, thanks Sowari.
     
  5. sowari

    sowari Moderator Moderator

    Messages:
    27,766
    this 'feature' is indeed broken, i have filed a bug report about this.

    sowari
     
  6. Ruari

    Ruari NI Product Owner

    Messages:
    265
    Ok, thanks for checking that out Sowari. Do you think that this is something we would be able to fix ourselves within the structure of the ensemble?

    I had a look but as far as I could see everything seemed to be connected up to something else, I'm not yet knowledgeable enough to be able to tell if the right bits were connected to the right other bits.
     
  7. salamanderanagram

    salamanderanagram NI Product Owner

    Messages:
    3,435
    i think maybe to have more than 2 outputs, you need to have that many inputs. it fixed a problem i had (starting in 5.5) that was similar.
     
  8. Ruari

    Ruari NI Product Owner

    Messages:
    265
    I'm not sure I know what you mean. I'm able to use Aerobic & Massive as multi outs, I don't think they have any inputs.
     
  9. salamanderanagram

    salamanderanagram NI Product Owner

    Messages:
    3,435
    :p my mistake - it might have been the other way around, to have x inputs you need to have x outputs, or maybe i am just crazy!
     
  10. Ruari

    Ruari NI Product Owner

    Messages:
    265
    Hehe, no worries.
     
  11. salamanderanagram

    salamanderanagram NI Product Owner

    Messages:
    3,435
    i did some sleuthing and it seems when you press the use single outs button, the respective switch turns on for a second and then turns off again :p

    hence the short burst of noise you're getting.

    going deeper, it looks as though right after you turn on the switches, the current snapshot reloads, causing them to go back to their original state... you can go down into the structure and simply remove all the switches that are turning off the audio signal leading out. takes about 5 seconds. then it works fine for me.

    one more edit - it looks like there is a snapshot recall that gets triggered upon a restart of the sequencer - when you press a switch it causes a GRE, which causes some bug to trigger the snapshot module.
    ---
    ... there's a step filter going into the snapshot module's recall input. if you place a separator before the step filter and connect the hi output from the the separator into the in input of the step filter, it seems to work, plus you can keep your CPU saving switches.

    if you want i'll upload a fix but it should be easy enough.
     
  12. Ruari

    Ruari NI Product Owner

    Messages:
    265
    Nice one salamanderanagram, I'll give it a go & let you know how I get on :D


    EDIT: I've done it, inserting the separator worked as you said. Thanks a lot for figuring that fix out, I don't have a clue how it works but I'm chuffed that it does.

    You guys are awesome :D
     
    Last edited: Jun 24, 2011
  13. salamanderanagram

    salamanderanagram NI Product Owner

    Messages:
    3,435
    glad to be of service!

    i started typing out what was going wrong but honestly it'll be gibberish if you're not really into building. it was kind of gibberish anyway, this stuff can be hard to explain lol
     
  14. Ruari

    Ruari NI Product Owner

    Messages:
    265
    Ha, yeah I wouldn't have understood very much of it. I haven't really started to get my head round the building side of things yet, I've had Komplete since November of last year & I've only just finished learning all the different synths - it's a ridiculously good deal but it does come with a bit of a steep learning curve.

    I do want to build some of my own things in the future but with Reaktor being such a huge package it's difficult to know where to begin, I'll figure it out eventually but right now my main focus is making music - after all, that's the thing that brought me here in the first place & with the wealth of outstanding ensembles available in the User Library & around the net I'm certainly not going to be short of tools to use any time soon.
     
  15. sowari

    sowari Moderator Moderator

    Messages:
    27,766
    i'll check this out myself.

    fwiw, Aerobic has a very similar similar - but slightly different - system to SineBeats but seems to work with no problem.

    sowari
     
  16. thenthorn

    thenthorn NI Product Owner

    Messages:
    1
    For those struggling to find the "switches", attached is a description of salamanderanagram's solution:
     

    Attached Files:

  17. komposer

    komposer NI Product Owner

    Messages:
    119
    Hi All,
    I've no clue how to modify the Sinebeat 2 structure to get it to work as multi output can someone share the modified ensemble or guide me step by step to rectified the issue.

    Thank you very much
    Cheers for now
    Komposer
     
  18. salamanderanagram

    salamanderanagram NI Product Owner

    Messages:
    3,435
    there is a pretty detailed explanation by me in this very thread?

    i can clarify is some part is unclear.
    in fact, maybe i'll just make a tutorial out of it.
     
  19. komposer

    komposer NI Product Owner

    Messages:
    119
    Thanks. I'll have a look
    Cheers
     
  20. komposer

    komposer NI Product Owner

    Messages:
    119
    Salamanderanagram,
    you are the man! mate.
    I got it up and running, thank you very much indeed!

    K
    ---
    Thenthorn,
    Thank you very much for your PDF that was very helpful!