1. Hi everyone,

    We have just announced our latest version of the Komplete bundles.

    Find out more about the bundles and the newly added instruments

    Komplete 13 is available for pre-order now, and will become available for download on October 1, 2020.

    Best wishes, 
    The NI Team

    Dismiss Notice

New [solved] [3.4.0.237] Browser Key Color Setting - Only 'Colour All' works

Discussion in 'Bug Reports' started by alec.tron, Sep 22, 2020.

  1. alec.tron

    alec.tron NI Product Owner

    Messages:
    714
    Hi.
    Here's a bug report, using the requested template (mayben this should be copied into the open beta as a sticky too ?)

    Version and Setup:
    • TPro 3.4.0.237
    • S4 mk3
    Reproduction Steps:
    • Start application
    • Play Song in Deck A
    • (Optional: Play Song in Deck B)
    • Open Settings go to 'Browser Settings' and switch 'Key Highlighting' between the options 2 to 4.
    • Observe what happens when you switch the settings. Or, when you apply Option 2 or 3.
    Observed Results:
    • Option 2 - 'Only Color Matching Keys' = Does not work. No Matching Key ever to receive a colour
    • Option 3 - 'Also Colour Adjacent Keys' = Does not work. No Matching or Adjacent Key seems ever to receive a colour
    • Option 4 - 'Color All Keys' = works as usual
    Expected Results
    • For the settings to work as in previous versions (also does not work on .233 either. Does work on 3.3.0 official release...)
    Attachments:
    None for now. It's 100% reproducible for me with the last 2 versions.

    Cheers.
    c.
     
    Last edited: Sep 22, 2020
  2. wayfinder

    wayfinder NI Product Owner

    Messages:
    136
    Currently, Matching and Adjacent keys are only colored when one deck is master, not when Global Master is on, can you check if that's what's happening here?
     
  3. alec.tron

    alec.tron NI Product Owner

    Messages:
    714
    Thanks for the heads up / idea - but no. Tested all possible Master (as well as Deck Focus) options and settings combinations, and none show 'Matching and Adjacent keys' in colours ever, for me, unless set to 'Color All Keys', which works as usual & expected.
    Is anyone else seeing this ?
    Cheers.
    c.
     
  4. wayfinder

    wayfinder NI Product Owner

    Messages:
    136
    I didn't have the system I had the beta on here, so I only had 3.3 to compare (where it works). Can now confirm that 3.4.0 colors everything correctly too for me.
     
  5. alec.tron

    alec.tron NI Product Owner

    Messages:
    714
    Eh, looks like the beta install has switched off Keylock... and Keylock in turn is a requirement for colouring the keys in. Once both track decks have keylock enabled again, 'Matching and Adjacent keys' works as expected again...
    So, f*ckery solved... thanks for chiming in!
    c.
     
    • Like Like x 1