SOLVED! Dropouts, Cracks, Pops on Windows 7 and NVIDIA GFX CARD!

Discussion in 'TRAKTOR Audio Interfaces' started by Classified, Dec 27, 2010.

Thread Status:
Not open for further replies.
  1. Classified

    Classified Forum Member

    Messages:
    30
    So I am happy to say that after such a LOOOOONG time I finally found the solution to this issue.

    I was having insane dropouts when using Windows 7 with TSP 1.2.7 and Audio 8 DJ (Any driver version)

    So here are the steps:

    1. I checked my system with DPC Latency checker which indicated that there are some drivers that can potentially cause dropouts.
    2. I then checked LatencyMon and found that there is a file called nvlddmkm.sys which is related to the NVIDIA card driver. It was taking an insane 18ms execution time.
    3. I disabled the card and the dropouts stopped! But I was without a graphics card driver.

    After a bit of looking around I found out that there is a service called NVIDA PowerMizer: The ultimate goal of PowerMizer technology is to optimize power use for the longest battery life in a notebook PC while providing the performance necessary for the task at hand. Some office applications like word processors and spreadsheets require less processing than is necessary for an immersive 3D gaming experience or for viewing a crystal clear high definition video. PowerMizer technology will intelligently adapt itself to suit the performance needs of the application.

    This is kind of like what Intel has to limit the CPU computing power based on what applications are running, in other words, it's a power management process for your graphics card which can cause spikes in your CPU usage - YOU DON'T WANT THIS.

    To disable the PowerMizer, here's what you have to do:

    (You may want to back up your registry first)

    1.Open up Regedit and go to

    \HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Video\********\0000\
    The *'s will be random numbers. There will be a few of them, pick the "0000" folder with the most keys in it.

    2.Create the 4 Powermizer keys (these will all be DWORD):

    PerfLevelSrc
    PowerMizerEnable
    PowermizerLevel
    PowermizerLevelAC

    3.Change the values (double click on them) to:

    PerfLevelSrc 3322
    PowerMizerEnable 0
    PowermizerLevel 1
    PowermizerLevelAC 1

    4.Reboot and Powermizer will be disabled!

    After this process, I ran LatencyMon again and the nvlddmkm.sys file is only taking up 0.2-0.3 ms in execution.

    Problem solved, the dropouts should be gone!

    Hope this helps you!
     

    Attached Files:

    • Informative Informative x 1
  2. goonzy

    goonzy Modérateur

    Messages:
    2,884
    Great job.. it will help a lot of people
     
  3. djmanchini

    djmanchini Forum Member

    Messages:
    303
    damn how should a human be able to solve this in case just to use an app :(
     
  4. Classified

    Classified Forum Member

    Messages:
    30
    That's why we have these forums to share information, as someone who suffered these dropouts for more than a year, I am happy that other people can now find the solution, provided that they are using NVIDIA cards... I'm fairly certain that it's affecting a lot of people!
     
  5. Classified

    Classified Forum Member

    Messages:
    30
    P.S. for those of you who don't want to fiddle with Registry settings, you can also disable the PowerMizer feature using an application called "PowerMizer Switch" it can be downloaded at this link: http://www.box.net/shared/v7jpoateoq
     
  6. Shween

    Shween Forum Member

    Messages:
    22
    My laptop has onboard grafix m8
     
  7. GEZMOND

    GEZMOND Forum Member

    Messages:
    27
    ok i have a nvidia geforce 310m card on my lenovo laptop, and after running latencymon the nvlddmkm.sys is the only driver thats causing my dpc spikes. I tried the powermizer switch but that didnt seem to work.

    will this fix work instead do you think? how is it different to the switch that you have posted? maybe i chose the wrong options of the switch, if so which option is the correct one?
     
  8. oreste

    oreste Forum Member

    Messages:
    84
    for me doesn't work latencymon. it gives me this error. any help?thanks!
     

    Attached Files:

    • 1.JPG
      1.JPG
      File size:
      12.6 KB
      Views:
      1,545
  9. GEZMOND

    GEZMOND Forum Member

    Messages:
    27
    ive just got back and tried your fix via regedit and it still hasnt worked?
     

    Attached Files:

  10. Steve Zorilow

    Steve Zorilow NI Product Owner

    Messages:
    959
  11. oreste

    oreste Forum Member

    Messages:
    84
  12. Steve Zorilow

    Steve Zorilow NI Product Owner

    Messages:
    959
    I would try to use the generic Microsoft VGA driver, it already work for some here. Probably you'll lose the 2nd display output though.
     
  13. Classified

    Classified Forum Member

    Messages:
    30
    The solution should work for Windows XP as well.

    Here's what I recommend to do:

    1. Go into the Registry and delete the values you created:

    PerfLevelSrc
    PowerMizerEnable
    PowermizerLevel
    PowermizerLevelAC

    Reboot your computer.

    2. Go in to NVIDIA's website and download the latest display driver available for your card, it should be 260.99

    After I installed this driver I noticed that the issue was solved, without having to disable PowerMizer.

    3. However, just to be sure, download PowerMizer Manager, it's a better application that can disable this service for you, you can get it here:

    http://somemorebytes.com/wp/wp-content/plugins/download-monitor/download.php?id=3

    When you open the PW Manager, it should tell you that it did not find any settings and will ask you if you want to create settings, click "Yes", you should then be able to see the settings and make sure that the "Enable PowerMizer" checkbox is not checked.

    4. Click on "Apply and Reboot" and then check DPC and LatencyMon.

    Hopefully, your issue should be solved.

    Let me know if that helped.
     
  14. TRIBAL TECHNO

    TRIBAL TECHNO Forum Member

    Messages:
    114
    hi, im about to purchase a macbook pro core2duo 2.4ghz lappy, and from what ive heard it has nvidia graphics, will i need to disable anything on the mac's nvidia graphics settings?
     
  15. GEZMOND

    GEZMOND Forum Member

    Messages:
    27
    classified - thanks for all your help - it seems as though were getting closer to a solution!

    my laptop runs on windows 7 btw and i have already downloaded and installed driver 260.99...

    anyway, ill have a go at deleting the entries later and then downloading the powermizer app to see if that works

    if not, can anyone link me to the windows vga driver? im not that fussed on the second screen option anyway and dont use the laptop for games so the graphix card doesnt need to be run to full capabilities!

    this is really frustrating, i feel sorry for anyone who have had to deal with this for a while - im lucky in that ive only had traktor for such a short time and am looking forward to getting some decent use out of it!
     
  16. Classified

    Classified Forum Member

    Messages:
    30
    Hey dude,

    Basically if you uninstall your GFX card in the Device Manager Windows 7 will automatically load the standard VGA driver for your card, so you don't need to download anything.

    However, you won't be able to run your display at its native resolution which is quite important to view Traktor correctly.

    Try to apply the fix first and let me know if you are facing any other issues after that.

    P.S.

    I just checked the screenshot of your Regedit and I noticed that you have 5 PowerMizer keys instead of the 4 you should have, the 5th is PowermizerDefault from what I can see, delete that one as well and then try to apply the fix again.


    @TRIBAL TECHNO, I'm pretty sure the PowerMizer feature is also active on Macbooks since it's the same GFX card but usually Traktor runs smoothly with a Mac and I'm not sure that it's going to pose an issue for you.

    I'm pretty sure that there is no way to disable PowerMizer in Mac but it only kicks in when the computer is not plugged in, so if you have plugged in it shouldn't cause issues.

    Anyway, a Mac is a Mac and generally performs better with Traktor than a PC, I'm quite sure you won't have this issue.
     
  17. GEZMOND

    GEZMOND Forum Member

    Messages:
    27
    Cheers mate, if the fix doesnt work and I have to resort to using the Windows VGA driver is there anyway that I can use an older NVIDIA driver instead which doesnt run the 3d part of the card at all but would therefore mean I'd still have a decent resolution? I think I read somewhere else that people have done this with satisfactory results?
     
  18. Classified

    Classified Forum Member

    Messages:
    30
    I'm not very savy about disabling parts of the card using an older driver, but I think you shouldn't go through this process, check out what I just added to my previous post:

    I'm pretty sure that the feature wasn't disabled due to the 5th key, you should only have 4 keys, delete all PowerMizer keys in your Registry, Reboot and let PW Manager do the dirty work for you :)
     
  19. GEZMOND

    GEZMOND Forum Member

    Messages:
    27
    Nice one, will give it a go later when i get home :D
     
  20. Classified

    Classified Forum Member

    Messages:
    30
    Cheers, let me know if it helped!
     
Thread Status:
Not open for further replies.

Share This Page