Sonar Crashes

Discussion in 'KOMPAKT' started by jfhyde, Aug 10, 2003.

Thread Status:
Not open for further replies.
  1. jfhyde

    jfhyde NI Product Owner

    Messages:
    20
    Its not all bad, I can open up a song with a kompakt multi, say the jazz multi, work with it for awhile and save it, but when I close the file Sonar almost always crashes with the Windows dialogue, "Sonar has generated errors and will be closed by windows".... but with the midi monitor still running in the taskbar. My guess is its a memory problem with Kompakt not releasing memory when its closed out...

    I'm running W2K with a P4 1.8 and a gig of memory, and I was able to run Kontakt 1.2.1 without this problem.
     
  2. jfhyde

    jfhyde NI Product Owner

    Messages:
    20
    Guess this is a bug, I talked to some people on the Sonar newsgroup and they said the same thing! Kompakt crashes when you close the project's window in Sonar.

    Sonar users should wait for version 1.1... :(
     
  3. dorism

    dorism NI Product Owner

    Messages:
    482
    Yip,

    I get this too :-(

    thought it was me!

    cheers
    Michael
     
  4. hhormbrey@hotmail.com

    hhormbrey@hotmail.com New Member

    Messages:
    13
    On the plus side, using the VST version of Kompakt wrapped using Cakewalk VST Adapter 4.3.1 in SONAR 2.2 seems to work fine and doesn't suffer the same crash problem on closing the project window. I've only just tried this, but so far it looks promising...

    Regards
    Harry
     
  5. David Das

    David Das Moderator Moderator

    Messages:
    7,060
    NI have found the problem, and a fix will be released shortly.
     
  6. jfhyde

    jfhyde NI Product Owner

    Messages:
    20
    I hadn't thought about trying kompakt using vst... give that a shot today.

    Thanks, John
     
  7. Z

    Z NI Product Owner

    Messages:
    236
    Ooh, neat! Can you put in a good word for us at the same time, so they fix the Akai import/save bug? :)
     
  8. David Das

    David Das Moderator Moderator

    Messages:
    7,060
    Can you refresh my memory on what exactly is going wrong? Remember to include ALL information that you possibly can -- computer, OS version, Kompakt version, specific disc(s) titles, and a step-by-step recipe to reproducing that thing going wrong.

    If you can do that, it helps the developers significantly. They can just go down your recipe, see it for themselves, and take steps to fix it.
     
  9. Z

    Z NI Product Owner

    Messages:
    236
    For my sake:
    XP SP1, Kompakt 1.0 - just noticed it on one Akai CD and knew it was a general problem so I didn't try any else.
    The Akai program loads fine and saves just fine as a .nki program, but upon loading the .nki, Kompakt complains about several missing audio files. Further inspection shows that a sample originally called i.e. E2 M has been renamed E2 M-L, and Kompakt complains about not finding the sample E2 M-R.

    To me, this immediately sounds as if Kompakt tries to save a program with samples in stereo, but only saves the left channel and then fail to load because of the samples for the right channel does not exist.
    This is also reported to happen on converting soundfonts, so it seems to be a general problem and not an Akai related one.
     
  10. David Das

    David Das Moderator Moderator

    Messages:
    7,060
    By the way, have you tried toggling the setting in the Options box to auto-combine imported samples to stereo? Setting it off if it's on (or vice versa) could be a potential workaround for the time being.

    Note that some options in the Kompakt Options box require you restarting the application/plug-in before they take effect -- even if it doesn't tell you that.
     
  11. Z

    Z NI Product Owner

    Messages:
    236
    Hmmm, maybe I found another bug?
    Was going to try the stereo setting (it was previously not selected) as you suggested, but if I select it and close options, it's unselected the next time I open options. Can anyone else confirm this? All the other option selections works...
     
  12. David Das

    David Das Moderator Moderator

    Messages:
    7,060
    Yes, that's a bug. I just tried it and found the same. I've reported it to the developers.
     
  13. dachay2tnr

    dachay2tnr NI Product Owner

    Messages:
    8
    FWIW, I am having the same crashing problem with Sonar. Just got it and installed it last night.

    Interestingly, I didn't seem to have the problem when I first loaded it. Shortly thereafter, however, I downloaded the DFD file and configured the DFD from within Kompakt. That's seems to be when the problem started (although it could just be coincidental).

    Any idea on when we might see the fix? It's liveable this way, but quite annoying.
     
  14. jfhyde

    jfhyde NI Product Owner

    Messages:
    20
    Hi, I finally got around to using Kompakt as a vst with cakewalk vst adapter ver4.3.1 and.... I haven't had a crash yet even after loading, deleting, changing parematers on different patches and multis. Also, the cpu load seems to be lower though I'm going on memory for this.

    So if you can't wait for the bug fix, the adapter can be purchased at the cakewalk web site.

    John



     
Thread Status:
Not open for further replies.