1. Please do not install macOS 10.15 Catalina yet, as Native Instruments software and hardware products are not supported under macOS 10.15 yet. For more info, please go HERE!
    Dismiss Notice

Sound output/routing problems on macOS

Discussion in 'GUITAR RIG' started by sstorkel, Feb 23, 2019.

  1. sstorkel

    sstorkel New Member

    Messages:
    2
    I'm currently playing around with the Guitar Rig 5 demo trying to decide whether to buy. I'm on macOS 10.13.6 (High Sierra) running on an iMac and using a Scarlett Solo as my audio interface. I've installed GR5 and the plug-ins work successfully in GarageBand 10.3.2, which is to say: when I strum the guitar I hear the sound through the Mac speaker and I can also record in in GB. Sounds great, BTW!

    Here's the problem: I'm not a huge fan of GarageBand and I'd really like to be able to use the Guitar Rig standalone app. When I run the standalone app and use the same presets and configs that work in GarageBand, I get absolutely no sound from my build-in speakers. I've checked my Audio/MIDI settings, as well as my input and output levels: they're all similar to what works in GB. When I play my guitar through the Scarlett, the level meters for everything in my rack spring into action... but I still can't hear anything. Even the the metronome doesn't produce any sound (yes, I remembered to unmute it)! I've also checked the audio settings in the System Preferences app: input is coming from the Scarlett and output is set to "Internal Speakers".

    Finally plugged a pair of headphones into the Scarlett and found that processed audio is being sent to it, rather than to the internal speakers. In GR5's "Audio and MIDI Settings" dialog my only options for Output on the Routing tab are "-not connected-" and "1: Output 1" or "2: Output 2". I have Output 1 assigned to the Left channel and Output 2 assigned to the Right, to mirror the Input Settings.

    Feels like I'm missing something obvious... Is there a trick for getting the standalone app to playback through the internal speakers?
     
  2. solger

    solger NI Product Owner

    Messages:
    3,877
  3. sstorkel

    sstorkel New Member

    Messages:
    2
    Woohoo! That was exactly what I needed to do! Many thanks, solger! Everything is working perfectly now...