1. Hi everyone,

    Apple just released Logic Pro 10.5 for MacOS 10.15. We found out that Crush Pack, Mod Pack, Replika, and Replika XT will crash.

    Our teams are currently working on a fix, and we hope to have this out to you as soon as we can!

    Best wishes, 
    The NI Team

    Dismiss Notice

Star ratings don't get imported from iTunes.

Discussion in 'Archive' started by kokernutz, Sep 28, 2019.

  1. kokernutz

    kokernutz NI Product Owner

    Messages:
    327
    (This bug existed in 3.2 and prior versions, but I was hoping this new iTunes integration would fix it.)

    If you are browsing the iTunes node you can see the star rating on tracks that have not yet been imported. But when you import the track, the rating is not carried over to the Traktor library. Then, if you right click on the iTunes node and select Sync Song Info, the star rating will then appear on the imported track.

    I can make a video of this if you'd like.
     
    Last edited: Sep 28, 2019
  2. radiokrishna

    radiokrishna NI Product Owner

    Messages:
    129
     
    • Informative Informative x 1
  3. kokernutz

    kokernutz NI Product Owner

    Messages:
    327
    Interesting. This beta says it supports older version of iTunes, so I feel this bug/issue should still be fixed/resolved.

    (FWIW, iOS 13 still has star ratings.)
     
  4. Friedemann @ NI

    Friedemann @ NI NI Team NI Team

    Messages:
    852
    Good catch! We'll fix this for the next beta. TPRO 3.3.0 should support older versions of iTunes (including import of the rating).
     
    • Like Like x 1
  5. Friedemann @ NI

    Friedemann @ NI NI Team NI Team

    Messages:
    852
    We found out that the problem is due to a change in iTunes, that no longer writes the Ratings into the files (which is the source for Traktor's import).
    So this becomes a feature request, to import the Rating nevertheless the changed behaviour in iTunes.
    We will not be able to provide this in the first release, but have it high on our list of improvements.
    The workaround is to use "Sync Song Info" after importing from the iTunes node.
     
    • Like Like x 1
  6. djinet

    djinet NI Product Owner

    Messages:
    24
    Hi Friedemann,

    I don't know exactly if what I'm going to ask you has to do with what is posed in this post.

    My problem is already exposed here: https://www.native-instruments.com/forum/threads/emojis-in-tracks-labels.360959/

    Mainly I would like to know why, when I want to edit a track label, for example, comments, and I press the key combination: Windows key and point (Win +.), to enter emojis, these seem to be stored but are not displayed.

    You can check the above, after entering some emoji in some track label, for example, '⭐⭐Good Track', then press enter to store. You will notice that they are not displayed, but if you double-click again, select the text, copy and paste, for example, in MS Word, then all the characters, including the emojis, are displayed.

    I am waiting for an answer. Thank you.
     
  7. Friedemann @ NI

    Friedemann @ NI NI Team NI Team

    Messages:
    852
    In the meantime we have fixed this issue and will make it available in one of the next betas.
     
    • Like Like x 1
  8. kokernutz

    kokernutz NI Product Owner

    Messages:
    327
    Just installed 3.3.0 69 and star ratings did NOT import when dragging from the iTunes/Music node into the Track Collection.
     
  9. kokernutz

    kokernutz NI Product Owner

    Messages:
    327
    I retested this again with newly purchase tracks (iTunes/Bandcamp), added some star ratings, and did a drag and drop (all at once) from the iTunes/Apple node to the Track Collection. The star ratings were not imported.
     
  10. Sander @ NI

    Sander @ NI NI Team NI Team

    Messages:
    826
    Hi,

    Which OSX version are you using or are you using Windows?
     
  11. kokernutz

    kokernutz NI Product Owner

    Messages:
    327
    macOS 10.15.2.

    The behavior is inconsistent. Sometimes it works and sometimes it doesn't. I think a restart fixes the issue, so I guess it's probably on the macOS side.

    I'll confirm a restart fixes the issue the next time it happens.
     
  12. Jayrock79

    Jayrock79 NI Product Owner

    Messages:
    263
    I'm still using the latest 10.14 and during testing TP 3.2.1 i could find out the following behaviour.

    When i import music folders (iTunes Media is one of my music folders) the star ratings don't get imported.
    When i import songs into my collection, using Itunes node/playlist, they'll be imported.

    Actual i use smart playlists for the different star ratings in iTunes, open the playlists in Traktor and square the tracks by sorting in the appropriate playlist. Mark the tracks and edit the rating.
     
  13. ffntal

    ffntal New Member

    Messages:
    7
    I would like to add to this problem the issue with Traktor importing the iTunes album ratings for tracks that are not rated but are part of the same album that others which are i.e. iTunes: <track 1 - album A - 5 stars>, <track 2 - album A - 0 stars>, Traktor: both tracks have 5 star rating.

    I already opened another post regarding this one but I thought it would be worth adding my findings in this one too.