1. Hi everyone,

    Apple just released Logic Pro 10.5 for MacOS 10.15. We found out that Crush Pack, Mod Pack, Replika, and Replika XT will crash.

    Our teams are currently working on a fix, and we hope to have this out to you as soon as we can!

    Best wishes, 
    The NI Team

    Dismiss Notice

Still get crackles

Discussion in 'Technical Issues (Archive)' started by Mr Mahogany, Feb 14, 2010.

Thread Status:
Not open for further replies.
  1. Mr Mahogany

    Mr Mahogany NI Product Owner

    Messages:
    705
    If you're using Maschine is standalone how do you sync the 2 up?
     
  2. Sparksta

    Sparksta NI Product Owner

    Messages:
    228
    Found the problem...

    turned off the Multi Processor Mode in Cubase. Now I can play in the beat without crackles.

    When its done and the track is getting fuller I switch it back on.
     
  3. prolit

    prolit Forum Member

    Messages:
    33
    you should try getting a better computer
     
  4. aqirforce2high

    aqirforce2high NI Product Owner

    Messages:
    231
    yeah ive been having the same issue since day. crackles in cubase studio 5, but only with controller, not with keyboard or in standalone. this is a real drag.
     
  5. ew

    ew Moderator Moderator

    Messages:
    21,328
    Download dpclat and find if you've got DPC issues:

    http://www.thesycon.de/deu/latency_check.shtml

    My old system blew up a little over a week ago, and with my new system, I was having DPC spikes. The solutions in my case? Disable the COM/LPT ports in my BIOS- if you just disable them in Windows, the IRQs are still reserved.

    The other thing in my case? Uninstalling my mainboard's OC utility that runs in Windows- I can do all of that in my BIOS anyways.

    With these three simple steps, my DPC latency went from 11,000 microseconds (more than enough to cause pops) to 18 microseconds. YMMV...

    ew
     
  6. Funky D

    Funky D Forum Member

    Messages:
    71
    Ahem... you could've saved yourself some hassles by actually reading this thread...

     
  7. Sparksta

    Sparksta NI Product Owner

    Messages:
    228
    Oh sorry, Must have overseen it.

    I don't think its the Computer its powerful enough.
    I will try the dpc Spike check.

    Sounds like my Problem. But in my Case it could also
    Be another Hardware causing the irq conflicts.

    But ill try
     
  8. smithwessen

    smithwessen NI Product Owner

    Messages:
    1,177
    this has nothing to do with maschine, its to do with either your computer bios settings, drivers or cubase's poor implemention of multicore support along with timestretch they are both the worst on the market.

    first follow my steps,

    1) make sure in your bios, you have no type of speed step, or anything that will downclock your cpu


    2)disable your lan card and any wireless internet device.
    check if you still have cutouts

    3) disable multicore support in cubase
    check if you still have cutouts

    4) increase your buffer settings

    folloe these steps and let me know how you got on,

    if stuck with any stages google it
     
  9. Sparksta

    Sparksta NI Product Owner

    Messages:
    228
    Hi,

    have already checked everything. No speed step, No lan card, On board sound disabled.

    Only thing working is to uncheck multi-core support....

    I also disabled something in my bios pointing to IRQ channels. Dont know if these are the right ones but if they are it did not work.
     
  10. smithwessen

    smithwessen NI Product Owner

    Messages:
    1,177
    lastly look for and disable

    CPU Enhanced Halt (C1E)
    C3/C6/C7 State Support
    CPU EIST Function

    the above are all types of speed step Disable all,

    lastly please post what you are using soundcard, motherboard etc
     
  11. Sparksta

    Sparksta NI Product Owner

    Messages:
    228
    looks like you just made my day......

    Thanks m8
     
  12. smithwessen

    smithwessen NI Product Owner

    Messages:
    1,177
    Dropouts or crackles on playback or using any firwire/usb/pci device

    steps to take

    1) increase your buffer settings

    this is the most simply step, the lower the buffer = more strain on cpu
    increase bufer

    if dropouts occur even when using a higher buffer settings see below


    2) make sure in your bios, you have no type of speed step, or anything that will downclock your cpu

    CPU Enhanced Halt (C1E)
    C3/C6/C7 State Support
    CPU EIST Function

    these play havoc with asio and cause most issues
    check to see if problems are terminated.
    (firewire interfaces are most severely affected by the above)

    3) make sure you have no downclocking/power saving/ speed stepping apps or drivers installed
    usually comes with motherboard drivers or motherboard manu's websites.


    4)disable your lan card and any wireless internet device.


    check if you still have cutouts
    (can cause dpc spikes)

    (cubase users only)
    5) disable multicore support in cubase
    check if you still have cutouts


    just a summary of whats needed if any users experience any sort of drop outs or crackles etc
     
  13. Sparksta

    Sparksta NI Product Owner

    Messages:
    228
    hmmm.

    just restarted and the crackles are back. Ill see if the Bios settings changed again.
    ---
    nope still the same. Guess it was working like usual in the beginning but when stressing it more it gets worse.

    Im out of ideas... I tryed everything... If bios also doesnt help i dont know.

    Guess i have to get a new DAW or PC.

    Had no problems with Ableton but i dont like the GUI. And since i just got into Cubase this sucks a lot hehe.

    The PC is new but next one will be a MAC for sure....

    well for now ill disable multi-processor support and hope that bigger Projects can be played without crackles with Multi support. :(
     
  14. aqirforce2high

    aqirforce2high NI Product Owner

    Messages:
    231
    disabled ports in bios, disabled multi processer support in cubase, increased buffer size, disabled lan card and its still glitching out.
     
  15. smithwessen

    smithwessen NI Product Owner

    Messages:
    1,177
    sorry guys i tried my best

    the points above are still valid for any daw using a firewire usb audio device, to gain optimal proformance
     
  16. ColdSteel

    ColdSteel NI Product Owner

    Messages:
    40
    You're not alone, I have exactly the same problem on a similar system.
    Intel Core2Quad 9550, 4GB RAM, MotU 828mkII Firewire Interface, WinXP SP3

    Maschine runs fine in standalone mode; as soon as I use the controller within Cubase - crackles. All other plugins (like Kore with its controller) are working absolutely fine. I tried different hardware settings, BIOS tweaks and so on but nothing seems to solve the problem.
     
    Last edited: Mar 17, 2010
  17. Funky D

    Funky D Forum Member

    Messages:
    71
    Did you try disabling multi-core support in Cubase, as suggested earlier in the thread?

    I'm pretty sure this is the only solution for Cubase users... Cubase's multi-core implementation isn't the best, and Maschine doesn't have multi-core support in the first place. Combine these two elements and you get the crackling problems.

    If someone is running a modern Cubase system in XP with multi-core enabled and no problems with Maschine, I'd love to hear about it... otherwise, no need to keep rehashing what's already been stated. I haven't tested in Win7 extensively, but wouldn't be surprised if it were the same. UAD cards were having similar spiking problems with Cubase and multi-core enabled.

    Sparksta, don't stress leaving the multi-core support disabled... it seems any performance benefit is lost as the project size grows, because the ASIO meter doesn't seem as stable with multi-core enabled. A new PC will won't fix anything, but an efficiently-coded DAW (Sonar, Reaper) probably would :)

    That being said, I'll stick with Cubase and it's flaws... it works well enough for me.
     
  18. ColdSteel

    ColdSteel NI Product Owner

    Messages:
    40
    Disabling multi-processor support isn't an option for me as I need the CPU power. So I have to wait for another solution - like optimizations in Maschine or Cubase.
     
  19. Mr Mahogany

    Mr Mahogany NI Product Owner

    Messages:
    705
    For me I thought that dis abling multi core was doing the trick but thecrackles came back. Since no other program or device does this for me I'm thinking this is something that N.I. could address. This really makes Maschine hard to work with.
     
  20. Funky D

    Funky D Forum Member

    Messages:
    71
    Mr Mahogany, did you try checking and unchecking the multi-processing option again? I think Cubase will sometimes "reset" this option without warning... I mentioned the problems with Cubase and UAD cards in my previous post, and UA provided a "clear CPU affinity" option in their drivers to force single CPU usage, which helped with Cubase issues. UA has apparently fixed the problems with Cubase with their latest release, but this is just more proof that Cubase has issues in multi-processor environments that plugin makers are forced to work around.

    Has anyone submitted this as a bug with the betas? NI could probably do some tweaking to make Maschine more Cubase friendly, but it's hard to expect them to when most of the problem lies in Cubase.
     
Thread Status:
Not open for further replies.