Support for M1 Macs

Discussion in 'Feature Suggestions' started by Bryan Lake, May 24, 2021.

  1. Bryan Lake

    Bryan Lake NI Product Owner

    Messages:
    32
    I just bought a new M1 Mac Mini and I'm wondering if Reaktor will even work on the new M1 Macs. I don't believe an Apple Silicon update has yet been released for Reaktor but the vast majority of NI plugins appear to have gotten one. Does that mean we can't even install Reaktor on an M1 system? Please understand that I'm new to Mac so forgive me if I'm not using the right nomenclature.
     
  2. Tony Jones

    Tony Jones NI Product Owner

    Messages:
    386
    You can install it but NI can’t give a lot of support. I’m using it a bit
     
  3. Bryan Lake

    Bryan Lake NI Product Owner

    Messages:
    32
    I'm guessing Reaktor will take the longest of all NI's product line to provide full support for Apple Silicon due to the sheer depth of Reaktor's architecture. Maybe it will run somewhat decently via Rosetta 2.
     
  4. EvilDragon

    EvilDragon Moderator Moderator

    Messages:
    19,262
    Porting Reaktor Core to ARM instructions is the most difficult part of the whole thing.
     
    • Like Like x 1
  5. Mutis

    Mutis NI Product Owner

    Messages:
    701
    But when NI started to do it? After Apple M1 release or they were aware before?

    Just curious...
     
  6. colB

    colB NI Product Owner

    Messages:
    3,824
    Makes sense - porting an optimising compiler to a completely different cpu architecture is definitely not just a quick recompile of the c code.
     
    • Like Like x 1
  7. Paule

    Paule NI Product Owner

    Messages:
    7,326
    Is win 7 pro supported for the future Reaktor or do I need win 10, which isn't my OS?
     
  8. EvilDragon

    EvilDragon Moderator Moderator

    Messages:
    19,262
    For now it still works on W7. But I wouldn't expect that to last forever.
     
    • Informative Informative x 1
  9. Paule

    Paule NI Product Owner

    Messages:
    7,326
    Okay, then I can't use UL uploads saved with the new Reaktor.
    And build more instruments by my own with R6.4!
     
  10. EvilDragon

    EvilDragon Moderator Moderator

    Messages:
    19,262
    Sure you can, latest version of Reaktor 6 still installs on W7 just fine AFAIK.