1. Hi everyone,

    Apple just released Logic Pro 10.5 for MacOS 10.15. We found out that Crush Pack, Mod Pack, Replika, and Replika XT will crash.

    Our teams are currently working on a fix, and we hope to have this out to you as soon as we can!

    Best wishes, 
    The NI Team

    Dismiss Notice

Traktor 2.8.0

Discussion in 'TRAKTOR PRO / TRAKTOR SCRATCH PRO' started by Plangin, Apr 28, 2015.

  1. Fryer77

    Fryer77 NI Product Owner

    Messages:
    56
    i`m not sure these drivers 3.0.1 that are on the NI site for windows didn`t work for me in the past , i use some older drivers , that i have downladed years ago.
     
  2. dial8d

    dial8d Forum Member

    Messages:
    26
    Ok, so 2.8.0 does not work properly with DJM 900 Nexus. :mad:

    I guess because its a 32 bit driver. Checked Pioneer website, and no 64 bit driver available. traktor wont run in 32 bit mode either. Great job :thumbsdown:
     
  3. innazone

    innazone New Member

    Messages:
    4
    Hi NI, thanks for releasing a 64 bit version, you will probably be aware of this rather petulant post on the Pioneer forum (from Pioneer) asking people to explain why they need to use the 64 bit version of Traktor Pro:

    "Maybe I should rephrase the question...

    Why is running a 64bit version of a DJ application important to you?

    We understand the technical angle of "more resources" -- but what is it that YOU need from the program? What does the 64bit version do better when you're using it?"

    Given that DJM 900 nexus users are unable to use the upgrade, a chicken / egg stand off is developing, with people unable to use the upgrade, and thus unable to explain the advantages. I'm a little surprised that they haven't sorted this out with you guys, but how would you advise people to answer the question. What are the advantages to upgrading to 64 bit, were one able to so?

    Many thanks,
     
    • Like Like x 1
  4. lethal_pizzle

    lethal_pizzle NI Product Owner

    Messages:
    10,601
    Yes it will, read the readme file
     
  5. lethal_pizzle

    lethal_pizzle NI Product Owner

    Messages:
    10,601
    From the release notes:

    TRAKTOR PRO now has 64-bit architecture. By making TRAKTOR PRO a 64-bit application, it allows TRAKTOR PRO to access all the available RAM on computers with 64-bit operating systems; previously, TRAKTOR PRO could only access a maximum of 2GB of RAM regardless of how much RAM was actually installed and available on the computer. By giving TRAKTOR PRO access to more RAM, it will increase performance of the software by allowing management of more items (larger Track Collections, more Remix Deck samples, better playback caching, etc.).


    Are you still using a 32-bit version of Windows? With this release, the 32-bit version of TRAKTOR PRO can now also access an additional 1GB of RAM (if the computer has it available) providing additional performance and stability.
     
  6. OY3NOH

    OY3NOH Active Member

    Messages:
    249
    It is not about what people need. It is about what the future is. And the future is 64bit.

    If everytime something evolved people like Pioneer would have said "what for" we would still live in caves.
    Even though 64bit might not give you a benefit using a DJ Software now it is just stupid to stay with 32bit while everything else in Software business goes to 64bit.

    And for all Pioneer Users it is possible to use 2.8 as 32bit anyway until pio gets up their asses to develope some 64 bit drivers
     
    • Like Like x 1
  7. alec.tron

    alec.tron NI Product Owner

    Messages:
    634
    I guess this is just Pioneer asking their customer base - as it should be... [NI / Traktor team take note of Developer/Company - customer interaction...!] - how they do use a certain feature and what it does for them in practical use cases.
    For those interested, this is the thread:
    http://forums.pioneerdj.com/entries/81409009-64bit-Software-Users-Question-for-you-

    I do hope the same communication happens between NI & Pioneer, who are partners & should exchange & cooperate for the sake of their customer base... but looks like that hasn't so far, seeing that people with 'Certified' hardware/mixers are having trouble now.

    c.
     
  8. Plangin

    Plangin NI Product Owner

    Messages:
    1,577
    It's 2015. Nuff said. o_O
     
  9. DJ Deeply

    DJ Deeply New Member

    Messages:
    23
    Have you actually tried to connect DJM 900 Nexus after installing 2.8.0 ? Anyone?
     
  10. ISaFeeliN

    ISaFeeliN NI Product Owner

    Messages:
    49
    DDJ-T1 also doesn't work with 2.8.0. Had to revert to 2.7.3 again.
     
  11. Masterbit_Tf

    Masterbit_Tf NI Product Owner

    Messages:
    432
    Anyone else having this Issue? Is this a known or official fact?
    Does this Issue also apply while starting the 2.8.0 as 32bit?
    Otherwise 2.8.0 would be out of Discussion for me.
    I still need my DDJ-T1 in some environments with old crappy Players.
     
    Last edited: Apr 30, 2015
  12. stroumf77

    stroumf77 NI Product Owner

    Messages:
    713
    My DDJ-T1 works fine to me.
     
    • Like Like x 1
  13. ISaFeeliN

    ISaFeeliN NI Product Owner

    Messages:
    49
    What version of drivers are you using? And what OS?

    I'm using Win10 Preview (latest build)
     
    • Dislike Dislike x 1
  14. stroumf77

    stroumf77 NI Product Owner

    Messages:
    713
    Latest drivers, everything updated . Mavericks 10.9.5
    Try to import again the .tsi settings for pioneer DDJ-T1.
    I don't know nothing about windows.
     
  15. djdig

    djdig New Member

    Messages:
    22
    lol NI moves to 64bit which is where it needs to go and the overpriced lords of dj equipment pioneer ask why do you need 64 bit version of it to their customers.... LOL, why did they not make their hardware compatible with 32/64 bit, its not like this concept is new.
     
  16. Plangin

    Plangin NI Product Owner

    Messages:
    1,577

    It is only Windows related... The latest OS X versions are 64 bit only. Since 10.7, a 64 bit processor is mandatory (Core 2 Duo and later). So on the Mac side, manufacturers are forced to provide proper 64 bit drivers instead of wasting time with senseless discussions.

    Windows is still available as 32 bit, also the upcoming Windows 10. So it will take another couple of years until Microsoft will be brave enough to pure 64 bit. :confused:
     
  17. Masterbit_Tf

    Masterbit_Tf NI Product Owner

    Messages:
    432
    Please(!) don't post issues about not working Controllers, Features or anything else in this Thread unless you are using an official Traktor 2.8.0 supported operating System ;)
    Other People might get a total wrong impression about the stability of this quite new Release and might think that its unsafe to use it.
     
    • Like Like x 3
  18. DJSE

    DJSE New Member

    Messages:
    9
    New version works fine for me (even solve some problem I had with 2.7). Im actually using it with the Audio 8.

    But I have same issue as you with the DJM900nxs. The mixer works fine as a soundcard for other program, but not in Traktor (exept in shared mode but can't use the timecode with that).

    Hope Pioneer will update their driver soon abd this is just a misunderstanding betwen them and NI about the release date...

    Good for me I have the Audio 8. Never update again before work :)
     
  19. ruslinarchtw

    ruslinarchtw New Member

    Messages:
    3
    hi has anyone used the xdj1000s with 2.8 yet i would love to see a vid showing the touch interface and features as these are relatively cheap (£700-£850) (compared to nexus) and will look professional in your setup.
     
  20. OY3NOH

    OY3NOH Active Member

    Messages:
    249
    Just use the 32bit 2.8 as mentioned in the read me file. You can use the DJM as usual then.

    Not NIs fault if Pioneer is living in the past....
     
    • Like Like x 2