1. Please do not install macOS 10.15 Catalina yet, as Native Instruments software and hardware products are not supported under macOS 10.15 yet. For more info, please go HERE!
    Dismiss Notice

Traktor dj w s2 mk2

Discussion in 'TRAKTOR DJ (for iPhone and iPad)' started by jcolinger, Mar 4, 2014.

  1. jcolinger

    jcolinger NI Product Owner

    Messages:
    55
    I'm thinking about buying an S2 MK2 for use with Traktor DJ for iPad. I read some comments and heard some mixed feelings from online sources.

    Just looking for a final recommendation...

    Yes or no? What would be your vote?
     
  2. trance alba

    trance alba Forum Member

    Messages:
    612
    My vote would be a yes, as long as you find one to try your iPad with first.

    Try before you buy.

    I'm still on ios6 so mine works fine, but there's still all manner of issues with ios7, and it seem very hit and miss, so I'd check your iPad compatibility by testing it first.
     
  3. djtsmooth

    djtsmooth Forum Member

    Messages:
    108
    Exactly what trance said, the s2 mk2 "may" work with an ipad using ios6. So if you have an older model ipad that you are not going to allow to update to ios 7 you might be ok. If you have any kind of new ipad, or have allowed your exsisting ipad to update to ios 7. Forget about it it will not work. Good luck..
     
  4. trance alba

    trance alba Forum Member

    Messages:
    612
    As far as I'm aware it was not a case of:
    Ios6 - hit and miss
    Ios7 - forget it

    It was the case that:
    Ios6 - almost always worked
    Ios7 - hit and miss

    Or is that wrong?

    I'm sure there's been people say here that ios7 worked for them with the S2 and S4.
     
  5. Steven V

    Steven V Forum Member

    Messages:
    74
    Ios 7.1 should be out any day. So that might fix some issue and another thing too. NI might have a update by then. Let's see what happen. I think that it's going to be straighten out soon. Apple really messed things up with ios7. Which cause a lot of apps to be all whacked out. I think NI haven't yet to release an update yet due too ios 7.1 is not out yet. We can all just cross fingers and hope all get iron out.
     
  6. Steven V

    Steven V Forum Member

    Messages:
    74
    One more thing to add. I know ios7.1 was a beta test for the developers to test there apps. I think NI iron all there kinks out :)
     
  7. XO Gold

    XO Gold Member

    Messages:
    35
    i hope they get this fixed soon... i REALLY want to buy an S4 for my iPad and iMac, but don't want to have the issues that a lot of you are having.
     
  8. thebeatworx

    thebeatworx Forum Member

    Messages:
    50
    There is a serious "hit or miss" issue with iOS 7 and hardware (meaning that it is intermittent) and it will be solved with iOS 7.1.
     
  9. basile

    basile NI Product Owner

    Messages:
    144
    7.1 has just been released so guess we'll know for sure soon enough
     
  10. XO Gold

    XO Gold Member

    Messages:
    35
    i hope you're right
     
  11. Steven V

    Steven V Forum Member

    Messages:
    74
    Well it's still not complete yet! Now NI has to do its part. By releasing there new firmware that will go with 7.1. Let's hope they release there firmware soon
     
  12. Native Coconut

    Native Coconut Member

    Messages:
    34
    Maybe the NI development team has already done it's part... ;)

    Let's wait for the official word from the good people at NI marketing...
     
    Last edited: Mar 10, 2014
  13. basile

    basile NI Product Owner

    Messages:
    144
    Having tested it for half an hour there, things are certainly looking promising...
     
  14. manaman

    manaman New Member

    Messages:
    11
    Upgraded to iOs 7.1 and now Ipad Air + Kontrol S2 Mk2 seems to work without the sound dropouts previously experienced under iOs 7.0

    Quite a relief!
     
  15. kassidy

    kassidy NI Product Owner

    Messages:
    11
    It really works... I played in a club with my S4 mk2 and my iPad Air upgraded with iOs 7.1 for almost two hours without any crash.
    As NI technical support wrote was a iOs Bug.

    Ciao
     
  16. XO Gold

    XO Gold Member

    Messages:
    35
    the S2 / S4 product page no longer carries the disclaimer at the bottom of the page stating that they are having issues with iOS 7
     
  17. trance alba

    trance alba Forum Member

    Messages:
    612
    So it seems I can now upgrade my iPad mini beyond iOS 6 and not have the issues with my S2 Mk2 that everyone else has.
     
  18. kassidy

    kassidy NI Product Owner

    Messages:
    11
    I confirm what I wrote yesterday. Today I played in a private party for 4 ours with my S4 mk2 and my iPad Air upgraded with iOs 7.1 without any problem.

    Ciao
     
  19. kassidy

    kassidy NI Product Owner

    Messages:
    11
    iPad 2 users don't upgrade to iOs7. The processor doesn't support both iOs7 and Traktor Dj. Too heavy.

    Ciao
     
  20. trance alba

    trance alba Forum Member

    Messages:
    612
    Well mine works, but I wish I'd known that a week ago.

    My iPad mini (effectively an ipad2) is not as smooth as it was on ios6, in various ways.