Traktor doesn't recognize S2

Discussion in 'KONTROL S2 / KONTROL S4' started by jtleniger, Mar 15, 2012.

  1. jtleniger

    jtleniger New Member

    I have Traktor 2.1.2 installed, and the driver for the Kontrol S2 is installed. I've tried uninstalling and reinstalling both.

    Traktor sees the Kontrol S2 as an audio interface, and sort of sees it as a controller.

    If I pick the default Kontrol S2 mapping in the controller manager, under In Port and Out Port it says n/a, as if it's not even there.

    If I pick Generic Midi Controller, it shows up under the In Port and Out Port, but then won't do anything if I try to do a midi learn to use a function.

    Why can't Traktor recognize a controller MADE FOR IT?

    Thanks in advance.
  2. jiggle

    jiggle Forum Member

    Have you tried changing the in & out port to S2?

    Have you tried running the wizard button in preferences?
  3. jtleniger

    jtleniger New Member

    Sorry, I guess I didn't explain very well.

    The in and out ports don't have an option for the S2.

    I've run the wizard multiple times; didn't help.
  4. jayjay91

    jayjay91 New Member

    i've got exactly the same problem! i'm from germany and i don't know what i have to do, if i want to replace or repair my kontrol s2...
    because i'm really sad about it doesn't work :( a week ago it worked very well...
  5. jcuzofp

    jcuzofp New Member

    Same with me, except that I use reloop contour interface edition.

    It worked for a few minutes, but i forgot to install the ASIO driver so I had no proper sound, after I installed those, I could control Traktor with my Interface, only vice versa. (So when I for example pressed play on Traktor, the play button on the interface would light up). I thought that if id update to Traktor Pro 2 it would work, but now the system wont even find the Interface....
  6. mcprescribed

    mcprescribed New Member

    We had this issue and my friend suggested we installed the "Controller Editor" software also downloadable for the device, this seemed to fix the input issue, I checked back after I reopened traktor pro 2 and I could then select S2 under in-puts.

    Hope this helps!
  7. Deodex

    Deodex New Member

    I'm having the same issue. Uninstalled/reinstalled traktor, controller editor, kontrol s2 driver, none of that worked. It's got to be a software issue, I can adjust settings within traktor between audio routing, output settings, controller editor, and "kontrol s2" at the very bottom of the settings list and get it to where the software responds to the controller input, but I have no sound. I can rearrange it to where the software has absolutely no response to the controller input, but the speaker connected to the controller has sound. I can also manage to get it where the software responds to the controller's input, I have sound, but the on-screen sliders (volume, tempo, fader) are gone and they don't respond to controller input. I'm completely stumped, especially since it worked fine 4 days ago.
  8. imtony

    imtony New Member

    I have a similar problem, I think I've established that its the USB port on the S2, would anyone know where I can get it repaired in or around Manchester UK?