Traktor Kontrol S4 controller not working

Discussion in 'KONTROL S2 / KONTROL S4' started by jcolinger, Oct 31, 2011.

  1. jcolinger

    jcolinger NI Product Owner

    My S4 is not connecting. The USB light is flashing.

    MacBook Pro 10.6

    I had Traktor Pro2 installed prior to installing the S4 and software. I plan to uninstall the TP2 software and sell the license now that I have the S4.

    I've tried all USB ports. I've tried thru a hub. I'm going to hook to a PC to see if it is a problem with software/hardware on my Mac.

    But, I've seen that others have had this issue and some suggestions to resolve... though I'm not sure what strategy I should take.

    Ironically, I used a Behringer BCD3000 with TP2 (and previous), and I've never had ANY problems at all.

    It sucks that with the S4 from NI that I'm dealing with this issue.

    Any suggestions welcome...
  2. zephry

    zephry NI Product Owner

    Did you by chance install and update your new s4 and software, then open your other tp2 software you are planning on selling?

    All versions of traktor get installed the one on you desktop may not be the one you need to click that has the drivers and info for your s4.

    Just a thought.

    Also check your usb devices to make sure the controller is enabled there. I reinstalled and had my usb port disabled that had the s4 on it. no idea why that happened but i enabled it and it worked.
    but then again I am on a pc.

    Hope this helps.
  3. jcolinger

    jcolinger NI Product Owner

    I'm going to uninstall according to the only document I found at -

    Which btw has a 55% negative article rating? Does Native Instruments read the statistic that 55% of the ratings on the only article from NI to uninstall Traktor on a Mac are negative?

    Anyway, I did a full backup with Time Machine last night. Tonight I'll do the uninstall/install. I plan to uninstall Traktor Pro 2 and the Traktor S4 software. Kind of unfortunate as I liked the idea of having them both for the times that I simply want to use my Behringer BCD3000. I like to throw it in a backpack and take it with me on trips or to parties.

    I'll report back the results.
    Last edited: Nov 2, 2011
  4. Count Zero

    Count Zero ModerAUtor Moderator

    You don't need the Traktor S4 software anymore. Pro 2 is the latest version and your S4 should work on that. (The BCD3000 would have worked on Traktor S4 as well) From your point of view Pro 2 is simply an upgrade to the older Traktor S4 software.

    Before you uninstall unplug the S4 and don't plug it back in again until after you have finished installing the software. You might also have some luck if you download the latest drivers from the NI website.
  5. jcolinger

    jcolinger NI Product Owner

    I did the full uninstall. No luck. I also tried the S4 on a PC and PC laptop. Still no connection, not even a "USB device detected" or anything like that. I called NI today, and they stated they would send me some info on a repair. I'm still waiting for the email.

    I am wondering if it has something to do with the USB cable and pins. Can anyone tell me how many pins are on the USB "receptacle" on the S4? I feel like the "pinned" USB cable (which is a good idea to help prevent it from falling out during a gig) may have fatigued/broken a pin... but this is a theory since I don't know what a working one looks like (if it has pins).

    Well, at least this lack of NI/Traktor for the time being is inspiring me to work on my Live skills and use my APC40.
  6. goofy22

    goofy22 New Member

    same problem but on mac

    Im having the same issue...suddenly I plugged everything as I always do in de club and start my s4 the little light show goes on and then just the master led is lid up and nothing else. The sound goest thru but nothing else is lid up or responds.
    I understand what u guys did on pc but do u know how to do this on mac? I couldnt find a way of enabling/disabling the usb device...

    thank you
  7. Ritchie_Jay

    Ritchie_Jay NI Product Owner

    Post a good photo of the USB port on the S4 without the cable in it, and also photo of the matching USB plug.

    You shouldn't be able to see bare pins in the USB port. As you refer to a pinned USB cable which makes no sense (you just use a normal USB cable), it sounds like the plastic square guiding peg of the USB port has broken off and is now in the USB cable's plug. If thats the case. Back for repair the S4 goes.
  8. jcolinger

    jcolinger NI Product Owner

    Yes, I assume that is the issue. I have already sent it to NI for repair. Waiting for status. I'll keep the thread up to date with info.
  9. Trollen

    Trollen New Member

    Behringer BCD3000 vs. Traktor S4

    Hi, it seems to me, since you have both Behringer BCD3000 and Traktor S4, you can answer me how much better tractor s4 is compared to BCD3000. Sincerely maja

    I just do not know what to buy, since I'm new to the field. 900 doller a lot of money.
  10. SESIL

    SESIL New Member

    Same issue....

    Hey, I was just wonder if you solved this issue... and if yes... how did u do it...
  11. goofy22

    goofy22 New Member

    Well I solved it in my case....more products from NI such as Maschine and x1 were all doing the same somewhere I've heard if u restart your mac and hold numbers 3 and 2 together it starts your OS in 32bit mode...when I did that all the problems went away and ever since all my native instruments products work try it either with holding numbers 3 and 2 together when see the apple logo for about 15-20 sec...if that doesnt work try it with holding 6 and 4 and if non of it works then problem is somewhere else I guess...
  12. DJ Odaddy

    DJ Odaddy NI Product Owner

    Yeah, but you shouldn't need to do that. Maybe you have some old drivers installed? I am using my make in 64 bit mode, and S4 works really well.
  13. MichaelKMusic

    MichaelKMusic Forum Member

    Try updating to OSX Lion
  14. Ld942

    Ld942 New Member


    Hi mate I too have exactly the same issues with my s4 and when I contacted Native they tried to blame my os 10.5.8. Advised me upgrade to the 10.6 Snow leopard OS. I am not happy with native instruments given the cost of the controller and I await what bull **** they will try to come off next time I receive an email from them. Well and truly pissed off

    Should have stuck with my BCD3000 it seems

    Here is a copy of their reply. Makes me laugh.

    > On 12 Jun 2012, at 14:35, NI-Ticket-System <>
    > wrote:
    > > Hello Paul R,
    > >
    > > You are using MacOSX 10.5
    > >
    > > Traktor Kontrol S4 and Traktor Pro 2 are only supported for MacOSX 10.6 and 10.7
    > >
    > > Please upgrade your OS to a compatible version and test if the problem occurs in
    > > that environment. Let me know how else I can help, in spite of the compatibility
    > > issue.
  15. davscanlon

    davscanlon NI Product Owner

    They released the S4 AFTER 10.5.8
    If you read the minimum requirements before you purchased the product you wouldn't be pissed off!

    There is a reason new technology doesn't work with old computers. Even Apple have cut off support for users of 10.4 and below. So why would a 3rd party company support old OS?

    It's like saying why doesn't my 10 year old computer work with technology made today?

    Easy solution > upgrade you Mac's OS. If 10.5.8 is the latest OS you can install, then my friend, you do indeed have an old computer. Time to upgrade....

    Don't blame NI.
  16. Ld942

    Ld942 New Member

    Ok thank you for your response my seemingly blaming N.I. For my self made problem. I did research as much as I thought I needed too. The minimum system requirements were met. As also indicated on the s4 packaging too. So this is the reason I am slightly peeved. MacBook pro purchased for the sole purpose of not encountering these problem. It's not old in my estimation and had been working fine only to all of a sudden stopped.
  17. MikaelByström

    MikaelByström NI Product Owner

    Because they do work. What's the minimum requirement for infinitely more complicated and fresh Ableton Live 9? Intel Mac with Mac OS X 10.5 or later. Ableton can because they care about compatibility and they are less lazy than NI.
  18. Ghost_On_Da_Maschine

    Ghost_On_Da_Maschine NI Product Owner

    No it's because they are only a software company not software/hardware.
    If they made hardware as well they would be doing the same thing.
  19. Ricky Woofer

    Ricky Woofer Account Suspended

    Hahahaha hence why they only have one product and NI tons , yep NI lazy and Ableton all over the place LMAO
  20. MikaelByström

    MikaelByström NI Product Owner

    Ableton Live Suite is not one piece of software, but several in one package. And "Ghost_On_Da_Maschine", Ableton is a hardware company now with Push. So you are both simply totally clueless. That's your prerogative of course.

    The Native Instruments Traktor team at least have the wrong priorities dropping OS X 10.6 support. There's no technical reason what so ever to not support OS X 10.6, an OS X version that is still widely in use, especially so among musicians.