1. Please do not install macOS 10.15 Catalina yet, as Native Instruments software and hardware products are not supported under macOS 10.15 yet. For more info, please go HERE!
    Dismiss Notice

trouble with D2 usb hub

Discussion in 'KONTROL D2' started by Spazinfo, Oct 11, 2017.

  1. Spazinfo

    Spazinfo New Member

    Messages:
    11
    Hi all,
    I come to the problem right now. :)

    my configuration: one Z1, one F1 and two D2. Computer Mac with 8Gb RAM, 2,5 GHz Intel Core i5

    I connected the first D2 to my Mac's USB, the other D2 and the Z1 to the USB Hub of the first D2, the F1 to the Hub of the second D2 ... but the F1 is not working. Same if i connect a pen drive or external HD. :confused:
    I noticed that in the first D2 the leds of USB ports are both green, while the leds of the second D2 USB ports, are both red.
    In the D2 documentation I found nothing about the management of their USB ports ... did anyone have any experience on this?
     
  2. ErikMinekus

    ErikMinekus NI Product Owner

    Messages:
    637
    I would love to know what the LEDs on the back of the D2 indicate. There is no info about it online or in the manual.
     
  3. Spazinfo

    Spazinfo New Member

    Messages:
    11
    me too, but I begin to suspect that they do not even know how they work because I'm still waiting for a response from the support center ... :(
     
  4. Spazinfo

    Spazinfo New Member

    Messages:
    11
    Update:
    I tried to directly connect the d2 with the usb problem, directly to the mac... the usbs still do not work.
    Moreover, the D2 has a different behavior from the first D2; it is not immediately operational but I have to press the loop knob to fully activate its functionality.
     
  5. Ghost_On_Da_Maschine

    Ghost_On_Da_Maschine NI Product Owner

    Messages:
    1,571
    Are you piggybacking the power or using 2 separate power adapters?
    If separate have you swapped the power supplies?
    When you tried to direct connect was it just the bad unit or still both units?

    I am piggybacking the power and going from one D2 to the next from the hub and both units have all green lights.
    The lights are red when you first turn the unit on then quickly change to green.

    Never was a big fan of hooking a hub to a hub seemed to always lead to a hardware problem down the road.
     
  6. Spazinfo

    Spazinfo New Member

    Messages:
    11
    hi Ghost.
    I use the power supply splitter but also tried with a single power supply each.
    Yes, I also exchanged power supplies.
    The problem is only on a D2, the old other continues to work well.
    The difference between the two is that bad, after turning it on, I must to press the loop knob.
     
  7. Ghost_On_Da_Maschine

    Ghost_On_Da_Maschine NI Product Owner

    Messages:
    1,571
    If it's that big a diffference and the problem follows that unit repair may be your only resolve.
    I would go ahead and open a support ticket.
     
  8. Spazinfo

    Spazinfo New Member

    Messages:
    11
    I have already opened a ticket, I sent the product on 25/10 and I'm waiting.
    They did not tell me if they fix or replace my D2 ...
     
  9. Ghost_On_Da_Maschine

    Ghost_On_Da_Maschine NI Product Owner

    Messages:
    1,571
    Be sure to post back and let us know the outcome.
     
  10. Spazinfo

    Spazinfo New Member

    Messages:
    11
  11. Spazinfo

    Spazinfo New Member

    Messages:
    11
    Problem solved, NI send me a new D2 and it works well. :thumbsup:
     
  12. Ghost_On_Da_Maschine

    Ghost_On_Da_Maschine NI Product Owner

    Messages:
    1,571
    Good to know it wasn't your setup.
     
  13. Spazinfo

    Spazinfo New Member

    Messages:
    11
  14. Ultradance

    Ultradance New Member

    Messages:
    4
    Hello Spazinfo, where you still in the warranty period? I have two and barely use them and I have exactly the same problem, one works just fine and the other one sometimes works and most of the times doesn’t , I didn't open a ticket support just yet, but I’m going crazy about this issue. Thanks in advance