1. IMPORTANT:
    We launched a new online community and this space is now closed. This community will be available as a read-only resources until further notice.
    JOIN US HERE

Unknown USB Device (Device Descriptor Request Failed)

Discussion in 'KOMPLETE KONTROL SERIES' started by brncao, Jan 6, 2017.

  1. brncao

    brncao New Member

    Messages:
    9
    My keyboard won't interface with Kontakt 5 (as stand-alone or plug-in). I get an error that says "Unknown USB Device (Device Descriptor Request Failed)." Is there a fix for this? The firmware is up-to-date and so are the drivers.

    I am using Windows 10 Pro (64-bit). I have restarted my computer and switched USB ports, but it still doesn't work! Any ideas how to fix this?
     
  2. solger

    solger NI Product Owner

    Messages:
    3,941
  3. brncao

    brncao New Member

    Messages:
    9
    Now I get this message in Device Manager:

    Human Interface Device > USB Input Device
    "This device cannot start. (Code 10)"
    "The I/O request was canceled."

    I followed the guide, but it did not help. I'm trying to test this on a different PC, unfortunately I am unable to because it's asking me to activate it first. I entered the serial number and it said it was invalid. I cannot proceed with testing this on a different computer. I'm trying to see if this is simply my desktop or the keyboard's drivers

    EDIT: now says...
    This device cannot start. (Code 10)
    {Operation Failed}
    The requested operation was unsuccessful.
     
    Last edited: Jan 7, 2017
  4. brncao

    brncao New Member

    Messages:
    9
    After pulling out all the USBs and plugging it in into a different port, it's working again. The M/B's rear USB ports were filled up. I'm guessing it was overloaded and couldn't provide enough power? I'll try getting a powered PCIe USB card to see if that'll alleviate the USB ports.
     
  5. brncao

    brncao New Member

    Messages:
    9
    Update
    I just installed a PCIe USB 3.0 card and it hasn't given me any errors since then. It could've been issues with the driver, controller, and/or power. The controller is by Fresco Logic and this card is powered directly from the PSU to ensure adequate power is being given to it.
     
  6. nrsiddle

    nrsiddle New Member

    Messages:
    9
    Hello everyone, hope you are all well.

    I've been having an ongoing issue that started over a year ago with my laptop. One day out of the blue one of the USB ports decided to not recognize anything I insert b2bappointmentsetting.com/.
    I've tried multiple devices with the same result. When I insert a USB device the notification sound plays that the device has connected and then it disconnects and says that
    the device is not recognized. Recently however I connected an external hard drive and it remained connected for longer than usual, about 5 seconds. I was about to click into it when it disconnected.


    [​IMG]

    I have check multiple websites for fixes and followed some of them with no success. Here is some of the stuff I tried:

    • Uninstalling all the devices in the Universal Serial Bus Controllers and then restarting.
    • Updating the drivers for all the USB devices and restarting.
    • Running a "chkdsk" command prompt thing that didn't seem to do much.
    • Attempting to follow the instructions of a SOLVED post on TomsHardware that required going into the registry and best spin bike reviews deleting stuff but I didn't continue as I was unsure.
    Below I've listed the specs of my laptop just in case it's useful:

    • Acer Predator Helios 300
    • Windows 10 Home 64bit (Up to date)
    • Intel i5 8300H 2.30GHz
    • 8GB DDR 4 RAM 2666MHz
    • Nvidia Geforce GTX 1060 6GB DDR5
    • Samsung 960 EVO SSD 250GB
    • 1TB Hard Drive
    • The laptop is 2 years old.
    The laptop is in excellent condition as I take care of my stuff. I hardly ever use the laptop's keyboard and trackpad as I have a USB keyboard and mouse. The laptop looks new.
    NOTE: I have sent an email to Acer so waiting to hear back from them, if ever...

    So any idea how to correct this issue with the USB port?
    Thanks for reading.
     
    Last edited: Nov 25, 2021
  7. DeepThumb

    DeepThumb NI Product Owner

    Messages:
    188
    Hi nrsiddle,

    Have you installed all drivers for your NI gear?
    Maybe it's worth to look for additional not installed drivers in Win10's update section.
     
  8. nrsiddle

    nrsiddle New Member

    Messages:
    9
    yes, I installed all drivers. writing a business plan techwhiff.com/learn/
     
    Last edited: Nov 24, 2021
  9. nrsiddle

    nrsiddle New Member

    Messages:
    9
    This happened shortly after the 204 updates. Not able to identify the specific hardware causing the issue going into properties and the various details. Tried unplugging the mouse, keyboard, webcam. Reinstalled chipset driver.

    Any way to identify the specific hardware causing this?
    [​IMG] Attached Thumbnails[​IMG]
     
    Last edited: Dec 21, 2021
  10. nrsiddle

    nrsiddle New Member

    Messages:
    9
    no response.
     
  11. Goon

    Goon NI Product Owner

    Messages:
    884
    Could quite possibly several things,
    1. the usb port on PC is not working correctly, especially as you say an externl hard drive also failed on the usb port.
    2. Are the NIHostIntegration services running, as these are needed.
     
  12. nrsiddle

    nrsiddle New Member

    Messages:
    9
    thank you for the suggestion.
     
  13. Jeremy @ NI

    Jeremy @ NI Support Team NI Team

    Messages:
    1,339
    Hey, sorry to interrupt but our community has moved! This forum is now a read-only archive. Please visit our new community: https://community.native-instruments.com/ Just search for a topic and continue the conversation over there, or create a new post if it doesn’t yet exist in the new forum.Thanks and see you over there.