1. Please do not install macOS 10.15 Catalina yet, as Native Instruments software and hardware products are not supported under macOS 10.15 yet. For more info, please go HERE!
    Dismiss Notice

Upgrading Duo to Pro

Discussion in 'TRAKTOR PRO / TRAKTOR SCRATCH PRO' started by bartjunited, Jun 12, 2013.

  1. bartjunited

    bartjunited NI Product Owner

    Messages:
    310
    Apologies in advance for my post.

    I have been writing to NI but the person who has been assisting me (Sara) has been useless when replying to simple questions.

    I am running Duo at the moment with my 1210's.

    Ive had the odd issue of the left deck cutting out & then of Traktor playing in reverse which no one could answer. NI suggested that i upgrade to Pro as this would resolve the issue.

    On the whole I am very happy with Duo & dont want to upgrade unless i have to.

    I have a ghost image of my set up which I can revert back to if needed.

    2 questions

    1 - if i upgrade to Pro what stable version should i upgrade to
    2 - is the upgrade process simply downloading the version I want & running the exe for it to upgrade Duo to Pro

    Apologies & thanks in advance

    Bart
     
  2. DJ Freshfluke

    DJ Freshfluke Traktor Mod Moderator

    Messages:
    26,753
    ticket number?
     
  3. bartjunited

    bartjunited NI Product Owner

    Messages:
    310
    Ticket#2013042310011118
     
  4. DJ Freshfluke

    DJ Freshfluke Traktor Mod Moderator

    Messages:
    26,753
  5. bartjunited

    bartjunited NI Product Owner

    Messages:
    310
    thanks

    I am happy to upgrade if the process is straightforward and it will help me in the long run given duo is no longer supported.

    would you recommend to upgrade

    and as mentioned I have the 2.6.0 update, can I just run this to get the upgrade to pro

    thanks again

    Bart
     
  6. djivobutnot

    djivobutnot NI Product Owner

    Messages:
    257
    My humble experience with Traktor Scratch leads me to think, that your problem is coming from a missing channel. Check your cart and needle, and most importantly - your cables. If you are using multicores, plug the turntable directly into Audio 4 DJ, and see if the problem is still there. If it is gone, the multicore is bad, if still there check the TT's cables