Upgrading to 1.3 from Traktor Scratch 1.0 - 1.2 *Please Read*

Discussion in 'TRAKTOR SCRATCH' started by djquartz, Jul 22, 2008.

Thread Status:
Not open for further replies.
  1. djquartz

    djquartz NI Product Owner

    Messages:
    5,321
    I just wanted to give everyone a heads up before upgrading.

    As stated one of the new features of Traktor Scratch 1.3 is unicode support.

    Wikipedia explanation, http://en.wikipedia.org/wiki/Unicode

    Traktor Scratch 1.3 will require you to convert your collection if not it will only work in read-only mode.

    The problem is if you convert your collection it will no longer be backward compatible with earlier versions of Traktor Scratch or Traktor.

    This applies to the hotkey files as well, you can open a hotkey file made in an earlier version of TS/Traktor with 1.3.

    However, if you make changes and save the hotkey file with 1.3 you cannot use it with earlier versions.

    One suggestio... if you're not wanting to lose your original collection make a back of your collection,hotkey files and settings files before installing 1.3.

    This will allow you to rollback if you need to for any reason. Then you can replace the collection files, etc with the original copies and reinstall an earlier version of Traktor Scratch.

    Refer to page 77 in your Traktor Scratch manual.

    NOTE: If you're using the SSL hotkey file, there is a new one posted on the last page of that thread.
     
    Last edited: Jul 25, 2008
  2. progen

    progen NI Product Owner

    Messages:
    265
    I believe that unicode support feature would be a really welcome addition. Perhaps more DJs where I am might try Traktor Scratch now because they have a lot of their mp3s' ID3 tags in Mandarin.
     
  3. plexor1

    plexor1 NI Product Owner

    Messages:
    29
    Question,

    If you download TS 1.3, Do you have to convert your collection to use tracks in T3.3 (or T3.4)? I never use TS, but I want the latest update for my setup. Thanks!
     
  4. djquartz

    djquartz NI Product Owner

    Messages:
    5,321
    @ Plexor1

    You don't have to upgrade to TS 1.3 if you're using Traktor 3.3. You would need to install Traktor 3.4 only.

    However, the same warning applies because 3.4 will need to convert your collection for full functionality.

    Traktor 3.4 has unicode support as well as all the other updates.
     
  5. plexor1

    plexor1 NI Product Owner

    Messages:
    29
    Thanks Quartz,

    As soon as I started d/ling T3.4, I saw the warning. I searched my Scratch and Traktor 3 folders and didn't see no TKS, hotkey, collection files saved. I basically typed TKS and Collection in my finder browser and found a bunch of Terminal apps and files saved as collections.nml and hotkey tks files. But I want to make sure If there is anything else I need to search? I feel that I copied everything I needed to but any bit helps. Thanks again.
     
  6. djquartz

    djquartz NI Product Owner

    Messages:
    5,321
    The Traktor 3 user folder is actually labeled Traktor3, do a search for this and see if it provides more specific results.

    Here is how the structure works.

    Traktor DJ Studio 3 settings.xml - Your program settings
    Collection.nml - Your main Track Collection
    <playlist name>.nml - Your custom created playlists

    *If you have changed any hotkeys but didn't save it as a different filename. Look for the following files.

    TD3Keyboard.tks
    TD3Midi.tks

    Refer to your manual, page 62 in the Traktor 3 - 2nd Revision Manual
     
  7. liamm

    liamm Forum Member

    Messages:
    35
    how do you convert your collection to unicode

    hello DJ quartz

    I have TS1.3 update but have not installed as I did not understand your post about unicode.

    Does the update automatically convert your track collection or do you have to do it yourself?

    If you have to do it yourself how do you do it?
     
  8. buenputter

    buenputter NI Product Owner

    Messages:
    1,858
    On every launch of a unicode TS-/Traktor-version you have to decide if you want to convert the collection or use it in read-only-mode. (Until you once converted your collection.)

    If you decide to convert the collection, Traktor / TS will do this for you.
     
  9. FatJunk

    FatJunk New Member

    Messages:
    3
    Will this conversion affect my warp markers in ableton 7?
    ---
    additional question:

    i've downloaded the new update installer 1.3, what is the proper way of upgrading? should i uninstall the 1.2 version first? Should i uninstall just by moving traktor to the trash or is it better to uninstall using appdelete? Thanks in advance!
     
  10. buenputter

    buenputter NI Product Owner

    Messages:
    1,858
    Don't use Ableton, sorry no clue.

    You can just install 1.3, BUT you definitely have to BACKUP your T3-folder in advance. There should be a paragraph with backup-hints at the beginning of the installation-process or in a readme that comes with the installer.
     
  11. chilly

    chilly Returning Customer

    Messages:
    3,123
    Ableton and Traktor never sync'd to begin with, so your answer is NO.
     
  12. FatJunk

    FatJunk New Member

    Messages:
    3
    Great! Thanks for your replies. : )

    One more thing, my friend also owns a traktor scratch. He lost the included usb cable. Can he use any standard usb cable as a replacement? The included usb cable has something at the other end, i dont know what that is for...standard usb cables dont have such. Wont there be any problem at all in the long run?
     
  13. djquartz

    djquartz NI Product Owner

    Messages:
    5,321
    If he buys a good quality usb cable, it will be alright.
     
  14. CraigKC

    CraigKC Forum Member

    Messages:
    66
    Another TS1.3 and T3.4 issue...

    Another part of this 'caution' could include that those of us using CD decks with a 'certified' mixer have found that timecode no longer works in TS1.3 and T3.4. Korg has more info and confirmed this, but NI has yet to respond in any way for days to a ticket I opened...
     
  15. mikewmmamedia

    mikewmmamedia New Member

    Messages:
    6
    Confused about upgrading to Traktor 1.3

    Hello,

    I have never completed the upgrade to 1.3 because when asked to convert my collection 1.3 started to reanalyze my collection from scratch. By doing so I was losing all my naming edits. Being I have 40K plus tracks it was a lot of edits to lose and starting over would be impossible. Am I doing something incorrectly? Can you convert your collection without losing all the edits to the collection?

    What happens if I don't convert it? Does read only mean I can not add anything new to it? Or can I add to it and make edits to anything new but not anything old?

    Thanks

    Mike
     
  16. bigbadselecta

    bigbadselecta Forum Member

    Messages:
    628
    Did you try to save your tags?

    Select your files > right click > save file tags

    Takes a while.
     
Thread Status:
Not open for further replies.