Volume control assignment

Discussion in 'AKOUSTIK PIANO' started by electricfuzz, Jun 1, 2008.

Thread Status:
Not open for further replies.
  1. electricfuzz

    electricfuzz New Member

    Messages:
    10
    I'm fairly new at midi in general so bare with me, I own an M-audio axiom 61 midi controller keyboard. I use VSTi's for live performances and am looking to replace my piano sound with something considerably better (currently using Cakewalk's TTS-1). I am trying out NI Acoustik Piano but can not seem to get my midi controller to control the volume. I'll admit that I do not fully understand midi controller assignment nor do I fully know how to program my Axiom keyboard, but with all other VSTi's I have used, the volume has already defaulted to what ever default my controller is set to (to put it simply, my keyboard's volume fader has always controlled the volume by default on all the vsti's i have installed). I am having the same problem with Electrik Piano. Is there something real basic here that I have yet to discover?
     
  2. geoelectro

    geoelectro NI Product Owner

    Messages:
    520
    They both will respond to MIDI controller for volume. CC #7
    Are you running these programs stand alone or inside a host?

    Geoelectro
     
  3. electricfuzz

    electricfuzz New Member

    Messages:
    10
    I'm running them in a host progam called forte by brainspawn. Apparently you can map all sorts of stuff using just forte but like i said, I'm kinda knew to all of this, i used to just play bass and harmonica. Thanks for the tip, I'll try it out when i get home! why is there no midi chart available for these synths or if there is where can i find it?
     
  4. ew

    ew Moderator Moderator

    Messages:
    21,329
    In AP's case, it's because the only controllers it recognizes are volume (7), pan (10), sustain (64) and sostenuto (65)- those are the standard MIDI controllers for those functions, so there's no real reason to document them.

    ew
     
  5. electricfuzz

    electricfuzz New Member

    Messages:
    10
    Thanks EW, that makes sense then. I am sending my volume control on cc 07 on midi channel 1, AP is set to recieve midi info globaly (i tried setting it to recieve on just channel 1 as well with no luck) and still no volume control. I'm going to redownload the trial version and reinstall it and see if that helps. Still open to any suggestions though. Thanks to all.

    I know this isn't the B4 forum but does anyone know where to obtain the midi implementation chart for that? There has got to be a ton of assignable controls for that! (I can't find a manual anywhere)

    e-fuzz
     
  6. ruddy duck

    ruddy duck Forum Member

    Messages:
    64
    B4 control is user assignable either manually or through midi learn.

    Sounds like you're using the same controller for playing and controlling so presumably the midi input is set correctly.

    Could try monitoring the outgoing midi with something like MidiOx.
     
  7. electricfuzz

    electricfuzz New Member

    Messages:
    10
    If by midi learn you mean right clicking a control, hitting midi learn, and turning a knob on the midi controller, I'm pretty sure that is not available on B4 (version 1) that is part of why I am considering B4II. If there is another way to use midi learn with B4I, plus share. Manually assigning the controls would probably require the midi implementation chart that I am so desparately searching for! I wish every VST had the right click midi learn function, I don't see why you would not include that function.
    Yes, my player and controller are both M-audio's Axiom 61. I will definitely look into the midiOx program and see if that will help me figure all this stuff out. I am sure that my keys are sending the right info cause it is no problem with other VSTs. I will move over to the B4 forum and continue my midi chart quest there as i dont want this to be misposted. Thanks for your help.
    e-fuzz
     
  8. electricfuzz

    electricfuzz New Member

    Messages:
    10
    found a work around

    I can't get anything to move the volume in AP or EP except the mouse and I have everything assigned right! Just thought I would share my work-around in case anyone else has the same problem. I use Forte as my VST host and I have inserted a Guitar Rig rack with only a volume pedal. The volume pedal was easily assignable with the midi learn function in guitar rig (had to do it outside of Forte and save as a preset though). Can't calibrate the sweep just right but it is working good enough for me.
     
Thread Status:
Not open for further replies.