Why is this sequencer acting strangely?

Discussion in 'REAKTOR' started by D. Vyd, Jul 21, 2019.

  1. D. Vyd

    D. Vyd NI Product Owner

    Messages:
    357
    Hi folks,

    I'd welcome comment on this simple step sequencer that is acting strangely. It is designed to generate patterns using Reaktor's morph feature and then record good patterns into a DAW. Users (just me) control the length of a step (gate length) with a single knob. The gate length feeds a delay that sends MIDI note off. Each pitch and volume step is an index to a lookup via a scanner/selector. The sequencer should reset to the first step whenever the user stops and then restarts the DAW. When I look at the lamps and listen to the MIDI output via a synth, there seems to be a delay of a step or more. I can't quite figure out what is going on.

    -david
     

    Attached Files:

  2. Paule

    Paule NI Product Owner

    Messages:
    4,899
    Da'ud, is it in a daw only or in standalone also?
     
    • Like Like x 1
  3. D. Vyd

    D. Vyd NI Product Owner

    Messages:
    357
    I built and tested it in Reaper. I'll check stand alone and report back here.
     
  4. D. Vyd

    D. Vyd NI Product Owner

    Messages:
    357
    Yes, the sequencer behaves the same way. The default settings use a high-pitched first step and the remaining steps are identically low-pitched. However, I hear the high pitch on the second step. I can't figure out why. Perhaps it is just a mismatch between the lamps and the MIDI? Also, I've seen sequencers with complicated MIDI note-off modules using sample holds and merges between the pitch and gate of a single MIDI note sender. My approach is simpler (to me) and uses two MIDI note modules, one for note-on and one for note-off. It seems to work--right?
     
    Last edited: Jul 21, 2019
  5. Paule

    Paule NI Product Owner

    Messages:
    4,899
    Are the reason the 2 order moduls?
    Bridge them over and listen. If it sound right delete the order moduls.
     
  6. D. Vyd

    D. Vyd NI Product Owner

    Messages:
    357
    I've removed the order modules and added Brutal from the UL for testing. The sequencer has the same issue. Can you confirm that you hear the higher pitch step playing one or two steps late?
     

    Attached Files:

    Last edited: Jul 21, 2019
  7. Paule

    Paule NI Product Owner

    Messages:
    4,899
    In pandora are seq modules because they are a bit instable - good for percussions.
    multiplex.png
    In MIDI Remote I use Multiplexes
     
  8. Paule

    Paule NI Product Owner

    Messages:
    4,899
    I step in soon.
     
  9. D. Vyd

    D. Vyd NI Product Owner

    Messages:
    357
    Ok. I'm not near my laptop right now. If I remember correctly, multiplex needs song location?
     
  10. Paule

    Paule NI Product Owner

    Messages:
    4,899
    Yes. Then you can use also different directions incl. randoms.
     
  11. Paule

    Paule NI Product Owner

    Messages:
    4,899
    Here is one seq module solution
    seq out x gate.png
     

    Attached Files:

  12. D. Vyd

    D. Vyd NI Product Owner

    Messages:
    357
    Thanks Paule. I'll try it tomorrow!
     
    • Like Like x 1
  13. D. Vyd

    D. Vyd NI Product Owner

    Messages:
    357
    Paule, you corrected the problem. I'll look at the wiring and figure out what you did. Thank you!
     
    • Like Like x 1
  14. Paule

    Paule NI Product Owner

    Messages:
    4,899
    Here are 3 old seqs like you build one. For your pleasure.
    Reaktor 2.3 load in R5 and saved. R6 can read them now.
     

    Attached Files:

  15. D. Vyd

    D. Vyd NI Product Owner

    Messages:
    357
    Thanks Paule! I'll take a look later today!
     
    • Like Like x 1