1. We're currently conducting systematic tests with the release version of macOS 11 (Big Sur) in order to offer full compatibility of our products as soon as possible. You can find our latest compatibility status - here


    Please note that although announced at the same time as macOS Big Sur, Apple Silicon processors are an independent release with separate compatibility concerns for NI products. Compatibility with macOS Big Sur will not yet ensure compatibility with Apple Silicon processors. At the moment, Native Instruments products are not supported on computers with Apple Silicon processors. Read more - here

    Dismiss Notice

Wierd mapping problem

Discussion in 'KONTROL X1' started by electrogrimey, Jun 9, 2010.

Thread Status:
Not open for further replies.
  1. electrogrimey

    electrogrimey Forum Member

    Messages:
    116
    I just changed my mapping there so that the right browser knob scrolls through the tree, (so I didn't have to use MIDI mode), and that worked fine. Then I tried to change it so that when you load a track it untoggles browser mode, so that when you're in browser mode and you load a track it'll return to normal. I mapped 'only browser toggle' to both load buttons as direct, and set value to 0. This works perfectly on the left browser buttons, so that when it's in normal mode it loads normally, and it browser mode it loads and returns to normal.

    However, the right buttons (even though they're mapped exactly the same) are working differently. When I press them they go into browser mode, and when I release it they return to normal. So when you load a track not in browser mode, browser mode flashes as you depress the button. All 4 are mapped exactly the same, so I don't see why this is happening. I'm guessing it's something to do with the new tree mapping. Any suggestions?

    tl;dr -

    Only browser toggle mapping is affected by new tree browse mapping. Why?
     
  2. Linuxgirly

    Linuxgirly Forum Member

    Messages:
    183
    go back in the mapper editor, press the box with the 0 value, delete it, press 0 again, then press enter and then apply settings. had this issue few times also when i was completely remmapping mine. It's not even perfect now, because when i turn browser mode to 0, and i'm not in browser mode then my screen flashes weird for a second.
     
  3. electrogrimey

    electrogrimey Forum Member

    Messages:
    116
    I'll try that, seems like a bug, because there's no reason for it to happen. Thanks :)
     
Thread Status:
Not open for further replies.