1. Please do not install macOS 10.15 Catalina yet, as Native Instruments software and hardware products are not supported under macOS 10.15 yet. For more info, please go HERE!
    Dismiss Notice

X-Session Pro & Traktor 3

Discussion in 'TRAKTOR 3' started by DoJ, Dec 11, 2006.

Thread Status:
Not open for further replies.
  1. marksaunders

    marksaunders NI Product Owner

    Messages:
    2
    thanks a lot for posting the x-session file....that saved me a huge amount of time. I coudn't for the life of me figure out how to get the two different pitch and volume sliders to operate on the two decks of Traktor (i discovered this during the 1 hour 45 minute wait on MI tech support!)

    best

    Mark

    www.marksaunders.com
     
  2. freshcity

    freshcity New Member

    Messages:
    16
    Imic

    While still using the x-session pro can is it still possible to use the imic as an aggregate device for the master audio and the built in out put for cueing in tracks?
     
  3. djk-tel

    djk-tel NI Product Owner

    Messages:
    328
    X-Session pro is a MIDI controller.

    It has nothing to do with audio.
    So your question is irrelevalnt.

    k-tel
     
  4. m4st3r

    m4st3r New Member

    Messages:
    13
    Hey,

    can some1 help me?
    I've got my X-Session Pro today and I've downloaded the tks file from here (this thread).
    Everything is working fine but I'm asking myself what knob I have to configure for the channel cue function (CC0 - CC127)?

    Hope someone can help me, otherwise I have to try all 128 selections :S ...
     
  5. misterj

    misterj New Member

    Messages:
    15
    I think the play button works as the cue function if you downloaded ktels tks file.
     
  6. m4st3r

    m4st3r New Member

    Messages:
    13
    I didn't mean the cue function.
    I mean the "channel cue" for Deck A and Deck B. This function is used for activating prelistening.
     
  7. misterj

    misterj New Member

    Messages:
    15
    I assume your sound card has been set up properly. To prelisten to a channel you need to have enough output on your soundcard. The phones are usually set to output 3&4.

    I think the big button with the headphone underneath the channel mixers could be assigned. What to is select the cue function from the midi list in Traktor. Press the learn key and then the button on the mixer.

    I am a noob myself so appologies if I give you a bum steer.

    ;)
     
  8. m4st3r

    m4st3r New Member

    Messages:
    13
    When I press the 'Learn' button nothing happens.
    So I need the CC numbers for these 2 knobs on the midi-controller with the headphones on.
     
  9. buenputter

    buenputter NI Product Owner

    Messages:
    1,858
    Do you see the X-session in the list of Midi-interfaces?
    Is there a "x" next to it? (= midi-interface is active / enabled)
     
  10. m4st3r

    m4st3r New Member

    Messages:
    13
    Yes, I do.
    The midi device is working fine ...
    But the 'Learn' function isn't working ... So I just need the CC numbers for the two knobs with the headphones on.
     
  11. buenputter

    buenputter NI Product Owner

    Messages:
    1,858
    O.K.

    Isn't there a table containing the cc-numbers in the x-session-manual? (e.g. in the faderfox-manuals you can find it at the end)
     
  12. misterj

    misterj New Member

    Messages:
    15
    OK. You can learn the Xsession. I just tried this and you need to open the midi settings (midi setup). Add a new control, find the deck monitor cue. Press the learn then press the button on the xsession. Then set it how you want. I set it to toggle. See the dump attached.

    I may use this myself now I have done it. I was using this as a sync function before.:cool:
     

    Attached Files:

    • dump.GIF
      dump.GIF
      File size:
      42.1 KB
      Views:
      690
  13. m4st3r

    m4st3r New Member

    Messages:
    13
    Thx!
    Now I know the settings for Deck B.
    Can you tell me the settings for Deck A, too?

    Thanks in advance.
     
  14. noahptefft

    noahptefft New Member

    Messages:
    3
    Hey guys - Traktor Noob here. Some quick questions for you all. I just got the X-Session pro to use on my Mac Book with Traktor 3. I've realised that I can't do any cueing since I only have one output on my laptop. I do have an Alesis Multimix 8 - Can I use that - or do I need some other type of soundcard? I've also been having a terrible time getting the X-Session to "learn" the knob movements. Any help would be greatly appreciated. Thanks!

    -noah
     
  15. noahptefft

    noahptefft New Member

    Messages:
    3
    And now my crossfader has disappeared from the screen - how do I get it back?
     
  16. buenputter

    buenputter NI Product Owner

    Messages:
    1,858
    I guess that you switched from internal-mixer-mode to external-mixer-mode.
    Preferences > Audio Setup > Output Routing
     
  17. misterj

    misterj New Member

    Messages:
    15
    Just above the deck B settings in the screen shot:p Did you try learn the function. It's a good way to try things with sliders/button/knobs that are not yet configured.
     
  18. noahptefft

    noahptefft New Member

    Messages:
    3
    Thanks, got it! I realised that I can use my Multimix - I just have to setup my output in mono - which is fine because it records in stereo. Still workin with the X-session - I'll get it - I hope.
     
  19. HAZIEL

    HAZIEL New Member

    Messages:
    15
    THANKS A LOT MAN i take this file as my x mas present i was having such hard time trying to figureout how to configure this thanks again

    Haziel
     
  20. tigerdog

    tigerdog NI Product Owner

    Messages:
    1
    Thanks for the .tks file

    Wow, that was easy. Thanks for posting the .tks file. Works great. Just got the X-Session Pro for $69 at Guitar Center. Yeah it feels cheap and the crossfader is way too light but for that price it seems pretty damn good. Haven't tried it yet with my Audio Kontrol 1 (still at work) but all seems good so far.
     
Thread Status:
Not open for further replies.