1. Please do not install macOS 10.15 Catalina yet, as Native Instruments software and hardware products are not supported under macOS 10.15 yet. For more info, please go HERE!
    Dismiss Notice

X1 not working in OSX 10.12.1

Discussion in 'KONTROL X1' started by maxg, Nov 23, 2016.

  1. maxg

    maxg New Member

    Messages:
    2
    After years of no issues my X1's are not being recognized by Traktor this past weekend.

    Symptoms - Both X1 controllers with different USB cables plugged into either USB port are showing the same following symptoms:

    - Power is going to the controller as it shows that when plugged in.
    - When restarting the computer and then Traktor sometimes A/B will flash but the controller is non responsive, I've not been able to replicate why sometimes it flashes and sometimes stays dark.
    - No midi info is appearing in Traktor

    Tried the following fixes as per the NI "missing controller" page:

    - Controller editor Deleted / Reinstalled / Deleted / Downgraded
    - Traktor reinstalled
    - Controller information deleted and reinstalled.

    Nothing is working. My F1 is showing the same issue.

    So we know it's not the cables, not the controllers. Only difference is the OS update but it was a couple of weeks since that update when I first
    plugged these in so it was possibly another cause. Midi keyboard works with Ableton just fine also.

    Does anyone have any idea what could be causing this?

    Thanks.

    Max
     
  2. d906560

    d906560 New Member

    Messages:
    1
    try hooking the x1's up using a powered USB hub. Sounds like issues I had when there was too little power for them.
     
  3. StefanvanHattum

    StefanvanHattum New Member

    Messages:
    12
  4. Brainmagic

    Brainmagic New Member

    Messages:
    4
    same problem here ! could you fix it ? im running x1 and z1. Both dont work anymore. My x1 just lights up when i start traktor and wants me to select my decks, but when i press the search button to confirm it doesnt do anything and keeps blinking showing A and B. The only knob thats working on my z1 is the master, without showing any changes in the software if i use it.

    I also tried reinstalling Traktor, deleting the drivers manually etc. No changes... :/
     
  5. mmmbutch

    mmmbutch New Member

    Messages:
    2

    Sorry for the old thread revival but I'm having the exact same issue. Did you work it out?
     
  6. Owner

    Owner NI Product Owner

    Messages:
    342
    Which Traktor Version do you use? I use 2.11.2 and my x1 and maschine, booth mk1, are still running. After my clean install of traktor i had to re-install the latest drivers from the x1 and maschine from the NI download section and it works fine now.
     
  7. tabache

    tabache NI Product Owner

    Messages:
    29
    on my macOS 10.13.6 High Sierra it is impossible recognize Traktor X1.
    I've installed all driver that i found of x1.
    I've installed also Controller Editor 2.2.5 Mac OS 10.12 and above. But also this Controller Editor don't recognize my x1.

    In my Windows7 instead, the Controller Editor can connect to the X1!!

    I've reinstalled all driver of X1, but nothing is changing.

    What driver version and Controller editor version do I need to install?!

    thanks

    I've lost a lot of hours. So bored.
     
    Last edited: Feb 22, 2019