1. The forum software has recently been updated. If you have comments or feedback, please let us know HERE! If you have arrived via a Google search, please use the forum search feature to locate specific information.

    Best wishes,
    The NI Team

Audio Latency settings?

Discussion in 'TRAKTOR PRO / TRAKTOR SCRATCH PRO' started by jettyson, Jan 21, 2009.

Thread Status:
Not open for further replies.
  1. jettyson

    jettyson New Member

    Messages:
    13
    I am new to Traktor Pro... I experienced the audio 'dropping out' occassionaly during a mix. I upgraded my RAM to 4 GB and it didn't seem to make a difference.

    What do people recommend for the audio latency setting?

    Sample Rate = 44.100 KHz
    Audio Latency = 5.5 ms

    The NI User guide didn't haver any recommendations in it...

    Thanks,
    Simon
  2. AntiTelo

    AntiTelo Forum Member

    Messages:
    245
    If you were on Windows OS I can recommend some optimization tricks, but I don't know anything about OS X
  3. djjasoncarroll

    djjasoncarroll NI Product Owner

    Messages:
    354
    Hi mate I run it at that rate with the audio 8 2.2ghz cpu with no problems, give us a little more info about what your doing are you running 4 decks with key lock on ? this could over do the cpu make it drop out, now I have messed about with the latency and got it down to 2.5 off, with key lock its poop even worse if I run 4 decks but again I am running the audio8 not a 4D so this could be total babble
  4. iTronz

    iTronz Forum Member

    Messages:
    24
    You should be able to drop the Latency down a lot more, on my system I got it down to 2.5 on 96000Khz. I don't get any cracks, pops or dropouts at all. Bear in mind my system is only used to for traktor, I have a desktop PC for my production. I keep WiFi turned off and all other programs closed so the only program open is traktor.
  5. Timtango

    Timtango Forum Member

    Messages:
    112
    Where's Phil? He'll be asking you for 'proof' of this incredible feat!

    I agree, I can run very comfortably at 2.5ms (48Khz) on my Macbook, and it's getting kinda old now. Firewire devices seems to go a coupe of ms lower than the usb ones judging by the comments posted here...
  6. iTronz

    iTronz Forum Member

    Messages:
    24
    Well, I'm happy to show proof in what ever way someone would want. I've been reading these forums for around a week now and I've seen a lot of people using latency's such as 4.5 at 44100Khz this is why I'm pretty shocked to see no one running 2.5 at 96000Khz.

    Unless I am missing something, when I go to the preferences menu in TSP it does say Sample Rate 96000Khz and Audio Latency 2.5ms. This is with the standard Audio 8 DJ sound card, setup in my Sig :).

    Please bear in mind the longest mix I've done under TSP so far at these settings is 30 minutes which I understand is no where near saying that it is completely stable but a turntablist's point of view and only using the program for short length routines this is stable enough for my liking.
  7. de wouzer

    de wouzer NI Product Owner

    Messages:
    1,328
    It's always important to take low Deck cache size
  8. Timtango

    Timtango Forum Member

    Messages:
    112
    Hi de wouzer

    Plese elaborate - I have no idea how deck cache may interact with performance and/or latency.
    I'm only using 2 decks at the moment, so I've been putting decks A+B on max cache, and C+D on minimum.
    My reasoning has been that the fully cached decks need less drive access and support beat-jumps more easily.
  9. jettyson

    jettyson New Member

    Messages:
    13
    Thanks for the input everyone.

    - I lowered my Audio Latency to 8.5 ms.
    - Turned off Airport and Norton Antivirus.
    - Switched off Key Lock on all 4 decks.

    I mixed for 1.5 hours tonight and it dropped out twce.

    - I am not using Audio 8 or any timecode controllers.
    - My Deck Cache size for both A&B and C&D was 128 MB.

    What are suggestions for next steps? Shuld I lower Deck Cache to 32 MB or lower for C&D and A&B or just one of them?

    I have read on a couple of forums both A&H and here that Xone:4D models 9000 below are problematic with power issues, but my model number is above 9000.

    I am running the A&H USB Audio Driver v1.4.14 as recommended here.

    Any more sugestios or feedback would be appreciated.

    S
  10. letsgooutside

    letsgooutside Forum Member

    Messages:
    103
    As I understand it...

    Deck Caching basically takes x amount of the uncompressed audio and loads it into memory, taking the strain off your hard drive. When you load a track into a deck, Traktor decodes the file until it hits the deck's cache size. When that cache is about to run out, it loads the next chunk. Hard drives below 7200 RPM (almost all laptop drives) are too slow to handle this at lower intervals without pause (despite a fast CPU/bus), so you need to specify a cache size large enough to load more of the track into memory. This means that you'll have to wait a bit longer for the track to load when you drop it in, but it should eliminate the gaps, because it's no longer loading the file in chunks.

    Note that's the UNCOMPRESSED size, which is ~20mb per minute @ 96000hz. If your cache is set to 128mb, then you've got a chance of hearing a gap about 6 minutes into a track. If you set it 256mb, Traktor will load 12 - 13 minutes of the track into memory and you'll be gap free. If you take it down to 48000hz or 44100hz, you get the same amount of time using 128mb, or double the time at 256mb. Does that make sense?
    ---
    Oh, and I've got a Sony Vaio, 2.4ghz dual-core, 4gb memory. I'm running at 96000hz with 6ms latency. I keep my cache size as high as possible on the decks I'm using (I set C & D to 8mb when I'm just using two decks).

    It's been absolutely flawless for me.
  11. kourampies

    kourampies Forum Member

    Messages:
    171
    its all a matter of config. i use 1.5 ms on my laptop, with 256mb cache on all 4 decks, but i spent a lot of time installing xp, and tweaking every aspect of the os.
    when the laptop shipped with vista, i could only do 11.5 ms glitch free, with 2 decks :(
  12. discostur

    discostur Forum Member

    Messages:
    33
    I'm running traktor @ 1ms, not having any trouble so far

    i have a macbook 13" (late08), 2 ghz, 2 GB Ram
    i'm using audio 8, 2 decks with timecode vinyl and 256mb cache size for deck A and B
  13. AntiTelo

    AntiTelo Forum Member

    Messages:
    245
    Don't use 96 kHz. On 44.1 timecode tracking accuracy is better.
  14. letsgooutside

    letsgooutside Forum Member

    Messages:
    103
    I find that 96khz sounds significantly better and I haven't felt or seen any difference in the tracking. All depends on machine/config, I guess.
  15. jgcamil

    jgcamil Forum Member

    Messages:
    84
    I used to perfectly run my TPro with 2 decks, keylock on with 5.5ms and 44.1 with no issues whatsoever...

    Last friday I switched to 4 deck view, with 2 decks with keylock and all fx on in all 4 decks... the thing started to pop a little.. I will have to play with a lower latency if I dont want to experience the same issues.

    Any ideas here?
  16. Ancipital

    Ancipital NI Product Owner

    Messages:
    304
    Hmm, if you play tracks from the internal drive, does it still pop?
  17. jgcamil

    jgcamil Forum Member

    Messages:
    84
    Dunno, I run everything from an external HD, running with FW400, although I will switch to FW800 to speed things up a little...
  18. jettyson

    jettyson New Member

    Messages:
    13
    I have only been playing off my internal drive.

    I am going to next try cutting down to only 2 decks and see if it still pops.

    The next test after that is to borrow my mate's newer 2.6 GHz MacBook Pro and see if it works any better... if I am still having issues I am going to contact A&H Technical Support... I have a sinking feeling that it might be the soundcard on the Xone:4D.
  19. Ancipital

    Ancipital NI Product Owner

    Messages:
    304
  20. Devon Damnit

    Devon Damnit Forum Member

    Messages:
    35
    i run at 2.0 ms without dropouts once i switch my wireless off, if i go to 88000 or what ever the figure is below 96000hz i get 1.5 no dropouts at all
Thread Status:
Not open for further replies.

Share This Page