1. The forum software has recently been updated. If you have comments or feedback, please let us know HERE! If you have arrived via a Google search, please use the forum search feature to locate specific information.

    Best wishes,
    The NI Team

No sound from speakers - Traktor S2

Discussion in 'KONTROL S2 / KONTROL S4' started by freddy240, Oct 14, 2013.

  1. freddy240

    freddy240 New Member

    Messages:
    8
    Hi everyone,
    I just bought a Traktor S2 Controller and hooked it up but noticed that no sound was coming out of the speakers. I can listen to the music through the headphones and I have also tested the speakers on another system and the speakers worked fine. I am guessing that it must be a configuration issue but I have tried a few different settings but none seems to work.

    Hope someone can help with a solution.

    Thanks
  2. makar1

    makar1 Forum Member

    Messages:
    3,139
    Have you connected your speakers to the S2?
  3. freddy240

    freddy240 New Member

    Messages:
    8
    Hi Makar1,
    Yes, the speakers are connected to the S2.

    Thanks
  4. makar1

    makar1 Forum Member

    Messages:
    3,139
    Did you turn up the Master dial on the S2? And how exactly are your speakers connected to the S2?
  5. tmccoy

    tmccoy Forum Member

    Messages:
    1,423
  6. freddy240

    freddy240 New Member

    Messages:
    8
    Yes the dial is turned up. I connected the speaker wires in the correct spot (red and white wire) in both the speaker and the S2
  7. tmccoy

    tmccoy Forum Member

    Messages:
    1,423
  8. ImNotDedYet

    ImNotDedYet Forum Member

    Messages:
    56
    Make sure your master and level gains aren't killed, volume faders are up, crossfader is in the middle and make sure your audio setup in settings has your master left and right configured correctly
  9. freddy240

    freddy240 New Member

    Messages:
    8
  10. makar1

    makar1 Forum Member

    Messages:
    3,139
    Have you tried the TRS output yet?
  11. freddy240

    freddy240 New Member

    Messages:
    8
    I assumed that you mean the TRS Input outlets. The TRS Input outlets require a different type of connection chord. I tested the speakers the same way with another system and they worked properly.
  12. makar1

    makar1 Forum Member

    Messages:
    3,139
    The S2 has TRS outputs
  13. tmccoy

    tmccoy Forum Member

    Messages:
    1,423
    The speakers are turned off in the picture. Please tell me they were on when playing music?

    Also post a screenshot of Traktor playing a song and a picture of the S2 when playing the song so we can see the levels. Even better, take a video of everything!
  14. freddy240

    freddy240 New Member

    Messages:
    8
    Yes the speakers were turned on when playing music.

    I decided to take the S2 to the store from where I bought it so that they can take a look at it and they were able to solve the problem. Just some minor configurations were made. I will post the pictures of the new configurations just in case someone else might find it useful.

    Really appreciate the help that I received on the forum.

Share This Page