1. The forum software has recently been updated. If you have comments or feedback, please let us know HERE! If you have arrived via a Google search, please use the forum search feature to locate specific information.

    Best wishes,
    The NI Team

Problem with Hercules DJ console MK4 & Traktor

Discussion in 'Technical Issues' started by daneford, Dec 27, 2010.

Thread Status:
Not open for further replies.
  1. daneford

    daneford New Member

    Messages:
    7
    I'm using Traktor Pro 1.2.4 and hercules dj console mk4 and it's not working properly. I followed the instructions many times over (the .tsi file, etc.). For one, when I move the treble nob on the left deck, it also moves the pitch of the right deck (in traktor). The medium nob on the left deck also moves the waveform of the left deck in the same direction of the nob being turned. Finally, the bass nob does the same thing except with the right deck.

    Also, moving the left volume fader also moves the pitch bender (on the software), and moving the right volume fader cycles through my songs (again in the software). whats going on? There are other weird things like this but you get the point.

    I can't figure out why it does this or how to fix it. I prefer traktor to virtual dj so I really need to fix this! help please!

    When I used a Hercules mk2 it worked fine but the mk4 with traktor is acting screwy.
  2. Count Zero

    Count Zero ModerAUtor

    Messages:
    6,452
    Upgrade to 1.2.7 first.
  3. daneford

    daneford New Member

    Messages:
    7
    So the mk4 won't work with 1.2.4, only 1.2.7?
  4. daneford

    daneford New Member

    Messages:
    7
    Can anybody help me please?
  5. DJ Phatso

    DJ Phatso Forum Member

    Messages:
    440
    So, are you using the Hercules provided TSI or did you create your own ?

    The Hercules TSI will work with version 1.2.4 and superior, so no problems there.

    Did you check if you might have other TSI which would be applied to the Mk4 and shouldn't ?

    As described in the instructions provided by Hercules, the MIDI In and Out need to be assigned correctly to the profile you want to use. If the MK4 MIDI In is also applied to other profile, that could explain the interferences...
  6. daneford

    daneford New Member

    Messages:
    7
    That could be it.

    I plug in the mk4, wait til the light comes on, launch traktor, load the tsi file, and I checked the input and outputs in the traktor preferences, and it only shows "Line in 0" and "Line in 1" as my options. It should be Input 1, 2, 3, 4, and Output 1, 2, 3, and 4, right?

    Not sure why it's doing this.

    As for the tsi file, it's named "TP_DJ_Mk4(PC)_v1.24.tsi" so I think it's the right one.
    ---
    I fixed this by selecting a different audio device, but now the same problem persists. Moving knobs and sliders on the mk4 does the correct movements in the software but it also moved something completely different and makes using it impossible.
    :S
    ---
    "As described in the instructions provided by Hercules, the MIDI In and Out need to be assigned correctly to the profile you want to use. If the MK4 MIDI In is also applied to other profile, that could explain the interferences..."

    what do you mean by this? How to I check to see it's only applying the TSI I want and not more than one?
  7. DJ Phatso

    DJ Phatso Forum Member

    Messages:
    440
    I guess you didn't read the PDF file that is included with the TSI file. :p

    It will show you exactly what you need to do to get it work correctly
  8. daneford

    daneford New Member

    Messages:
    7
    No, I read through that PDF several times and it simply doesn't work.

    Do I have defective mk4 or a defective copy of traktor?
  9. Count Zero

    Count Zero ModerAUtor

    Messages:
    6,452
    Version 1.2.4 of traktor is very buggy (especially the cracked versions). Why don't you upgrade to latest version 1.2.7?
  10. DJ Phatso

    DJ Phatso Forum Member

    Messages:
    440
    @ Daneford

    1) So you did put the MK4 in ASIO in the DJ control panel BEFORE launching Traktor ?

    If so, then you should:

    - be able to select MK4 ASIO as Audio Device

    - the 4 outputs should be available in Output Routing

    2) Next, you used the IMPORT button to load the TSI ?

    - Then, once done, you went to Controller-Manager, selected the MK4 in Device and In-Port and Out-Port.

    If you see any other components appear in the Device Menu, select it and put the In-Port and Out-Port to None to prevent any conflicts.

    If you did all this, normally it should work, given that your MK4 is installed properly to start with:

    http://ts.hercules.com/faqs/eng/her_eng_00411.pdf
  11. daneford

    daneford New Member

    Messages:
    7
    Thank you!

    The thing I was missing was setting the in-port and out-port to none for the other things showing up in the controller manager. Now everything seems to work correctly.

    Thanks again!
  12. téa

    téa NI Product Owner

    Messages:
    576
    This same issue was posted previously about a cracked copy of Traktor.......

    Why not try some other open source DJ apps for bedroom mixing, or buy the software? That way you can have the latest version and get bug fixes as they come......
  13. fredro

    fredro New Member

    Messages:
    5
    i tried all that for my mk4 but it still doesnt work do i have to assign every control cause nothin comes up on the assignment table can any one help me
  14. DJ Phatso

    DJ Phatso Forum Member

    Messages:
    440
  15. fredro

    fredro New Member

    Messages:
    5
    yeah i downloaded the pc version and i read the pdf followed all the steps to set it up. But after i import the tsi file and go to the controller-manager the mk4 shows up in the devices the mk4 shows up and i also put the mk4 on the in-port and out-port it all comes up like it said in the pdf. but in the assignment table below the device setup there is nothing assigned and nothing works on the mk4. i know the mk4 is set up right cause it works with the virtual dj and it comes up in the devices on my computer
  16. DJ Phatso

    DJ Phatso Forum Member

    Messages:
    440
    What version of Traktor are you using exactly ?
  17. fredro

    fredro New Member

    Messages:
    5
    it says Traktor Duo version 1.2 (07/2009) thats what it says in the booklet. i got both the mk4 and the Traktor
  18. téa

    téa NI Product Owner

    Messages:
    576
    You need to upgrade to the latest version. This can be done through the native instruments service center.

    If you Traktor is not legit then you will not be able to update to the latest version, and you should stop asking paying customers for help.
  19. fredro

    fredro New Member

    Messages:
    5
    It is legit I bought it at sam ash over here in phoenix but ill try updating it
  20. téa

    téa NI Product Owner

    Messages:
    576
    Glad about that! Didnt mean to sound harsh, just wanted to make sure.... XD

    Just load up service center and it will be right there.
Thread Status:
Not open for further replies.

Share This Page