1. We're currently conducting systematic tests with the release version of macOS 11 (Big Sur) in order to offer full compatibility of our products as soon as possible. You can find our latest compatibility status - here


    Please note that although announced at the same time as macOS Big Sur, Apple Silicon processors are an independent release with separate compatibility concerns for NI products. Compatibility with macOS Big Sur will not yet ensure compatibility with Apple Silicon processors. At the moment, Native Instruments products are not supported on computers with Apple Silicon processors. Read more - here

    Dismiss Notice

2.8.2 Crash with Arturia Plugins

Discussion in 'MASCHINE Area' started by pfokus, Apr 28, 2019.

  1. pfokus

    pfokus NI Product Owner

    Messages:
    58
    Mac OSX 10.14.4 Mojave
    iMac Pro 2017 - 64GB - 18 Cores

    Maschine attempts to open the last song I was using and then crashes. I've attached the most recent crash log.

    The song worked right before an Arturia update, but another song had a similar issue with an Arturia plugin a few weeks ago.

    To get the song(s) to open, I go into the Arturia centralized plugin app and uninstall the offending plugin. Then open Maschine again. I repeat this until all plugs that cause an issue are removed and then the song will open.

    The first time it was the Buchla-Easel-V.vst3. Then after removing that I see similar errors with the Mini-V3.vst3 as well as the AU component. I copied just the error part.

    (
    Terminating Process: exc handler [9071]

    Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
    0 com.Arturia.Mini-V3.vst3 0x0000000153f08e6f 0x153d98000 + 1511023
    1 com.Arturia.Mini-V3.vst3 0x0000000153f07702 0x153d98000 + 1505026
    2 com.Arturia.Mini-V3.vst3 0x0000000153eed1c6 0x153d98000 + 1397190
    3 com.arturia.component.Mini-V3 0x000000014c95e891 0x14c945000 + 104593
    4 com.arturia.component.Mini-V3 0x000000014c96758e 0x14c945000 + 140686
    5 com.arturia.component.Mini-V3 0x000000014c94e2ee 0x14c945000 + 37614
    )

    I've had to remove 3 Arturia plugins for this song to open.

    To me this seems like Arturia, but didn't the plugs have to pass validation?

    I'm open to any suggestions. Thanks in advance for any guidance.
     
  2. Goon

    Goon NI Product Owner

    Messages:
    787
    Maschine doesnt use VST3's yet, are they in same folder as the AU/VST2's? As that maybe causing conflicts
     
  3. scheffkoch

    scheffkoch NI Product Owner

    Messages:
    585
    …is that with the latest arturia update from a few days ago?…no problems here with the older versions of the vsts…
     
  4. pfokus

    pfokus NI Product Owner

    Messages:
    58
    It looks like there is a separate folder for vst3s and all the other ones aren't causing issues. So... this makes me think it's not a vst3 problem.
     
  5. pfokus

    pfokus NI Product Owner

    Messages:
    58
    I had one before the update with the Matrix-12 plugin. I still have all the maschine crashes so I can go back and look at which plug-in took down the app. After the latest update, 2 additional ones caused the same crash, so I had to remove them to get the song to open. :(
     
  6. Goon

    Goon NI Product Owner

    Messages:
    787
    But is the path to the VST3's in Machine prefs? If so remove it.
     
  7. scheffkoch

    scheffkoch NI Product Owner

    Messages:
    585
    ...i had crashes with maschine and ableton after downgrading the modular synth...turned out i forgot to uninstall the plugin via service center first...after doing so, re-installing and running the service center again everything is normal again...
     
  8. pfokus

    pfokus NI Product Owner

    Messages:
    58
    Thank you very much for the suggestion, but it was not in the path. :(

    upload_2019-4-29_12-45-15.png
     
  9. pfokus

    pfokus NI Product Owner

    Messages:
    58
    Yeah, I uninstalled and reinstalled the offending plugins but the errors returned as soon as I reinstalled and the song wouldn't open.
    I've opened a ticket with Arturia as well as posted in their forum. Strange one, but I want to fix :)
     
  10. Goon

    Goon NI Product Owner

    Messages:
    787
    yes but are the VST3's in any if those 2 folders?