1. We're currently conducting systematic tests with the release version of macOS 11 (Big Sur) in order to offer full compatibility of our products as soon as possible. You can find our latest compatibility status - here


    Please note that although announced at the same time as macOS Big Sur, Apple Silicon processors are an independent release with separate compatibility concerns for NI products. Compatibility with macOS Big Sur will not yet ensure compatibility with Apple Silicon processors. At the moment, Native Instruments products are not supported on computers with Apple Silicon processors. Read more - here

    Dismiss Notice

Ableton Live 8

Discussion in 'KONTROL X1' started by Y2Kev, Jul 1, 2010.

Thread Status:
Not open for further replies.
  1. Y2Kev

    Y2Kev New Member

    Messages:
    17
    Has anyone started working on a X1 mapping for Live 8 ?
     
  2. shmhfd

    shmhfd New Member

    Messages:
    4
    that would be nice and helpfull.
     
  3. Y2Kev

    Y2Kev New Member

    Messages:
    17
    I'd love to start out mapping some instruments in Live like Impulse or Drum Rack, but for some reason when I'm in midi mode in Live 8 it does not receive ant midi signal... I've tried to check out the "Controller Editor" and all knobs and buttons have some kind of midi value attached to it, but in midi mode in Live 8 I get zip... Can anyone help?
     
  4. ihy2000

    ihy2000 Forum Member

    Messages:
    33
    hit shift + hot cue to switch the controller to midi mode then run live, select it as the midi in device from settings->midi and you are ready to go.

    i've tried this a couple of days ago while i was missing with my new X1, i dont think there is anything have to do with the controller editor.
     
  5. Y2Kev

    Y2Kev New Member

    Messages:
    17
    My ableton is reiceving Midi (the yellow light flashes in the top right corner) but when I try to map it to Impulse or drum rack it does nothing.... All my midi settings in live are Ok and I'm following all the mapping instructions but still nothing.... ? Any suggestions....
     
  6. electrogrimey

    electrogrimey Forum Member

    Messages:
    116
    It's not going to work in the normal mode, because it transmits HID signal not MIDI signal, it has to be in MIDI mode.
     
  7. Y2Kev

    Y2Kev New Member

    Messages:
    17
    It was all about ableton settings, but most of the instruments in live accept MIDI notes not CC's so Controller Editor is recommended... As for Session view and mixer controls the accept CC's.
     
  8. audiovoid

    audiovoid Forum Member

    Messages:
    33
    encoders

    Any of you guys noticed how mapping any of the x1's rotary encoders to an Ableton Knob or Slider results in very sketchy controls?
    I've tried the different control map modes in both the x1's editor and inside of Live (ie: relative, absoute, etc) but I still can't get it to behave properly.
    What's currently happening is if I map an encoder to , say AA Live DeAny of you guys noticed how mapping any of the x1's rotary encoders to an Ableton Knob or Slider results in very sketchy controls?
    I've tried the different control map modes in both the x1's editor and inside of Live (ie: relative, absoute, etc) but I still can't get it to behave properly.
    What's currently happening is if I map an endless encoder to , say A Live Device's on screen knob then once it's set I have to literally crank the encoder an absurd amount of times only to have live's knob just inch along in Tiny increments.
    I found that changing lives control mode to Bin Offset halfway fixes the problem except now it's the opposite. The on screen knob jumps HUGE values.
    I cannot seem to find an in between.
    ANy ideas?
     
Thread Status:
Not open for further replies.