Anyone used a Behringer BCF2000 w/Maschine?

Discussion in 'MASCHINE Area' started by Bonus Beats, Mar 1, 2019.

  1. Bonus Beats

    Bonus Beats NI Product Owner

    Messages:
    2,305
    update:
    So i picked up this second hand Behringer BCF 2000 (you know like the kind Tim Exile uses) and It works great in Ableton with flying faders and ALL, even when I MIDI map a VST to one of the faders the hardware still mirrors the softwares movements and the flying faders take motion.

    SOoo I am trying to get the same response in Maschine but the faders don't react to the moment of midi mapped knobs ... meaning the hardwares faders don't physically move to react to automation.

    Is this even a possibility in Maschine software?

    It does use the Mackie Control protocol and I have a feeling this could be why it deonst respond with movement.

    Can anyone confirm this or tell me why it sent working or what Maschine software is lacking that doesn't allow for this?

    Does machine send messages out to the controller to tell the feeder where to be at /move to?
     
    Last edited: Mar 2, 2019
  2. Uwe303

    Uwe303 NI Product Owner

    Messages:
    4,176
    No thats not possible with maschine stand alone you can only do this using a host
     
    • Like Like x 1
  3. Bonus Beats

    Bonus Beats NI Product Owner

    Messages:
    2,305
    not ideal but good idea and Ill try that.
     
  4. Bonus Beats

    Bonus Beats NI Product Owner

    Messages:
    2,305

    Hey brotha I quick question slightly out of the forums boundaries but I have recently connected this BCF thing back into Ableton live and some reason the faders only move up even when following the automations.

    Would you happen to know w of any reason why they don't follow the automation up AND down in an Ableton session?

    I thought it might be because the in or out wasn't set up properly in the MIDI prefs. but every combo I tried doesn't get it to work right.

    Here is a visual of what m talking about>




    the software reacts to everything but the faders don't move down only up and the stop at the highest point written in the automation lane.

    help would be hugely appreciated spent like 3 hours today trying to research and get going.
     
  5. Uwe303

    Uwe303 NI Product Owner

    Messages:
    4,176
    yes i can check that tomorrow but i only own live lite 10.1
     
  6. Bonus Beats

    Bonus Beats NI Product Owner

    Messages:
    2,305
    nice. Im not sure if its broken or what?
    but lite should do all the same MIDI stuff i think.
    Thanks could be a big help to either push this thing aside or have faith in it.
     
  7. Uwe303

    Uwe303 NI Product Owner

    Messages:
    4,176
    so i tried right now and in my case it works - even if i had problems with the sysex dump from live to the bcr - i can learn the faders to whatever fader or device knob and it works in both directions up and down - do you use the preset provided by ableton (send knob in prefs) or as mcu with nnc in the display?

    Uwe
     
  8. Bonus Beats

    Bonus Beats NI Product Owner

    Messages:
    2,305
    Are you talking about the bcf 2000 script in Ableton? I can’t get that one to work for me so I’ve been using the MCU in the chooser I preferences the whole time.

    I got this thing second hand and used it only a couple time before I put it away for months and finally found a spot where it can be on my desktop so brought it back out to put it In use but was caught by surprise when it seemed the faders would go downwards only fly up to the highest point in automation and then rest there unless moved by hand in which case they would fly back up after my hand released the physical fader.

    That’s he thing is that the LCD went dark after I brought it back out which made me think something could be broken but was hoping I just did t have the right choices set up In Ableton prefs.
     
  9. Bonus Beats

    Bonus Beats NI Product Owner

    Messages:
    2,305
    Also I use the preset in the BCF that you get when you power it in and hold button 4.

    Since I can’t see the LCD I’m not sure if it’s going into the eg mode (edit) and maybe that’s why it’s not working? That’s just being hopeful though I suppose.
     
  10. Uwe303

    Uwe303 NI Product Owner

    Messages:
    4,176
    OK then i will test it again with the mcu script - power on and press button 4.

    Uwe
     
  11. Bonus Beats

    Bonus Beats NI Product Owner

    Messages:
    2,305
    Thanks that would be awesome.
    Just a quick verification before I have to toss it out of the window now
     
  12. Uwe303

    Uwe303 NI Product Owner

    Messages:
    4,176
    So in my case it works but not start with the 4rth button pressed you have to press the 2nd button. Both work but with 2nd button the racks with the 8 knobs are pre mapped, press learn and for the first rack press on knob 1 and then the 2 encoders are mapped to that rack. Later i will search for a manual or at least an overlay. but now i have to go to work. There is also an option to test your device with bcmanager software.

    Uwe
     
  13. Bonus Beats

    Bonus Beats NI Product Owner

    Messages:
    2,305
    EF6FCE84-A1AE-47E4-9414-B4212B01EDB2.jpeg Ya this thing is freaking out. Don’t know what’s going on with it now the LCD freaked it’s lighting up but still not functioning right.
     
  14. Bonus Beats

    Bonus Beats NI Product Owner

    Messages:
    2,305
    well I guess I could use the Maschine jam template seems to be pretty cool.
    Ill give this to a buddy.
     
  15. Uwe303

    Uwe303 NI Product Owner

    Messages:
    4,176