Can I extend the Session Horns Forte-Piano-Crescendo length?

Discussion in 'KONTAKT' started by foamj, Feb 2, 2017.

  1. foamj

    foamj New Member

    Messages:
    9
    The Forte-Piano-Crescendo setting on the Sessions Horns instrument is perfect for me... except the notes are too short!

    Sample here: https://www.dropbox.com/s/60aa1oj9fmgd3q7/hornsproblem.wav?dl=0 The horns stop before the end of every second bar.

    The manual says: "Short for Forte-Piano-Crescendo (Italian: loud/quiet/growing). This articulation starts with a loud attack, gets quiet very quickly, then increases volume and finally ends abruptly. The dynamic process is based on a tempo of 120 BPM (beats per minute)."

    There's also a Forte-Piano-Crescendo (Time) mode: "This articulation is the same as FoPiCre above, but here the dynamic process is synced to the tempo setting of your host sequencer!"

    I have the same problem whether I set it to the "FoPiCre" or"FoPiCre (Time)" modes. Is there any way to lengthen the length of the notes?
     
  2. EvilDragon

    EvilDragon Moderator Moderator

    Messages:
    14,564
    Hmmm, not sure I can confirm that here. I'm checking with 4 beat variant, enabled timestretching in Control tab... the crescendo does end up nicely when the second bar begins.
     
  3. David Das

    David Das Moderator Moderator

    Messages:
    6,988
    foamj, have you checked to make sure Kontakt is correctly syncing to your host sequencer? If you say you're having the same problem with FoPiCre and FoPiCre (Time) that tells me that maybe it is not...
     
  4. foamj

    foamj New Member

    Messages:
    9
    Thank you for the replies so far!

    I'm running Kontakt as a VST plug-in in Ableton. I'm an experienced Ableton user but don't know the advanced functions of Kontakt yet. Other instruments loaded in Kontakt seem to sync to the Ableton tempo - for example arpeggiators on synths and stuff.

    Do I need to enable timestretching? How do I do that? I googled "Kontakt Control tab" but couldn't find anything obvious.
     
  5. David Das

    David Das Moderator Moderator

    Messages:
    6,988
    In the header to Kontakt, make sure you have Master enabled:

    http://imgur.com/a/D8JhF

    Then, check the Master header for something like this:

    http://imgur.com/a/FhN48

    See my EXT button is highlighted? This means Kontakt is slaved to external sync, i.e. it's receiving sync/tempo information from your host sequencer. If you change the tempo in your host sequencer, this number (86 in my screenshot) should update in real-time.

    I typically keep external sync on at all times. The patches that don't sync to tempo ignore it, and the patches that do sync to tempo need to be able to chase to the changing tempo of the host sequencer.
     
  6. foamj

    foamj New Member

    Messages:
    9
    Thank you so much for the detailed reply and screenshots. I really appreciate it.

    EXT was already on and Kontakt does indeed change BPM when I change it in Ableton. I didn't have Master enabled, but enabling it doesn't change anything. :(
     
  7. David Das

    David Das Moderator Moderator

    Messages:
    6,988
    OK, strange. So at least we know tempo information is getting to Kontakt. Now we have to figure out why Session Horns isn't responding to it (when using tempo-synced patches).
     
  8. foamj

    foamj New Member

    Messages:
    9
    So, just to make absolutely sure, when you guys use this patch, the note lasts until you release the key? It doesn't have a max length?
     
  9. David Das

    David Das Moderator Moderator

    Messages:
    6,988
    I just tested this and it works properly.

    But note that "the note lasts until you release the key" wouldn't work with f-p-c. That would only work with sustain articulations.

    I did a quick video demo of how it's made to work:

     
  10. foamj

    foamj New Member

    Messages:
    9
    A video, awesome, thanks.

    Yes, the "lasts until it holds the key" was a dumb example that I hadn't thought through. That isn't exactly what I want and I understand why it wouldn't work. I just want the note to last for the duration of the midi note.

    OK, your video helped me figure out the problem. The note always lasts the duration of one bar and no longer, no matter the tempo. I need it to last beyond for two bars. Is there a way to do that? If not, I can still hack it halving the tempo, which creates the same effect, though that's inconvenient and means I have to mess around with a lot of other things.
     
  11. David Das

    David Das Moderator Moderator

    Messages:
    6,988
    I just checked the manual and don't see any controls for this (apart from a .5/1/2x button).

    Other libraries do let you adjust the length of tempo-synced patches (e.g. Rise and Hit) but apparently not Session Horns...sorry.
     
  12. foamj

    foamj New Member

    Messages:
    9
    OK. Thanks so much for your help, I really do appreciate it!

    I think I can get round this with some manipulation...
     
  13. sean.jam

    sean.jam New Member

    Messages:
    1
    Hey guys,

    I've been having this difficulty myself with wanting the "FoPiCre4Beat" crescendo articulation to span over 8 beats/2 bars.

    I have found the solution!

    Make sure "time stretching" is enabled in the "control" pane. Notice if you have "info" enabled in Kontakt it says "Turn on/off time stretching for PoPiCre2Beat and FoPiCre4Beat articulations." when you hover over the time stretching button:

    upload_2017-5-31_13-33-19.png

    Then make sure the Kontakt "master editor" pane is enabled:

    upload_2017-5-31_13-48-30.png

    Click "Ext" to unsync Kontakt from your DAW's tempo. Then if you want to the 4 beat articulation to span over 8 beats... halve the BPM!

    upload_2017-5-31_13-51-28.png

    Hopefully this helps anyone else who thinks a 1 bar crescendo is too short!
     
    Last edited: May 31, 2017
  14. blackmatt

    blackmatt New Member

    Messages:
    1
    well, with one search this thread sorted me out to understand this! thanks everyone. FoPiCre FTW!