Can't cancel pitch bend on Session Horns

Discussion in 'KONTAKT' started by Richard Buckton, May 13, 2019.

  1. Richard Buckton

    Richard Buckton New Member

    Messages:
    5
    Hard to sum up in a title but I've used the pitch bend in Session Horns Pro to add some falls to a part (and you can see them in the step editor, all fine). The problem is when the saxes come back in after several bars of space, new region in Logic etc they are playing as if the pitch bend hasn't been cancelled. Look in the step editor and there are no recorded pitch bends to be seen. How can I 'cancel' that command? I've tried duplicating the last pitch bend event and setting the bend to 0 but that didn't work.
    Thanks
    Richard
     
  2. David Das

    David Das Moderator Moderator

    Messages:
    6,994
    I'm confused by you saying "there are no recorded pitch bends to be seen" then "I've duplicated the last pitch bend event" -- those two seem to conflict.

    When you do the bend down, do you see the pitch bend information on that note? If so -- just as a test -- try removing half of it (so it pitch bends only halfway of your intended distance). Play back. See if the playback follows the new data. That might provide a clue.
     
  3. Richard Buckton

    Richard Buckton New Member

    Messages:
    5
    Thanks David. Yes, I wasn't that clear - I meant there were no visible events on the later region (where I don't want the falls) and that I'd duplicated the last event in the earlier region (with the falls) in an attempt to reset the track. I tried changing the last event to see if that changed the unwanted falls in the later region but it didn't. I've also just deleted the affected region and replaced it by copying an earlier instance of it (which plays fine) and the problem's still there. So it's not data in the actual region but something on the track (in fact my short term fix has been to duplicate the track and use a new one which works fine but isn't the best use of memory).
    So here's the region with the falls (visible);
    Screenshot 2019-05-14 at 15.00.32.png
    And here's the region after which has no events but plays with falls;

    Screenshot 2019-05-14 at 15.02.38.png
    Maybe it's just not fixable but thanks for the suggestions, very grateful.
     
  4. David Das

    David Das Moderator Moderator

    Messages:
    6,994
    This is hard to diagnose from afar because I can't be 100% sure of what is what in the screenshots. However, here's a new clue: you have two different tracks named saxes. Is it possible you have two MIDI tracks set to the same MIDI channel destination (the Session Horns instrument)? Maybe the event chasing on one track is overriding the pitch bend on the other, causing it to not respond to the pitch bend you *do* want.

    Double-check your MIDI assignments. And if you do have double tracks heading to the same MIDI channel, try temporarily deleting one, then trying your pitch bend tests again, to see if it starts working. If it does, you've found the cause.
     
  5. Richard Buckton

    Richard Buckton New Member

    Messages:
    5
    Will do, thanks.