1. We're currently conducting systematic tests with the release version of macOS 11 (Big Sur) in order to offer full compatibility of our products as soon as possible. You can find our latest compatibility status - here


    Please note that although announced at the same time as macOS Big Sur, Apple Silicon processors are an independent release with separate compatibility concerns for NI products. Compatibility with macOS Big Sur will not yet ensure compatibility with Apple Silicon processors. At the moment, Native Instruments products are not supported on computers with Apple Silicon processors. Read more - here

    Dismiss Notice

Collection cannot be read error

Discussion in 'Technical Issues (Archive)' started by garysulter, Nov 3, 2008.

Thread Status:
Not open for further replies.
  1. garysulter

    garysulter NI Product Owner

    Messages:
    35
    tried this.. it worked twice, third reboot and same problem :(
    also tech told me to do this...

    I assume that you changed the Root Directory under Data Location within the
    Preferences to your Traktor 3 folder. This does not work! Please open the
    Preferences in Traktor, go again to Data Location and and then hit the
    "Default Dir" button. After you did that, please right click the Track
    Collection icon in Traktor's user interface and choose "Import Collection".
    Then please select your Traktor 3 Collection to be imported

    I hadn't changed anything but did as I was told and..... same bloomin problem..... I'l call them again and let you know of any outcomes....
     
  2. sla200x

    sla200x Forum Member

    Messages:
    43
    I though I got mine fixed and this just happen again and I just lost an entire weekend of work for the 4th time.This is a major bug that NI need to fixed! Even if you are not having this problem you should be concerned that your entire collection can blowup one you at the most inopportune time. I notice many of you reported this issue occurred when importing your T3 Collection. In my case (the first 3 times anyway.) I did not use my T3 collection,. I just imported directly from my Music folder. After seeing the "solution" posted here I decided to do the T3 collection import on my 4th try. It appeared to work at first. Now after getting my playlist and beat grids perfect and ready for a gig this Wednesday, I shut down T-Pro and got the same error again (upon reopening Pro) and lost all my work. This is ridiculous!

    Can someone from NI comment to let us know if this on the on the high priority fix list? Right now Pro is unusable for some of us.

    Thanks
     
  3. garysulter

    garysulter NI Product Owner

    Messages:
    35
    I totally agree... I was really looking forward to this new version and I'm having so many problems just to import tracks that T3 manage with no problem...This must be a High Priority for the NI guys...
     
  4. PhrunkyTek

    PhrunkyTek NI Product Owner

    Messages:
    5
    Same problem with my playlist totally gone when rebooting. I've uploaded the playlist from the backup at least 6 times, sometimes my playlists are all in tact (but in red, meaning can't locate tracks in these playlists). Then, I'll relocate the last correct collection that was correct in the backup history, import playlist and then will have to hand drop the playlists from the menu on the left, back into the shortcut playlist menu.

    This happened to me when I foolishly wanted to play a gig with TraktorPro last night as well, freaked out and went back to Traktor3 when I had set up everything, booted up the computer to only find TraktorPro had done it again. All my tags are written correctly, my direct root path is the original that came with TraktorPro. Today, I've been able to shut down TraktorPro a few times and the playlist has been in tact, but I don't know if I do a reset on my entire computer, if it will be different. I'll report if I find any stable solution.
     
  5. sla200x

    sla200x Forum Member

    Messages:
    43
    Can a moderator please comment on this problem. At least let us know whether or not this has been escalated or something. Thanks
     
  6. Kirk Smeaton

    Kirk Smeaton NI Product Owner

    Messages:
    401
    I've got the same problem here.

    I'll try the solution posted by DJ_AS but it's going to take a while to "write tags" in T3 so if there is a better, more reliable solution I'd like to hear about it.
     
  7. chilly

    chilly Returning Customer

    Messages:
    3,131
    What's "better" or "more reliable" than what was posted?

    It's the best and most reliable solution.

    In the time that's past since you've posted, you could have easily have wrote all your tags.
    ---
    The only problem with this is that you wipe out all the built-in playlists from TPro (with the scratch samples and such).

    If you export all the playlists from TPro first, then you follow your directions, you can reimport them when you're complete :)
     
  8. DJ_AS

    DJ_AS NI Product Owner

    Messages:
    452
    To be honest I didn't even notice the scratch samples were in a playlist - I can confirm that they're still in the collection. Its just that all my old collection is correctly re-imported too.

    Still working well without any problems. *fingers crossed*
     
  9. chilly

    chilly Returning Customer

    Messages:
    3,131
    They're definitely still in the collection, just those playlists are gone. I didn't mean to be confusin.

    They are actually in quite a few playlists (like 5 or 6 just off the top of my head).

    That's great that you're still working without problems!
     
  10. Kirk Smeaton

    Kirk Smeaton NI Product Owner

    Messages:
    401
    if only that were true - it took about 18 hours of tag writing and then got to The Robert Cray Band and froze - a dodgy m4a file being the problem I think.
    Anyway had to force quit and start again - it's still writing tags as I type ...
     
  11. chilly

    chilly Returning Customer

    Messages:
    3,131
    Damn...but at least you're getting through it.
     
  12. planb76

    planb76 New Member

    Messages:
    3
    Hey guys.. I think i've found a "kind" of solution.. I did everything i could to import my collection from TS but the problem still remained..
    So when i tried not to import my playlists too (!) Tpro starts up normally without collection errors..
    when i try to import my playlists too i will post my results..

    (ps:this whole thing is ridiculous, i've been using Final Scratch since 2004 and now the things r getting more complex, why NI doesn't support us like it should?)
     
  13. chilly

    chilly Returning Customer

    Messages:
    3,131
    Are you greek?
     
  14. hightekpimp

    hightekpimp New Member

    Messages:
    1
    I fixed it for me, here is how (very easy, Laymen Instructions)

    Okay first of all, I'm new here and have been reading the situation you guys were in because i myself have been experiencing the same problem.
    I run Windows Vista 64 bit edition. Just in case this matters.
    After following the idea of,
    * writing tags to the files in Traktor DJ Studio 3.4.
    * I then closed all Traktor programs.
    * rename the "Traktor3" folder in "My Documents" to the "Traktor 3 backup" folder.
    * copy the "traktor 334" folder (or whatever folder that was called, but something like that) located in the "My Documents/Native Instruments" folder to that renamed folder named "Traktor 3 Backup" in the "My Documents" folder.
    * uninstall Traktor 3 DJ Studio completely. Not Pro/Scratch
    * deleted the collection.nml from the "My Documents/Native Instruments/Traktor" folder
    * copy the collection.nml file from the backup folder to the "My Documents/Native Instruments/Traktor" folder.
    * Open Traktor Pro/Scratch and it will tell you that the file has to be converted to the new format. Agree and proceed as you have your backup anyways.
    Upon doing so your collection should work.
    Now the test , go ahead close the program, reopen it, reboot your PC. Run Traktor.
    The collection should remain to load properly.
    YAY !
    I hope this works for you all as it did me. Let me know.
     
  15. cherab

    cherab NI Product Owner

    Messages:
    21
    Anyone achieved to import its cue points from T3 to TPRO ?

    I just imported the readjusted BPM (many bugs yet) and all my load and grid cue points are not there...

    NI have messed up with it, specially when you preordered and you assumed that you would just have to transfer collection to get things right..Now I got TPRO and it's not working, I have the feeling I shouldn't have switched so quickly.


    If someone did it well, please let all members know.

    EP
    ---
    I forgot to say playlists are unexportable, they remain in grey when I try to import them on TPRO.
     
  16. Fresh519

    Fresh519 NI Product Owner

    Messages:
    108
  17. buffalo joe

    buffalo joe New Member

    Messages:
    2
    did this before a gig yesterday and it seemed to work ok, but today the 'collection invalid' spectre was back again.

    doh! joe
     
  18. stylebreakup

    stylebreakup New Member

    Messages:
    14
    I have the problem, that I can not import my old collection. If I click on "Import Collection" the t3 collection file is just grey and not clickable.
     
  19. onno

    onno Forum Member

    Messages:
    51
    never used T3, same problem

    I see a lot of people having problems with this because they want to use their T3 collection.

    I started my Tpro collection from scratch and have the same problem!

    This needs to be fixed!
     
  20. Marius @ NI

    Marius @ NI NI Team NI Team

    Messages:
    1,052
    Hello,

    we recently detected that on Mac this error can be caused by a slash which is used in one of the file names of the tracks being used. Therefore it would be good to know if everybody who could not solve his problem yet, has a slash (/ or \) in one of the track names. The problem should only appear when the slash is at the beginning or at the end of the name.

    On PC this was reported just a few times yet, since this special character is not allowed to be used as file name on Windows, but the problem might appear in a cross platform situation when you move files and collections from Mac to PC. This problem shall be fixed in a future version, of course, but for know you might search your track folders on the hard disk for slashes and change the names if necessary.
     
Thread Status:
Not open for further replies.