1. Please do not install macOS 10.15 Catalina yet, as Native Instruments software and hardware products are not supported under macOS 10.15 yet. For more info, please go HERE!
    Dismiss Notice

Confused and in need of serious help...

Discussion in 'TRAKTOR 3' started by scoundrel, Feb 13, 2010.

Thread Status:
Not open for further replies.
  1. scoundrel

    scoundrel New Member

    Messages:
    2
    Hi
    I have been DJing on Traktor on a friends laptop with him live for about a year now,i have become very familiar with the setup we have it on when we play and the current version ( v3.1.3) which he has.
    I decided after earning a bit of money that i should get my own kit having enjoyed his so much,but i opted too go for a mac instead of pc for various reasons but mainly for stability and so i can produce when i dont have a desktop nearby.
    The problem is,i dont know anything about where too get this particular version,ive tried most methods and am happy too pay but i cant find it,other versions dont cut it for the style i seem too have developed :-(
    If anyone can point me in the right direction id be grateful
    Ta very much

    EIDT: just read the first post at the top by the administrator that mac v 10.6 crashes anything previous too Traktor pro ,gutted.....any suggestions on a version thats very similar too 3.1.3?
     
  2. fabriknos

    fabriknos Forum Member

    Messages:
    21
    All of the 3x versions are very similar in form and function. what specifically does 3.1.3 do that the other 3x versions don't?
     
Thread Status:
Not open for further replies.