1. Please do not install macOS 10.15 Catalina yet, as Native Instruments software and hardware products are not supported under macOS 10.15 yet. For more info, please go HERE!
    Dismiss Notice

Komplete Kontrol not recognizing Kontrol 61

Discussion in 'KOMPLETE KONTROL SERIES' started by Murdox, Jan 21, 2017.

  1. Murdox

    Murdox New Member

    Messages:
    5
    All, I've been struggling mightily to fix this issue. I'm on a Mac OS 10.10.5 and although my Kontrol 61 is showing up in USB on my Mac report and testing out fine in the Audio/Midi Studio, I can't seem to get Komplete Kontrol to recognize it. It is greyed out as a controller option. In other words, it wiill play all the instruments and send MIDI signals, but the Browse function and all of the upper controls on the keyboard are useless. Any ideas?
     
  2. Murdox

    Murdox New Member

    Messages:
    5
    I should add that I have Pro Tools 11 installed but I am simply trying to use the stand alone version of Kontrol. In other words, I am just running Komplete Kontrol alone. The Kontrol 61 can play MIDI but all other functionality is dead. Pressing Browse, Instance does nothing and those controls seem dead. Not sure if that is normal. The middle knobs are lit and in some factory setting.
     
  3. Murdox

    Murdox New Member

    Messages:
    5
    Edit - I found the documentation on removing the Avid driver. And now it works. That said, how the heck am I supposed to use this with Pro Tools if I can't use that driver?
     
  4. terrybritton

    terrybritton NI Product Owner

    Messages:
    582
    On a PC (not sure about how Mac is configured) the S-series keyboards expose three ports to the system -

    Komplete Kontrol -1 (The keybed, pedal, mod-wheel, pitch-wheel)
    Komplete Kontrol -EXT (Whatever is plugged into the S-Series MIDI-In DIN plug)

    and most importantly

    Komplete Kontrol -DAW (all of the control signals sent to and from the keyboard for the knobs and buttons, control of the KK software, etc.)

    If all three of these can be accessed, that is a good thing... but maybe not!

    For instance, Digital Performer, in "Single Record" mode, opens up every single port as an input. The unfortunate effect is that it opens the Komplete Kontrol -DAW port as if it was a normal MIDI stream, and what "seems" like a MIDI feedback loop takes place, and there is no other way to isolate the ports and channels in that "Single Record" mode, so you are forced to use "Multi-Record" which permits selecting ports and channels for that track.

    If Pro-Tools is doing something similar -- not treating the Komplete Kontrol -DAW port as a special case -- it could be freezing things up the same way as happens in DP. I suspect that is the case from what you report here.

    See if you can isolate the Komplete Kontrol -DAW port and not pass it into Pro-Tools, perhaps.

    Terry

    P.S. - there also is the OSX 10.10 issue that I think you already were referring to.
     
    Last edited: Jan 22, 2017
  5. Murdox

    Murdox New Member

    Messages:
    5
    Terry, I think my issue is related more to the OSX 10 issue you link to, which is where the Pro Tools plug in apparently interferes with the ability of Komplete Kontrol to recognize that the Komplete 61 keyboard is attached. I haven't even tried to use Komplete with Pro Tools yet, but I find it ridiculous that I need to remove the Pro Tools Avid Core plug-in before being able to use NI in stand alone. I'm not sure what that Avid Core plugin does, but I assume I need when recording in Pro Tools, so I'm a bit puzzled how I would use the two systems together.
     
  6. terrybritton

    terrybritton NI Product Owner

    Messages:
    582
    I get the drift from that article that the Avid Core plug-in is only needed for some kind of monitoring of external inputs, not of VSTi's. Could be wrong there, but give it a try and see how far you can get.

    Probably both the Komplete Kontrol -DAW and the AVID Core ports are trying to use the exact same resources or memory addresses, like the old IRQ conflicts hardware used to have back in the day, perhaps. They'll have to come to some agreement, I imagine.

    Terry
     
  7. Young Blew

    Young Blew NI Product Owner

    Messages:
    27
    Good morning. I am having a similar issue, the only difference is, I don't have Pro Tools installed. Pro Tools 11 doesn't support a lot of my plugins and I mistakenly upgraded to OSX 10.11.6 after a hard drive swap, which doesn't support Pro Tools 10, so no pro tools at the moment. Any idea why Komplete doesn't recognize my S49? Any help would be greatly appreciated.
     
  8. Tim @ NI

    Tim @ NI Director | Music Production NI Team

    Messages:
    331
    • Informative Informative x 1