M-Audio fast track pro + traktor 3

Discussion in 'TRAKTOR 3' started by r3dGeert, Mar 4, 2008.

Thread Status:
Not open for further replies.
  1. r3dGeert

    r3dGeert New Member

    Messages:
    4
    Hi people,

    I recently bought a M-Audio fast track pro USB audio interface for my powerbook with OS X Leopard (10.5.2).
    Almost everything I planned on doing with it works out fine (for example, connecting it to 2 channels on an analog mixer, etc.) but there is one thing I can't figure out.

    When I'm at locations where I do not have a mixer available to connect my fast track pro with I'd like to do be able to do some internal mixing in Traktor 3.
    My fast track pro has 2 RCA outputs, stereo 1/2 and stereo 3/4. While mixing internal in Traktor I set my master to stereo 1/2, stereo 3/4 is not assigned to anything at this point. The problem I run into is that I can't figure out how to use my headphones the way Traktor is designed to use them.
    When I plug my headphones into my fast track pro, I'm able to select stereo 1/2 or stereo 3/4 as source for my headphones. As stereo 1/2 has the master assigned to it, this is the only signal I hear when I select this output at my headphones setup. The only other option, stereo 3/4 doesn't do anything.

    So basically, when internal mixing I've got 1 of the 2 RCA outputs assigned to the master output, how do I configure my headphones so I can use Traktor's cue-ing to prelisten etc.

    An overall note: I'm a bit disappointed by the options I have in my system preferences and in Traktor preferences about setting up this audio interface.
    In Traktor I can only select output 1/2/3/4 to be assigned to master/booth/monitor/record and in system preferences I can only enable/disable the 2 RCA outputs, 1 inputs and the S/PDIF in.

    I downloaded the newest drivers already, didn't change anything. Thanks in advance for your help!
     
  2. Argus225

    Argus225 Forum Member

    Messages:
    74
    hmm. well, the FastTrack Pro has 2 stereo RCA outs plus a headphone jack on the front. that's obviously the one you'll want to use for cueing.

    now, Traktor should actually give you 3 output pairs. 2 each for the stereo RCA, and 2 for the stereo jack. so if you find out which one that is and set it as monitor, your problem should be solved.

    if, however, the headphone out is not even recognized in Traktor, then it's a little more complicated. either it's something with the drivers (which you said didn't change anything though), or some other more complicated problem.

    do you use a mac?
    if you do, you could create an aggregate device and either try to find your M-Audio's phone jack or just use the one on your computer.

    the way to create an aggregate device is to find and open the application "Audio MIDI setup", select "Open Aggregate Device Editor" from the Audio drop down menu, and create a new one in there.

    hope that helped a bit. and I hope you have a mac, so that wasn't all for nothing! :D
     
  3. r3dGeert

    r3dGeert New Member

    Messages:
    4
    Yes, I have a mac (i mentioned that in the first sentence of my post :) )

    I found a workaround as a mac indeed doesn't recognize the headphone jack by default, this solved the problem:

    Follow these steps on Mac OS:
    Go
    Utilities
    Audio Midi Setup
    Audio
    Make sure th MAudio is set for Default/System Output
    Click Configure Speakers
    Click Multichannel
    Change to Quadrophonic
    Click Ok
    Save all the changes

    Then you should be able to setup your monitor output to either the 2nd RCA output which you can listen to over your headphones, or if you use other software setup your cue-ing differently.

    Thanks for helping out!
     
  4. Argus225

    Argus225 Forum Member

    Messages:
    74
    I'm like a therapist, I help people find the solution THEMSELVES :D
     
  5. dozens

    dozens New Member

    Messages:
    12
    Hey r3dGeert, did you install the drivers for the Fast Track Pro? Just curious if they are really needed with OSX or not....
     
  6. r3dGeert

    r3dGeert New Member

    Messages:
    4
    lol @ Argus :) You did point me out the right direction though, thanks for that!

    Dozens:
    There is no need to install drivers if you are only planning to use 1 RCA stereo output and the headphones jack. If you want to use all options on the fast track pro (all 4 stereo outputs, S/PDIF, inputs, etc) then you do need to install the drivers.

    Driver support for mac is quite good though, drivers are really small and they work perfectly fine for me!
     
  7. jltnol

    jltnol Forum Member

    Messages:
    146
    There is a MUCH easier way.

    1. Go to M-Audio's website, download and install the OSX driver for your Fast Track Pro.

    2. Once installed, go to the System Prefs, find the Prefs for Fast Track Pro, and make sure that both Output 1 & 2 and Output 3 & 4 are checked.

    3. Start Traktor.

    4. In Traktor prefs, with internal mixer engaged, you can now choose to route your main audio out to 1 & 2, and your Cue/Monitor/Headphone output to 3 4.

    5. On Traktor, the top RCA's(1 & 2) will be your main output, and would connect to the house sound system.

    6. You can connect a pair of headphones to the front, press the A/B button, twist some dials and you should be able to hear the Traktor Monitor output there.


    And as an aside, the M-Audio does not have 3 pair of audio outs... it only has 2 pair. The digital output mirrors outputs 3 & 4.

    The 1/4" outputs, labeled TRS are balanced audio outs and should be used in place of the RCA outs if at all possible.

    The two 1/4" jacks labeled INSERT have to do with recording and mixing.
     
  8. r3dGeert

    r3dGeert New Member

    Messages:
    4
    I'm not sure where you think I mentioned that the fast track pro has 3 pair of outputs, because it indeed hasn't.

    If your solution works as well, it does makes things easier. But as long as it works, I'm happy either way :)
     
Thread Status:
Not open for further replies.