We launched a new online community and this space is now closed. This community will be available as a read-only resources until further notice.

Our Traktor Pro Public Beta is available again in our new online community. Join us if you want to try new features.


New MacBook Pro 16 M1 Pro - V3.5.2

Discussion in 'Bug Reports' started by stfer, Nov 29, 2021.

  1. stfer

    stfer New Member


    on MacBook Pro 16 M1 Pro with Monterey 12.0.1, I'm having a big problem with traktor. Could not close it properly, I have to force it to quit the program. Regularly, the interface stops responding when I modify parameters in the configurations. It is currently unusable :(

    Thank you very much for your feedback.
    • Like Like x 1
  2. cirmler

    cirmler Member

    Hi Steven,

    here is my experience and steps I did so far:

    1st I decided NOT to migrate my 16" (2019) Intel MacBook Pro to my new M1 Max MacBook Pro!
    Instead I did a fresh, new install of Traktor with the same username as on my old MacBook Pro.

    After finishing the install Traktor freezes on the first start at the Beatport dialog at the end of the setup wizard.
    I forced quit Traktor, restarted Traktor and went to the settings where I disabled the "Multicore Support" in Audio Settings.

    Next I played around a bit with NO external HW connected and everything worked fine.

    Now I copied my music folder, Native Instruments folder in Documents and shared folder in users to an external SSD drive.
    I closed Traktor, then copied the original files in the folders on my new MacBook (deleted the folders from the install first) and after everything was copied I restarted Traktor.

    Before anything else, I did the consistency check on my music collection, deleted missing files from the collection (they where left in my download folder on the old MacBook) then I analyzed tracks which haven't been already. So at the end my collection looked fine.

    All this went well and very fast without any issues. I played around locally, checked some tunes and all seems to be ok.
    Next I connected my S4MK3 - and first it was not found by Traktor... checked in the OS system info and found out that it was not recognized.
    I exchanged my USB-C hub with an Apple original USB-A -> USB-C adapter. S4MK3 was successfully connected.

    Fist play went well, so I decided to give it a try on my gig (had my old MacBook Pro as Backup with me).
    Played 4 hours, switched between local files and Beatport with no issues at all.

    Checked the settings again and been surprised that "Multicore Support" was ticked again (from the copy of my settings of course).

    Overall I really loved the snappier response on the new MacBook Pro M1. Everything is just lightning fast.

    I hope my experience and the steps are helpful for you or anyone else who want to move to a new MacBook Pro M1.

    Sunny greetings,
  3. Friedemann @ NI

    Friedemann @ NI NI Team NI Team

    We can confirm that both scenarios exist on M1 Max and M1 Pro - flawless functionality and freeze on startup or other symptoms.
    We need to find out what makes the difference, in order to get closer to find a workaround or a fix.
    One assumption is the clean install, vs. the migration.
    As we don't have an in-house repro yet, any help/insight is welcome to shade light in this problem.
  4. re5etuk

    re5etuk New Member

    mine is a fresh install.
    after a few tries of loading/setting no multi processor / exiting it seems to be ok .
    i deleted all stems etc etc from collection & hard drive , a few times (when it didnt exit properly) the collection was still present but with '!' present, so i guess it didnt save the collection properly.

    but ive deleted it all again , exited and its no longer failing to quit.
    I'll add some of my own music and see how it works in the next day or two.

    so to clarify.
    fresh install, it was not quitting properly.
    ive ensured multi processor is off , but also deleted all stems etc.
    its is now quitting ok.

    AND , on this machine it starts up full screen!. .. my other machine never does.even with the setting flagged.
  5. Bob!

    Bob! New Member

    Thanks for the detailed post here. I want to offer my data points.

    M1 Pro
    Fresh Install
    Hangup on Link page, eventually disabled multi core, still hung on exit, would not play any mp3 (green play button but no movement of the mp3/sound)
    Deleted the pre installed collection
    Right clicked on collection and hit save
    Quit traktor and it quit successfully
    Restarted, clicked "continue without link", traktor started, added an mp3 of my own and the deck plays the music!!!

    I have a Z2 that I will be testing tomorrow morning and will update here. And probably let this thing play on auto loop for a few hours.

    I also want to say that I both really appreciate the devs and the native team, the individuals trying to get compatibility with an ever moving target of apple hardware and software, and it can also be frustrating not having day one compatibility. I'm buds with some full time developers and they get slapped around by expectations and moving targets. While it can be frustrating to not have our new computers and not able to run our software of choice on day on (errr... or many days after that), I think the frustration is warranted while also having a lot of appreciation for the on the front line devs of NI doing their best. Would I prefer NI and Apple to prioritize my scenario of software? Of course! Do I think we need to give those individual devs and mods the heat of that frustration? nah.

    Keep up the good work everyone and I'll keep my intel MacBook as a backup :)
    • Like Like x 1
  6. cirmler

    cirmler Member


    ...I had my AirPods still on, because I organized some music in Apple Music... starting Traktor the audio in the AirPods has changed (became muffled) and Traktor has frozen... AirPods back into the charging case - thus the last audio settings (MacBook Core Audio) were back and Traktor has started through normally!


    changing the Audio Buffer Size - FREEZE
  7. Bob!

    Bob! New Member

    update from my last thread - Z2 worked!
    hot tip to remember - mac sys pref > privacy > microphone > allow traktor access (this was causing the z2 to not "hear" the turntable)
    • Informative Informative x 1
  8. Bob!

    Bob! New Member

    another update - z2 worked for the entire 5hr gig! My takeaway / experience - delete the entire preinstalled collection, right click on collection in the tree, click save, restart and if lucky like me, you're good to go!
  9. DjIbiza

    DjIbiza New Member


    I am also experiencing a lot of bugs with the new Monterey and Traktor Pro 3.5.2.

    I cant do any modifications in settings as this will make the program unresponsive. I have to force quit to close traktor.

    If i dont go into settings and try to play a file it does not playback only the green light turns on the play button but no actual file playback.
  10. djyyjohn

    djyyjohn New Member

    Also experiencing these problems :( Program freezes on startup when adjusting any setting. Deleting collection.nml and Traktor\ Settings.tsi allows me to start Traktor, but then tracks won't play when my controller (S4MK3) is plugged in. Adjusting any settings causes the program to hang.