1. Hi everyone,

    Apple just released Logic Pro 10.5 for MacOS 10.15. We found out that Crush Pack, Mod Pack, Replika, and Replika XT will crash.

    Our teams are currently working on a fix, and we hope to have this out to you as soon as we can!

    Best wishes, 
    The NI Team

    Dismiss Notice

Mapping "Cue type selector" doesn't seem to work

Discussion in 'TRAKTOR PRO / TRAKTOR SCRATCH PRO' started by mykejb, May 20, 2013.

  1. mykejb

    mykejb NI Product Owner

    Messages:
    630
    I have "Cue Type Selector" mapped to an unused key on my keyboard with controller type as "button" and "Interaction mode" as INC.

    When I press the key the current cue type is set to Cue, and subsequent keypresses do nothing. If I set the mode to DEC then the cue type is set to Loop and again subsequent presses do nothing.

    I'm expecting that keypresses would cycle through the cue types as this is the logical thing to do. Am I doing something wrong with the mapping or is this a possible bug?

    Mike
     
  2. DJ Freshfluke

    DJ Freshfluke Traktor Mod Moderator

    Messages:
    26,779
    can you post a screenshot of the respective mapping?
     
  3. -Yul-

    -Yul- NI Product Owner

    Messages:
    1,152
    it doesn't cycle, it goes up (inc) or goes down (dec) usually.
    so if you want to make a cycle you have to set a starting point and use a modifier that would also increase so when you reach the upper value, it resets or goes back to value 0 (with corresponding hot cue type).
    Does that make sense (I'm in a hurry so that's the short version).
     
  4. frankle

    frankle NI Product Owner

    Messages:
    870
    Sorry to bring up an old thread but just trying to do this myself and same problem with my X1mk2.

    Screen Shot 2014-05-25 at 9.59.01 pm.png

    Trying to use some of the un-used FX buttons for beat-gridding and cue-mapping/changing.
     
  5. Jodi Curtis

    Jodi Curtis New Member

    Messages:
    23
    I've encountered this using inc/dec buttons and using an encoder, neither work on 2.9
     
  6. w00t

    w00t New Member

    Messages:
    9
    This got broken wayyyyyy back but I remember I used to be able to do this from my controller..
    now it seems NI doesn't give a single **** about this, cause the bug's been standing for years!
     
  7. Stevan

    Stevan NI Product Owner

    Messages:
    889
    It works eventually but you have to work on the "Hotcue X State" modifier setup.
     
  8. muthafunka

    muthafunka NI Product Owner

    Messages:
    241
    I know this is ooooold but it still doesn't work...could you explain how to do that? thanks