1. We're currently conducting systematic tests with the release version of macOS 11 (Big Sur) in order to offer full compatibility of our products as soon as possible. You can find our latest compatibility status - here


    Please note that although announced at the same time as macOS Big Sur, Apple Silicon processors are an independent release with separate compatibility concerns for NI products. Compatibility with macOS Big Sur will not yet ensure compatibility with Apple Silicon processors. At the moment, Native Instruments products are not supported on computers with Apple Silicon processors. Read more - here

    Dismiss Notice

Bug Maschine V2 Multi Port MIDI Out (Windows)

Discussion in 'MASCHINE Area' started by Mystic38, Nov 26, 2014.

  1. CakeAlexS

    CakeAlexS NI Product Owner

    Messages:
    5,427
    Not sure if extra coding is needed for this or not. It might just be handled in the core. If anything it may be the drivers that need tweaking..
     
  2. PlipPlop

    PlipPlop New Member

    Messages:
    12
    Is it possible that this bug is not fixed because of a hardware bug in the maschine midi hardware? That is the only reason I can think of why this bug is taking so long to be fixed.

    For users with lots of gear connected to midi I recommend to use a midi patch-bay like the MOTU series of midi patch-bays. Others are the M-audio midisport interfaces. Or the iConnectivity iConnect interfaces which some of them have extra audio pass through functions. Or the Midi Solution midi interfaces.

    For midi debugging purposes I recommend the MIDIOX tool and for Mac users Midi monitor. Maybe someone can pinpoint the exaxt cause of the problem with Maschine Midi implementation.
     
  3. lethal_pizzle

    lethal_pizzle NI Product Owner

    Messages:
    10,599
    The hardware works fine on OSX
     
    • Like Like x 1
  4. 44FORGE

    44FORGE Forum Member

    Messages:
    65
    Hi and thank you for the recommendation!
    Unfortunately I could only find Mac setup videos on YouTube which show some details about the motu's. Can you confirm that getting one of there will make it possible to have only one midi out enabled in maschine but route further channels in a motu application?
    I am asking because I am not lacking of midi ports, it's just that I could only enable one of the outputs until this is fixed.
     
  5. 73*

    73* Forum Member

    Messages:
    355
    I was using a Motu MIDI Express XT (I'm selling it, PM me if anyone is interested), and the bug was present. In fact I don't use typically use the MIDI port on my Maschine HW. Therefore I highly doubt that the issue is related to the Machine HW.
     
  6. CakeAlexS

    CakeAlexS NI Product Owner

    Messages:
    5,427
    If the hardware works under Apple it should work under windows bottom line.
     
  7. b-righteous

    b-righteous Moderator Moderator

    Messages:
    9,673
    @44FORGE, Did not follow your link yet but I can tell you the bug does not exist on MAC whatsoever and the disable time stamp on Windows reg fix eliminates the issue entirely. The fact that you still have issues after applying the reg fix and on MAC suggest this is a problem with your midi routing or other issues in your system. The same issue can be caused if you rout incorrectly and create a midi feedback loop. But your current issue is not related to the bug described in this thread even though the symptoms seem the same.
     
    Last edited: Aug 17, 2015
    • Informative Informative x 1
  8. b-righteous

    b-righteous Moderator Moderator

    Messages:
    9,673
    As I suspected. Start a new thread in the technical area and I will move the relevant comments there.
     
  9. 44FORGE

    44FORGE Forum Member

    Messages:
    65
  10. b-righteous

    b-righteous Moderator Moderator

    Messages:
    9,673
    Relevant post moved.
     
  11. CakeAlexS

    CakeAlexS NI Product Owner

    Messages:
    5,427
    OP's issue fixed on 2.3.1?
     
  12. CakeAlexS

    CakeAlexS NI Product Owner

    Messages:
    5,427
    Weird, I tried to repro it in 2.3.0 again and I could not...
    Now upgrading to 2.3.1
     
  13. CakeAlexS

    CakeAlexS NI Product Owner

    Messages:
    5,427
    Backpeddle - just got it in 2.3.1 I think :mad:.
     
  14. b-righteous

    b-righteous Moderator Moderator

    Messages:
    9,673
    This issue was not on the fix list. Still present afaik.

    Wonder if the issue happens under Windows 10?
     
  15. CakeAlexS

    CakeAlexS NI Product Owner

    Messages:
    5,427
    Hunch is it will be exactly the same as other software works...
     
  16. andow

    andow New Member

    Messages:
    26
    I just installed the 2.3.1 update, hung notes after one minute of playing....:thumbsdown:
     
  17. uncle sem

    uncle sem New Member

    Messages:
    6
    same here, still . . . . . . . . . .
     
  18. lethal_pizzle

    lethal_pizzle NI Product Owner

    Messages:
    10,599
    The situation has not changed. The Windows OS MIDI implementation is buggy and you've basically got the choice of using a single hardware port with timestamping enabled or multiple ports with timestamping disabled (and resultant jitter) by changing the registry as per this previous post from Mr36.

    https://www.native-instruments.com/...ut-bug-still-there.230214/page-2#post-1407669

    I don't think there are going to be any further improvements NI's end in this respect although I don't understand why they don't integrate the Timestamping feature into the preferences directly.
     
  19. CakeAlexS

    CakeAlexS NI Product Owner

    Messages:
    5,427
    Thanks...
    So why do DAW's and other software using MIDI out work perfectly well in windows ?
    This sure looks a big fat bug to me anyway..
     
    • Like Like x 2
  20. andow

    andow New Member

    Messages:
    26
    Changing the registry and disabling midi time stamping with the registry file supplied by the support seems to do the trick. However, I am really concerned that this will screw up my midi timing and accuracy.... I didn't have time to do some tests yet, however.
    Can someone enlighten me what this registry file really does? Is midi time stamping only disabled for maschine or on my whole system?
    I now realize I rushed a little by just executing this registry file without questioning it!