Not possible to install X1 driver on macOS Catalina (10.15.4)

Discussion in 'KONTROL X1' started by Jan Boekel, May 22, 2020.

  1. Jan Boekel

    Jan Boekel New Member

    Messages:
    2
    Hi,

    I currently have quite an old Macbook Pro (2012) running macOS Catalina (10.15.4) and two X1 controllers. The controllers lit up when inserting the USB cable but after that stay turned off. I tried installing the drivers but the ones with the latest macOS support are for Mac OS X 10.9 - 10.11 (I currently have 10.15.4). I tried to downgrade my macOS but Apple doesn't really support that very much.

    Does NI really not support later versions when using Macbook? Is there no other way then downgrading your operating system (which I think is quite tough)? Would be very interested to hear any kind of easier solution.

    Thanks,
    Jan

    Schermafbeelding 2020-05-22 om 19.37.35.png Schermafbeelding 2020-05-22 om 19.38.46.png Schermafbeelding 2020-05-22 om 22.24.43.png
     
  2. ChrisSei

    ChrisSei New Member

    Messages:
    1
    Hi,

    if you are a bit familiar with the Terminal/Console, you can install it manually

    here is the howto: https://seidlitz.it/#id=3

    i know the X1 MK1 is working with Catalina. on my Mac mini (Updated from 10.12 or 10.13) to 10.14 and now 10.15.5 it is working fine.
    i analyzed what the driver is installing. so it is only the KEXT-File (Driver). and it is registeredd to the system. Only Copy the Kext is not working.

    WHY: I wanted to use it with my new Macbook Pro 2019. I'm not a fan of artificial obsolescence
     
    • Like Like x 3
  3. djaytek

    djaytek NI Product Owner

    Messages:
    50
    Thanks for the solution Chris. I wonder why NI prevents us using X1 MK1 driver on Catalina while it is somehow working with another solution. Is it security issue or stability issue with Catalina? If there is a known stability issue, I will use it with caution.
     
  4. olafmol

    olafmol NI Product Owner

    Messages:
    646
    Thats AWESOME Chris! Will this also work for the X1 mk2, and possibly even for the Audio4DJ soundcard?
     
  5. Brian Hurley

    Brian Hurley New Member

    Messages:
    1
    To add to the above, if you get an error copying files to driver directories, you will need to disable system integrity protection (SIP) using Recovery Mode. Reboot the mac, and hold down command+r until the Apple logo appears. Start the terminal and type:
    csrutil status (it will show enabled)
    csrutil disable
    reboot

    After doing the above, it should work, but Traktor may not see the X1 after a reboot. If this happens, you will need to rebuilt the kext cache:
    sudo touch /Library/Extensions
    reboot to rebuilt the cache

    If you want, you can reenable SIP in Recovery Mode by typing csrutil enable and rebooting. Be sure to test again, but it worked for me after did this.

    Always test your system after mac os updates. :)
     
  6. Cairn

    Cairn New Member

    Messages:
    1
    First - Thank you SO much for the solution. Don't know how I feel now that the SIP is disabled but, at least the equipment works.

    NI - The X1/MK1 is just trash now? That's really terrible. How is what is, in essence, a midi controller just useless? I find it hard to believe that it would be that difficult to create a Catalina-compatible driver.
     
    • Like Like x 1
  7. feri77

    feri77 New Member

    Messages:
    1
    Dear Chris,

    Many thanks for your solution, it worked and saved me to purchase X1 mk2s :)

    Just a quick add, in order to update

    NIUSBTraktorKontrolX1.kext to

    /Library/StagedExtensions/Library/Extensions

    we have to change the System Integrity Protection (SIP) on Catallina, otherwise you cannot move or paste .kext file.

    In order to do this,
    • Click the  menu. Select Restart...
    • Hold down command-R to boot into the Recovery System.
    • Click the Utilities menu and select Terminal.
    • Type csrutil disable and press return.
    • Close the Terminal app. Click the  menu and select Restart....
    If you decide later you want to re-engage SIP (and I earnestly hope that you do), repeat these steps, use csrutil enable instead.


    Thank you again!

    (My system was MB Pro 2012 Mid 2012, Catallina 10.17, Traktor Pro 3.4, 2 x Kontrol X1 Mk1.)